+ Post New Thread
Page 3 of 4 FirstFirst 1234 LastLast
Results 31 to 45 of 50
How do you do....it? Thread, live@edu and ILM to sync passwords in Technical; Is all this correct? C:\Users\Administrator>setspn.exe -L OLsync Registered ServicePrincipalNames for CN=OLSync,CN=Users,DC=adtest,DC=**** PCNSCLNT/DCTEST.ADTEST.****.EDU C:\Program Files\Microsoft Password Change Notification>pcnscfg.exe -LIST The service ...
  1. #31

    Join Date
    Apr 2010
    Location
    Oahu
    Posts
    16
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Is all this correct?

    C:\Users\Administrator>setspn.exe -L OLsync
    Registered ServicePrincipalNames for CN=OLSync,CN=Users,DC=adtest,DC=****
    PCNSCLNT/DCTEST.ADTEST.****.EDU


    C:\Program Files\Microsoft Password Change Notification>pcnscfg.exe -LIST
    The service configuration is not set. Defaults will be used by the servic

    Default Service Configuration
    MaxQueueLength........: 0
    MaxQueueAge...........: 259200 seconds
    MaxNotificationRetries: 0
    RetryInterval.........: 60 seconds

    Targets
    Target Name...........: PCNSCLNT
    Target GUID...........: 9C3B135D-1B14-4666-949D-41AACC3EE2BC
    Server FQDN or Address: DCTEST.ADTEST.****.EDU
    Service Principal Name: PCNSCLNT/DCTEST.ADTEST.****.EDU
    Authentication Service: Kerberos
    Inclusion Group Name..: ADTEST\Domain Users
    Exclusion Group Name..:
    Keep Alive Interval...: 0 seconds
    User Name Format......: 3
    Queue Warning Level...: 0
    Queue Warning Interval: 30 minutes
    Disabled..............: False

    Total targets: 1

    C:\Program Files\Microsoft Password Change Notification>

    Is seems that ILM doesn't like me!

  2. #32

    RabbieBurns's Avatar
    Join Date
    Apr 2008
    Location
    Sydney
    Posts
    5,531
    Thank Post
    1,341
    Thanked 470 Times in 307 Posts
    Blog Entries
    6
    Rep Power
    200
    Yep that looks good to me.

    What errors are you getting now / Where is it going wrong?

  3. #33

    Join Date
    Apr 2010
    Location
    Oahu
    Posts
    16
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Well that is the funny part I do not get errors I just can't get the password to sync. At this point I'm thinking that ILM is not configured right, even though I followed the instructions and check all the checkbox that they told me to. Tomorrow I'll send you the screen shot of the ILM settings.
    Thanks Pal.

    Manu
    Last edited by ManuPug; 29th April 2010 at 02:22 AM.

  4. #34

    RabbieBurns's Avatar
    Join Date
    Apr 2008
    Location
    Sydney
    Posts
    5,531
    Thank Post
    1,341
    Thanked 470 Times in 307 Posts
    Blog Entries
    6
    Rep Power
    200
    How you getting on did you get it sorted?

  5. #35

    Join Date
    Apr 2010
    Location
    Oahu
    Posts
    16
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    I noticed through verbose logging that my Pass Sync was using the wrong target, but the password is still not working. I am still trying to figure it out. Thanks

    Manu

  6. #36

    Join Date
    Apr 2010
    Location
    Oahu
    Posts
    16
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    I have been setting things here and there and I managed to have the domain controller to give me the message that the password has been delivered to all targets, but on the ILM Server I get from the event viewer these messages:
    "The management agent "Hosted" completed run profile "Delta Import (Stage Only)" with a delta import or delta synchronization step type. The rules configuration has changed since the last full synchronization.

    User Action
    To ensure the updated rules are applied to all objects, a run with step type of full synchronization should be completed."

    for MIIS and this for OLMA:
    "The following error occurred while reporting client data. The root cause may be that the server has not been upgraded to the latest version. Error: System.Management.Automation.RemoteException: A parameter cannot be found that matches parameter name 'ClientData'.
    at System.Management.Automation.PowerShell.CoreInvoke[TOutput](IEnumerable input, PSDataCollection`1 output, PSInvocationSettings settings)
    at System.Management.Automation.PowerShell.Invoke[T](IEnumerable input, IList`1 output, PSInvocationSettings settings)
    at System.Management.Automation.PowerShell.Invoke[T](IEnumerable input)
    at Microsoft.PowerShell.HostingTools.PowerShellProxy. InternalInvoke[T]()
    at Microsoft.PowerShell.HostingTools.PipelineProxyBas e.Invoke[T]()
    at Microsoft.Exchange.XmaConnector.ElmaPSCommand.Invo ke()
    at Microsoft.Exchange.XmaConnector.PSDataProvider.Inv okeCmdlet(PSCommand cmd)
    at Microsoft.Exchange.XmaConnector.PSDataProvider.Rep ortScorecard()
    "
    Have you seen anything like this? Let me know.

    Manu

  7. #37

    Join Date
    Apr 2010
    Location
    Oahu
    Posts
    16
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    SON OF B@#%$!! WORKS!!
    Thanks anyway man! I found out that the error message is negligible.
    Cheers.

    Manu

  8. #38

    RabbieBurns's Avatar
    Join Date
    Apr 2008
    Location
    Sydney
    Posts
    5,531
    Thank Post
    1,341
    Thanked 470 Times in 307 Posts
    Blog Entries
    6
    Rep Power
    200
    Quote Originally Posted by ManuPug View Post
    SON OF B@#%$!! WORKS!!
    Thanks anyway man! I found out that the error message is negligible.
    Cheers.

    Manu
    Nice one!! Glad you got it sorted in the end

  9. #39

    Join Date
    Apr 2009
    Location
    South West, UK
    Posts
    39
    Thank Post
    7
    Thanked 3 Times in 3 Posts
    Rep Power
    12
    Hi Guys, bit of a long shot (I realise this is an old thread).

    I'm having trouble setting up our PCNS solution for our Live@EDU.

    When I configure as per MS instructions and RabbieBurns pdf guide (found in a different thread), I change a password to test and get an error in the event log:

    Code:
    PCNSSVC
    6025
    
    Password Change Notification Service received an RPC exception attempting to deliver notification.
    
    The password change notification target could not be contacted.
    
    User Action: The target server may not be running. Verify that the target server is running.
    Now what I'm slightly confused about during setup is regarding PCNSCLNT. Is this the actual word I use? Or a computer name supposed to go in place of that?

    I hope someone can help me out. Starting to hit my head against a brick wall!

  10. #40

    RabbieBurns's Avatar
    Join Date
    Apr 2008
    Location
    Sydney
    Posts
    5,531
    Thank Post
    1,341
    Thanked 470 Times in 307 Posts
    Blog Entries
    6
    Rep Power
    200
    PCNSCLNT i think can be anything, its not a computer name.

    The computer name comes later in the string when you need to set the spn. Its been a while since I did it, do not sure of ideas a this time of night but will write more in the morning.

    Have you installed the PCNS client on each and every one of your DC's and rebooted them all?

  11. #41

    Join Date
    Apr 2009
    Location
    South West, UK
    Posts
    39
    Thank Post
    7
    Thanked 3 Times in 3 Posts
    Rep Power
    12
    Thanks for the fast response and for clearing up the PCNSCLNT bit!

    Yes, I have it installed on all of my DC's and rebooted them. According to the Event Viewer, the service starts fine; but as soon as I change a password I get errors (as mentioned above).

    I've tried so many different combinations of SPN and PCNS settings, but nothing seems to work! :/

  12. #42

    RabbieBurns's Avatar
    Join Date
    Apr 2008
    Location
    Sydney
    Posts
    5,531
    Thank Post
    1,341
    Thanked 470 Times in 307 Posts
    Blog Entries
    6
    Rep Power
    200
    yeh it was a pain to set up I had to do it a few times before I got it wrong..

    If you run a

    Code:
    pcnscfg.exe -LIST
    can you paste the results ?

  13. #43

    RabbieBurns's Avatar
    Join Date
    Apr 2008
    Location
    Sydney
    Posts
    5,531
    Thank Post
    1,341
    Thanked 470 Times in 307 Posts
    Blog Entries
    6
    Rep Power
    200
    Ill need to have another look at my documentation when I get back to the office in the morning, but the service you account you created for ILM has to be the one you use in the SPN and PCNS command line settings

  14. #44

    RabbieBurns's Avatar
    Join Date
    Apr 2008
    Location
    Sydney
    Posts
    5,531
    Thank Post
    1,341
    Thanked 470 Times in 307 Posts
    Blog Entries
    6
    Rep Power
    200

  15. #45

    Join Date
    Apr 2009
    Location
    South West, UK
    Posts
    39
    Thank Post
    7
    Thanked 3 Times in 3 Posts
    Rep Power
    12
    Sure, I get:

    Code:
    C:\Program Files\Microsoft Password Change Notification>pcnscfg.exe -LIST
    The service configuration is not set. Defaults will be used by the service.
    
    Default Service Configuration
      MaxQueueLength........: 0
      MaxQueueAge...........: 259200 seconds
      MaxNotificationRetries: 0
      RetryInterval.........: 60 seconds
    
    Targets
      Target Name...........: PCNSCLNT
      Target GUID...........: 1A1DFADF-FC93-4716-8A40-492BDE7F3337
      Server FQDN or Address: pcs-billy-01.priory.internal
      Service Principal Name: PCNSCLNT/pcs-billy-01.priory.internal
      Authentication Service: Kerberos
      Inclusion Group Name..: PRIORY\Domain Users
      Exclusion Group Name..:
      Keep Alive Interval...: 0 seconds
      User Name Format......: 3
      Queue Warning Level...: 0
      Queue Warning Interval: 30 minutes
      Disabled..............: False
    
    Total targets: 1
    
    C:\Program Files\Microsoft Password Change Notification>
    pcs-billy-01 is the name of the server running ILM.

SHARE:
+ Post New Thread
Page 3 of 4 FirstFirst 1234 LastLast

Similar Threads

  1. ipod sync to pc
    By layercake426 in forum Windows
    Replies: 8
    Last Post: 22nd July 2011, 07:42 AM
  2. Sync folder
    By irsprint in forum How do you do....it?
    Replies: 5
    Last Post: 14th June 2009, 06:06 PM
  3. How do I... sync
    By matt40k in forum Coding
    Replies: 0
    Last Post: 1st June 2009, 02:28 PM
  4. Kaleidos - sync with anything?
    By theriver in forum Virtual Learning Platforms
    Replies: 3
    Last Post: 9th March 2009, 11:43 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •