+ Post New Thread
Page 1 of 2 12 LastLast
Results 1 to 15 of 23
How do you do....it? Thread, Lego Mindstorms in Technical; I've just had Lego Mindstorms NXT Education dropped on my desk, a full site license. However its the usual problem, ...
  1. #1

    Join Date
    Mar 2007
    Posts
    421
    Thank Post
    14
    Thanked 16 Times in 10 Posts
    Rep Power
    18

    Lego Mindstorms

    I've just had Lego Mindstorms NXT Education dropped on my desk, a full site license.

    However its the usual problem, a site licence that means you can install a single user page across hundreds of PCs!

    Has anyone managed to deploy this across a network? Its around 650Mb so its a fairly big package to deploy automatically.

  2. #2

    Join Date
    May 2009
    Location
    England
    Posts
    264
    Thank Post
    58
    Thanked 36 Times in 35 Posts
    Rep Power
    19
    A job to deploy during summer perhaps? Or if you happen to re-image any suites?

  3. #3

    Join Date
    Mar 2007
    Posts
    421
    Thank Post
    14
    Thanked 16 Times in 10 Posts
    Rep Power
    18
    I was hoping to avoid manual deployment! It takes ages to install as it is

  4. #4

    Join Date
    May 2009
    Location
    England
    Posts
    264
    Thank Post
    58
    Thanked 36 Times in 35 Posts
    Rep Power
    19
    Sorry, when i said deploy i meant as group policy over summer, as though its large, it wouldn't bother anyone over summer?

  5. #5

    Join Date
    Mar 2007
    Posts
    421
    Thank Post
    14
    Thanked 16 Times in 10 Posts
    Rep Power
    18
    Alas, it doesn't come with a proper MSI and a package I created with Wininstall LE failed. Just wondering if anyone had deployed it successfully and using what?

  6. #6

    powdarrmonkey's Avatar
    Join Date
    Feb 2008
    Location
    Alcester, Warwickshire
    Posts
    4,855
    Thank Post
    412
    Thanked 777 Times in 650 Posts
    Rep Power
    181
    We've never yet found a way to deploy this automatically, I've lost count of the number of different ways I've tried and none of the work. It's an odd one.

  7. #7

    Join Date
    Mar 2007
    Posts
    421
    Thank Post
    14
    Thanked 16 Times in 10 Posts
    Rep Power
    18
    Thats the answer I half expected and dreaded!

  8. #8

    russdev's Avatar
    Join Date
    Jun 2005
    Location
    Leicestershire
    Posts
    6,873
    Thank Post
    650
    Thanked 534 Times in 353 Posts
    Blog Entries
    3
    Rep Power
    200
    I have it on my system deploying as msi but trying to remember how I sorted it let me look back through helpdesk I remember it was quite easy to do once sorted final step out.

    Russ

  9. #9

    mattx's Avatar
    Join Date
    Jan 2007
    Posts
    9,229
    Thank Post
    1,056
    Thanked 1,066 Times in 623 Posts
    Rep Power
    739
    I deployed it using Prism Deploy:

    Prism Deploy - Automated Software Deployment from New Boundary

    We have an old version of this which still works but it is quite expensive.

    You could always knock up a install script.....

  10. #10

    russdev's Avatar
    Join Date
    Jun 2005
    Location
    Leicestershire
    Posts
    6,873
    Thank Post
    650
    Thanked 534 Times in 353 Posts
    Blog Entries
    3
    Rep Power
    200
    Here is my notes

    CC3 Instructions used as basis for cc4.

    MAIN SOFTWARE:

    1) Perform the first scan and install the app using the setup.exe file on the CD
    2) DO NOT reboot computer after installation
    3) Perform the second scan
    4) Open msi in msi editor

    Delete "Uninstall LEGO Mindstorms Edu NXT" & "Readme" shortcuts
    Delete all HKCU entries

    Flash Player install needs to be removed from the msi using the following instructions:

    Delete all files in Target Dir "[SystemFolder]\Macromed\Flash\"
    Delete "HKLM\Software\Microsoft\Active Setup" Key

    Click on Registry

    Navigate to HKEY_CLASSES_ROOT\CLSID
    Delete {D27CDB6E-AE6D-11CF-96B8-444553540000}
    Delete {D27CDB70-AE6D-11CF-96B8-444553540000}
    Navigate to HKEY_CLASSES_ROOT\Typelib
    Delete {57A0E746-3863-4D20-A811-950C84F1DB9B}
    Delete {D27CDB6B-AE6D-11CF-96B8-444553540000}

    You will need to save after each individual regkey delete otherwise these just re-appear

    To remove the driver install from the MSI:

    Delete all files from [WindowsVolume]\Config.MsiDelete all Driver files in folder VXIPNP
    Delete "Create Folder" entries for VXIPNP
    Delete HKCR\Installer\Features\8A1A2DB22FA2E064AA3C8E3288 E43B60
    Delete HKCR\Installer\Products\8A1A2DB22FA2E064AA3C8E3288 E43B60
    Delete HKCR\Installer\UpgradeCodes\7632B6917C3C58942B09E7 7A6FD8454B
    Delete HKLM\Software\National Instruments\Common\Installer\Distributions\{996AB8 18-B1E4-4863-9DB3-36E77E47EB5D} _1.0.0.0_9\{2BD2A1A8-2AF2-460E-AAC3-E823884EB306}
    Delete HKLM\Software\Microsoft\Windows\CurrentVersion\Ins taller\Folders\@WinVol\Config.M si
    Delete HKLM\Software\Microsoft\Windows\CurrentVersion\Ins taller\Folders\@WinVol\*VXIPNP
    Delete HKLM\Software\Microsoft\Windows\CurrentVersion\Ins taller\UpgradeCodes\7632B6917C3 C58942B09E77A6FD8454B
    Delete HKLM\Software\Microsoft\Windows\CurrentVersion\Run Once
    Delete HKLM\SYSTEM\CurrentControlSet\Control

    You will need to save after each individual regkey delete otherwise these just re-appear


    DRIVER MSI:

    You only need the msi file from CD. All other mst files are not needed.

    1) Run AppWiz and choose the "add an existing msi" option
    2) Edit msi with ORCA and remove all references to "Disk 1" from Media table and replace with .\

    I had some problems with the install when placed in the folder called v1.0.0.0 but this may be another issue i was having. It will work without this folder structure

    Add the command Dependencies=mainsoftwarename to the ini file.

    Would still fail to download to the brick under anything other than system admin.

    Write Access entry was needed to give everyone full access to VXIPNP folder.
    This is based on work from a guy from RM Communities.

    So will need to use something like WinInstall to do first scan and second scan.

    Then edit msi that is produced with the edits above.

    Russ

  11. #11

    powdarrmonkey's Avatar
    Join Date
    Feb 2008
    Location
    Alcester, Warwickshire
    Posts
    4,855
    Thank Post
    412
    Thanked 777 Times in 650 Posts
    Rep Power
    181
    Quote Originally Posted by mattx View Post
    I deployed it using Prism Deploy:

    Prism Deploy - Automated Software Deployment from New Boundary

    We have an old version of this which still works but it is quite expensive.

    You could always knock up a install script.....
    Hmm, we use Prism packager, just not the deployment tool. Care to share any tips? It just wouldn't work for us.

  12. #12

    Join Date
    Jul 2012
    Location
    South Shields
    Posts
    3
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Red face Mindstorms 2.0 Install method

    The Mindstorms 2.0 package in made up of three parts

    Main program
    Driver for the device
    Visual C++ Runtimes

    These were all MSI within the package downloaded from the Mindstorms website.
    These did not deploy successfully when run separately.

    I had had to repackage the product.
    I ran discover with WIN INSTALL LE (pre shot)
    The main (Standalone installer) Setup program had to be used to install the software.

    I then used The Visual C++ Runtime msi to uninstall this component.
    I then ran the post shot of the computer

    The MSI that was created then is fully deployable
    Deploy the C++ runtimes separately
    Hope this helps
    Thanks
    Adam

  13. #13

    Join Date
    Jan 2009
    Location
    Brighton
    Posts
    2
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Hi Adam,

    fantastic set of instructions.
    unfortunately, it didn't work for me.
    can i ask you about the win install le version that you use to make the msi.
    i am using the 10.10.0010 build 42.48.

    i have the v2.0 mindstorms cd - will this make any difference?

    thanks
    Patricio

  14. #14

    Join Date
    Jul 2012
    Location
    South Shields
    Posts
    3
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Hi Sorry havent been back to you sooner.

    The version I used is 5.1.2600.5512 (older one I know)

    Dont forget to uninstall the C++ runtimes before you run the discover post install shot of the computer.

    I could send you MSI made if you like?

    Thanks

    Adam

  15. #15

    Join Date
    Jan 2009
    Location
    Brighton
    Posts
    2
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Hi Adam,
    Thank you for you replied.
    that will be great - this will stop me going more grey ;-).

    Thanks Patricio

SHARE:
+ Post New Thread
Page 1 of 2 12 LastLast

Similar Threads

  1. [Website] Fun with figures [ Lego ones ]
    By mattx in forum Jokes/Interweb Things
    Replies: 1
    Last Post: 12th June 2009, 12:33 PM
  2. [Video] Stop motion animation of Lego people building the Millennium Falcon
    By mattx in forum Jokes/Interweb Things
    Replies: 2
    Last Post: 12th March 2009, 02:30 PM
  3. Lego : Digital Designer MSI
    By contink in forum Educational Software
    Replies: 5
    Last Post: 3rd July 2008, 05:00 PM
  4. Lego Robotics
    By speckytecky in forum Educational Software
    Replies: 9
    Last Post: 25th September 2006, 04:02 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •