+ Post New Thread
Results 1 to 6 of 6
How do you do....it? Thread, RichProfile in Technical; Hi I am trying to make a vbs login script with richprofile that will automatically configure Outlook for Exchange Server. ...
  1. #1

    FN-GM's Avatar
    Join Date
    Jun 2007
    Location
    UK
    Posts
    16,104
    Thank Post
    891
    Thanked 1,752 Times in 1,511 Posts
    Blog Entries
    12
    Rep Power
    457

    RichProfile

    Hi

    I am trying to make a vbs login script with richprofile that will automatically configure Outlook for Exchange Server. I am using Outlook 2007 and I know for a fact it is compatible.

    This is the code I am using:

    Code:
    objShell.Run "\\fn.local\NETLOGON\BIN\RICHPROFILE FN-EXCHANGE.FN.LOCAL " & strUserName & " email Y D", 0, 0
    But when I open outlook it asks me to pick a profile (the only one listed is the one it makes with the above code) then asks me for the details of the exchange server.

    What am I doing wrong please?

  2. #2
    pooley's Avatar
    Join Date
    Sep 2005
    Location
    S Wales
    Posts
    1,157
    Thank Post
    82
    Thanked 127 Times in 106 Posts
    Rep Power
    68
    Not sure how it works with vb but I have a batch file running

    Code:
    \\server\netlogon\RichProfile.exe server %USERNAME% %USERNAME% N D
    Works for me

  3. #3

    FN-GM's Avatar
    Join Date
    Jun 2007
    Location
    UK
    Posts
    16,104
    Thank Post
    891
    Thanked 1,752 Times in 1,511 Posts
    Blog Entries
    12
    Rep Power
    457
    Quote Originally Posted by pooley View Post
    Not sure how it works with vb but I have a batch file running

    Code:
    \\server\netlogon\RichProfile.exe server %USERNAME% %USERNAME% N D
    Works for me
    That doesn't work for me either

  4. #4

    Join Date
    Aug 2005
    Location
    London
    Posts
    3,157
    Thank Post
    116
    Thanked 529 Times in 452 Posts
    Blog Entries
    2
    Rep Power
    124
    Not used richprofile but you need to have a value "DefaultProfile" at HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Windows Messaging Subsystem\Profiles - can you try setting that value to the name of your profile after you've run richprofile?

  5. #5

    FN-GM's Avatar
    Join Date
    Jun 2007
    Location
    UK
    Posts
    16,104
    Thank Post
    891
    Thanked 1,752 Times in 1,511 Posts
    Blog Entries
    12
    Rep Power
    457
    Ok when I add that to the registry it fixes the profile issue but its still asking for the name of the exchange server. Anyone got any suggestions please?

  6. #6

    Join Date
    Aug 2011
    Posts
    1
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Quote Originally Posted by FN-GM View Post
    Ok when I add that to the registry it fixes the profile issue but its still asking for the name of the exchange server. Anyone got any suggestions please?
    I use version 5 which you can get from RichProfile.com and it works great. It might be worth a try if you are still having this issue.

SHARE:
+ Post New Thread

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •