+ Post New Thread
Page 1 of 3 123 LastLast
Results 1 to 15 of 41
How do you do....it? Thread, DHCP Relay Agent in Technical; Ive just set up the DHCP relay agent on my HP procurve switch and entered the ip addrees of of ...
  1. #1

    Join Date
    May 2008
    Posts
    536
    Thank Post
    18
    Thanked 8 Times in 8 Posts
    Rep Power
    16

    DHCP Relay Agent

    Ive just set up the DHCP relay agent on my HP procurve switch and entered the ip addrees of of our DHCP server for vlan 100 but its not assigning DHCP address. IP routing is enabled on the switch and ive also created a new DHCP scope on the server. VLAN 100 also has an IP address set on the switch. Does any one have any ideas on why DHCP is not giving out IP address for the new range?

    Everything on vlan 1 is fine and picking up an address.

  2. #2

    FN-GM's Avatar
    Join Date
    Jun 2007
    Location
    UK
    Posts
    16,374
    Thank Post
    906
    Thanked 1,811 Times in 1,559 Posts
    Blog Entries
    12
    Rep Power
    468
    Have you setup IP Helpers?

    If you give a static ip to a machine on the other VLAN does everything network wise work?

  3. #3

    Geoff's Avatar
    Join Date
    Jun 2005
    Location
    Fylde, Lancs, UK.
    Posts
    11,850
    Thank Post
    110
    Thanked 598 Times in 514 Posts
    Blog Entries
    1
    Rep Power
    227
    What did the windows server think? Did it issue an IP lease? Anything in the logs on the procurve? Also post your actual config.

  4. #4

    FN-GM's Avatar
    Join Date
    Jun 2007
    Location
    UK
    Posts
    16,374
    Thank Post
    906
    Thanked 1,811 Times in 1,559 Posts
    Blog Entries
    12
    Rep Power
    468
    Have you given the VLAN an IP Address?

  5. #5

    timbo343's Avatar
    Join Date
    Dec 2005
    Location
    Leeds/York area, North Yorkshire
    Posts
    3,198
    Thank Post
    321
    Thanked 314 Times in 219 Posts
    Rep Power
    125
    Have you given the DHCP server the default gateway address of vlan100

  6. #6

    Join Date
    May 2008
    Posts
    536
    Thank Post
    18
    Thanked 8 Times in 8 Posts
    Rep Power
    16
    Quote Originally Posted by FN-GM View Post
    Have you setup IP Helpers?

    If you give a static ip to a machine on the other VLAN does everything network wise work?
    Yes it does.

  7. #7

    Join Date
    May 2008
    Posts
    536
    Thank Post
    18
    Thanked 8 Times in 8 Posts
    Rep Power
    16
    The VLAN does have an ip address in the same range as the new DHCP scope and yes the DG is the ip address of vlan 100

  8. #8

    timbo343's Avatar
    Join Date
    Dec 2005
    Location
    Leeds/York area, North Yorkshire
    Posts
    3,198
    Thank Post
    321
    Thanked 314 Times in 219 Posts
    Rep Power
    125
    Not too sure if this helps... but i have got my 1 DHCP server working and giving out IP addresses through VLANs

    Code:
    Running configuration:
    
    ; J8770A Configuration Editor; Created on release #L.11.20
    
    hostname "ProCurve Switch 4204vl"
    snmp-server contact "xxxx"
    snmp-server location "xxxx"
    max-vlans 256
    module 1 type J8768A
    module 2 type J9033A
    module 3 type J9033A
    module 4 type J9033A
    ip default-gateway 172.16.24.8
    ip routing
    snmp-server community "public" Unrestricted
    vlan 1
       name "DEFAULT_VLAN"
       untagged A1,A3-A24,B1-B24,C1-C24,D1-D24
       ip address 172.16.24.24 255.255.248.0
       ip helper-address 172.16.24.4
       no untagged A2
       ip igmp
       exit
    vlan 2
       name "Staff-BYOD"
       untagged A2
       ip address 192.168.12.1 255.255.252.0
       ip helper-address 172.16.24.4
       tagged A1,A3-A4,A9,A11,A14
       exit
    vlan 3
       name "Stu-BYOD"
       ip address 192.168.16.1 255.255.248.0
       ip helper-address 172.16.24.4
       tagged A1,A3-A4,A9,A11,A14
       exit
    vlan 4
       name "Guests_BYOD"
       ip address 192.168.24.1 255.255.255.0
       ip helper-address 172.16.24.4
       tagged A3-A4,A9,A11,A14
       exit
    ip route 0.0.0.0 0.0.0.0 172.16.24.8
    spanning-tree

  9. #9

    FN-GM's Avatar
    Join Date
    Jun 2007
    Location
    UK
    Posts
    16,374
    Thank Post
    906
    Thanked 1,811 Times in 1,559 Posts
    Blog Entries
    12
    Rep Power
    468
    You will need an IP Helper Address just like the config above.

  10. #10

    Join Date
    May 2008
    Posts
    536
    Thank Post
    18
    Thanked 8 Times in 8 Posts
    Rep Power
    16
    I have an ip helper address on my DHCP server on VLAN100 of the switch. Would the default gateway on the DHCP server need to that of the vlan 1 IP adresss where the DHCP server sits?

  11. #11

    timbo343's Avatar
    Join Date
    Dec 2005
    Location
    Leeds/York area, North Yorkshire
    Posts
    3,198
    Thank Post
    321
    Thanked 314 Times in 219 Posts
    Rep Power
    125
    My DHCP server settings are:

    IP: 172.16.24.4
    Subnet: 255.255.248.0
    D GW: 172.16.24.24

    DNS1: 172.16.24.5
    DNS2: 172.16.24.3

  12. #12

    FN-GM's Avatar
    Join Date
    Jun 2007
    Location
    UK
    Posts
    16,374
    Thank Post
    906
    Thanked 1,811 Times in 1,559 Posts
    Blog Entries
    12
    Rep Power
    468
    Would the default gateway on the DHCP server need to that of the vlan 1 IP adresss where the DHCP server sits?
    This doesn't need changing.

    Please can you post your HP config up?

  13. #13

    Join Date
    May 2008
    Posts
    536
    Thank Post
    18
    Thanked 8 Times in 8 Posts
    Rep Power
    16
    Running configuration:

    ; J8697A Configuration Editor; Created on release #K.15.07.0008
    ; Ver #02:1b.2f:36

    hostname "SVR-Servers1"
    module 1 type J8702A
    module 2 type J8705A
    module 3 type J8705A
    module 4 type J8702A
    module 6 type J8708A
    interface A1
    no power-over-ethernet
    exit
    interface A2
    no power-over-ethernet
    exit
    interface A3
    no power-over-ethernet
    exit
    interface A4
    no power-over-ethernet
    exit
    interface A5
    no power-over-ethernet
    exit
    interface A6
    no power-over-ethernet
    exit
    interface A7
    no power-over-ethernet
    exit
    interface A8
    no power-over-ethernet
    exit
    interface A9
    no power-over-ethernet
    exit
    interface A10
    no power-over-ethernet
    exit
    interface A11
    no power-over-ethernet
    exit
    interface A12
    no power-over-ethernet
    exit
    interface A13
    no power-over-ethernet
    exit
    interface A14
    no power-over-ethernet
    exit
    interface A15
    no power-over-ethernet
    exit
    interface A16
    no power-over-ethernet
    exit
    interface A17
    no power-over-ethernet
    exit
    interface A18
    no power-over-ethernet
    exit
    interface A19
    no power-over-ethernet
    exit
    interface A20
    no power-over-ethernet
    exit
    interface A21
    no power-over-ethernet
    exit
    interface A22
    no power-over-ethernet
    exit
    interface A23
    no power-over-ethernet
    exit
    interface A24
    no power-over-ethernet
    exit
    interface C1
    no power-over-ethernet
    exit
    interface C2
    no power-over-ethernet
    exit
    interface C3
    no power-over-ethernet
    exit
    interface C4
    no power-over-ethernet
    exit
    interface C5
    no power-over-ethernet
    exit
    interface C6
    no power-over-ethernet
    exit
    interface C7
    no power-over-ethernet
    exit
    interface C8
    no power-over-ethernet
    exit
    interface C9
    no power-over-ethernet
    exit
    interface C10
    no power-over-ethernet
    exit
    interface C11
    no power-over-ethernet
    exit
    interface C12
    no power-over-ethernet
    exit
    interface C13
    no power-over-ethernet
    exit
    interface C14
    no power-over-ethernet
    exit
    interface C15
    no power-over-ethernet
    exit
    interface C16
    no power-over-ethernet
    exit
    interface C17
    no power-over-ethernet
    exit
    interface C18
    no power-over-ethernet
    exit
    interface C19
    no power-over-ethernet
    exit
    interface C20
    no power-over-ethernet
    exit
    interface D1
    no power-over-ethernet
    exit
    interface D2
    no power-over-ethernet
    exit
    interface D3
    no power-over-ethernet
    exit
    interface D4
    no power-over-ethernet
    exit
    interface D5
    no power-over-ethernet
    exit
    interface D6
    no power-over-ethernet
    exit
    interface D7
    no power-over-ethernet
    exit
    interface D8
    no power-over-ethernet
    exit
    interface D9
    no power-over-ethernet
    exit
    interface D10
    no power-over-ethernet
    exit
    interface D11
    no power-over-ethernet
    exit
    interface D12
    no power-over-ethernet
    exit
    interface D13
    no power-over-ethernet
    exit
    interface D14
    no power-over-ethernet
    exit
    interface D15
    no power-over-ethernet
    exit
    interface D16
    no power-over-ethernet
    exit
    interface D17
    no power-over-ethernet
    exit
    interface D18
    no power-over-ethernet
    exit
    interface D19
    no power-over-ethernet
    exit
    interface D20
    no power-over-ethernet
    exit
    interface D21
    no power-over-ethernet
    exit
    interface D22
    no power-over-ethernet
    exit
    interface D23
    no power-over-ethernet
    exit
    interface D24
    no power-over-ethernet
    exit
    ip routing
    vlan 1
    name "DEFAULT_VLAN"
    untagged A1-A8,A10-A24,B1-B24,C1-C24,D1-D24,F1-F4
    ip address 10.43.113.73 255.255.248.0
    no untagged A9
    exit
    vlan 100
    name "BYOD"
    untagged A9
    ip helper-address 10.43.112.4
    ip address 10.74.220.5 255.255.254.0
    tagged B24,F1
    exit
    power-over-ethernet pre-std-detect
    no ip ssh
    interface F1
    flow-control
    exit
    snmp-server community "public" unrestricted
    snmp-server host 10.43.112.12 community "public"
    snmp-server host 10.43.115.40 community "public"
    snmp-server location "Server Room"
    password manager
    password operator

  14. #14

    FN-GM's Avatar
    Join Date
    Jun 2007
    Location
    UK
    Posts
    16,374
    Thank Post
    906
    Thanked 1,811 Times in 1,559 Posts
    Blog Entries
    12
    Rep Power
    468
    What is the IP address of 10.43.112.4? I assume its not your DHCP server as it doesn't fall into the same range as the devices in VLAN 1. Does the DHCP server live in VLAN 1?
    Last edited by FN-GM; 12th February 2013 at 02:54 PM.

  15. #15

    Join Date
    May 2008
    Posts
    536
    Thank Post
    18
    Thanked 8 Times in 8 Posts
    Rep Power
    16
    Quote Originally Posted by FN-GM View Post
    What is the IP address of 10.43.112.4? I assume its not your DHCP server as it doesn't fall into the same range as the devices in VLAN 1. Does the DHCP live in VLAN 1?
    Its in the same subnet and its the dhcp server.



SHARE:
+ Post New Thread
Page 1 of 3 123 LastLast

Similar Threads

  1. forcing dhcp renew across network
    By russdev in forum Windows
    Replies: 19
    Last Post: 7th October 2005, 11:47 AM
  2. 2 DHCP Scopes One Network 2 Schools
    By nuttygeek in forum Wireless Networks
    Replies: 31
    Last Post: 3rd October 2005, 08:44 PM
  3. VPN +DHCP
    By Dos_Box in forum Wireless Networks
    Replies: 7
    Last Post: 30th September 2005, 02:14 AM
  4. DHCP
    By kingswood in forum Wireless Networks
    Replies: 10
    Last Post: 7th September 2005, 07:29 AM
  5. how to do dhcp and isaserver
    By browolf in forum Windows
    Replies: 7
    Last Post: 28th June 2005, 10:20 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •