+ Post New Thread
Results 1 to 14 of 14
How do you do....it? Thread, Updating the Grandstream GXP-2000 VOIP phone easily in Technical; Right, I had a slight issue with the fact that the 32 GXP-2000 phones we bought for school came with ...
  1. #1

    localzuk's Avatar
    Join Date
    Dec 2006
    Location
    Minehead
    Posts
    17,697
    Thank Post
    516
    Thanked 2,455 Times in 1,899 Posts
    Blog Entries
    24
    Rep Power
    833

    Updating the Grandstream GXP-2000 VOIP phone easily

    Right, I had a slight issue with the fact that the 32 GXP-2000 phones we bought for school came with various versions of firmware on them. This caused no end of problems such as switches ignoring packets with corrupt 802.1p information in them (courtesy of various firmware itterations).

    So, I decided that the entire lot needed an upgrade, and this is how I did it.

    First, I set up a web server with a subdirectory of 'gs'.

    Then, I collected all the MAC addresses of the devices and their locations, and the speed dial key details. I then downloaded the Grandstream Configuration Generator from http://www.grandstream.com/configurationtool.html, and the templates also.

    I then went through and generated a config file for every phone - remembering to not add a 802.1p priority value. I customised the firmware and configuration file server settings to the local server address - you should do the same.

    Now, here's the bit that counts -

    Download and place the latest firmware from either grandstream.com or from http://www.grandstreamsucks.com/ (where I got it from) and unzip its contents into that directory.

    Also, place the configuration files you generated earlier in that same directory.

    Ensure you have a DHCP server set up from which all the phones can get IP addresses and ensure they are informed of your DNS server address also.

    On your DNS server, add a new zone titled 'grandstream.com' and add an A record of fm.grandstream.com to point to your web server.

    Go round each phone and force a factory reset. Each phone will now download the latest firmware and configuration file from your server, instead of the usually unreachable grandstream one. They will reboot a few times and voila they are done.

    Now, if you wish to enable 802.1p, you should alter your template files and add the priority value in, then regenerate the config files, copy them to your server and unplug/re-plug in the phones. They will download the new config file, reboot and you are done.

    You can remove the DNS zone from above now, as they should all be collecting the data from your local web server now.

  2. #2

    Join Date
    Oct 2007
    Posts
    8
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Re: Updating the Grandstream GXP-2000 VOIP phone easily

    hi there,

    were you able to actually set a P87 value for 802.1p priority value?

    any time i set it to other then 0, the phone restarts and just sits there saying "STARTING NETWORK"

    I think have to factory reset and start over.

    any ideas?

  3. #3

    localzuk's Avatar
    Join Date
    Dec 2006
    Location
    Minehead
    Posts
    17,697
    Thank Post
    516
    Thanked 2,455 Times in 1,899 Posts
    Blog Entries
    24
    Rep Power
    833

    Re: Updating the Grandstream GXP-2000 VOIP phone easily

    Yes, I now have 40 of these working just fine. You can only set the P87 value once you have updated the firmware to the latest version from here.

    If you set the P87 value on any older firmware, the phone locks up or the system ends up being ignored by switches due to bad packets.

    What version of the firmware are you currently using? Also, what value are you trying to set?

  4. #4

    Join Date
    Oct 2007
    Posts
    8
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Re: Updating the Grandstream GXP-2000 VOIP phone easily

    thanks for the reply. I have been trying to set it to 6 or perhaps i will use 5. I understand that 5 is usually for voice traffic if the reference stuff i have found it right. I have tried this with many version of the firmware where i set it via the web interface including 1.1.4.14 and 1.1.4.18 and the beta 1.1.5.3

    I will try again via cfg file using the firmward version you linked to.

    camber

  5. #5

    localzuk's Avatar
    Join Date
    Dec 2006
    Location
    Minehead
    Posts
    17,697
    Thank Post
    516
    Thanked 2,455 Times in 1,899 Posts
    Blog Entries
    24
    Rep Power
    833

    Re: Updating the Grandstream GXP-2000 VOIP phone easily

    I linked to the firmware page which lists 1.1.4.18 as the latest stable release - which is what I am using. If you have upgraded to 1.1.5.3, I don't know if you'll be able to downgrade...

    I'll have a look at work tomorrow to see what I actually did set it to.

  6. #6

    localzuk's Avatar
    Join Date
    Dec 2006
    Location
    Minehead
    Posts
    17,697
    Thank Post
    516
    Thanked 2,455 Times in 1,899 Posts
    Blog Entries
    24
    Rep Power
    833

    Re: Updating the Grandstream GXP-2000 VOIP phone easily

    Also, check what the phone says it is using firmware-wise via the menu->Status on the unit itself.

  7. #7

    Join Date
    Oct 2007
    Posts
    8
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Re: Updating the Grandstream GXP-2000 VOIP phone easily

    yes, it said 1.1.5.3

    im still having the issue. I think perhaps my router doesnt support the protocol perhaps?

  8. #8

    localzuk's Avatar
    Join Date
    Dec 2006
    Location
    Minehead
    Posts
    17,697
    Thank Post
    516
    Thanked 2,455 Times in 1,899 Posts
    Blog Entries
    24
    Rep Power
    833

    Re: Updating the Grandstream GXP-2000 VOIP phone easily

    That is a possibility - what is the router you are using? Also, what are you trying to connect to? An asterisk server? Linux? GUI or CLI only?

  9. #9

    Join Date
    Oct 2007
    Posts
    8
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Re: Updating the Grandstream GXP-2000 VOIP phone easily

    its asterisk via trixbox. I have tried it on a netgear switch and a dlink router, and a netopia dsl router and got the same results. interesting on the netopia router, i assigned a static ip to the phone, and it appeard to get past the "starting network" screen, but alas, it no longer connected to the trixbox server after i set the TOS to 6.

    so, i dont think its a switch.router issue, but perhaps its with my isp? maybe they dont support it. I will try to call them.

  10. #10

    localzuk's Avatar
    Join Date
    Dec 2006
    Location
    Minehead
    Posts
    17,697
    Thank Post
    516
    Thanked 2,455 Times in 1,899 Posts
    Blog Entries
    24
    Rep Power
    833

    Re: Updating the Grandstream GXP-2000 VOIP phone easily

    Ah, so the server is not on a LAN? It is a distinct possibility that your ISP is causing the trouble here. All my phones are on the same LAN, which I have complete control of.

  11. #11

    Join Date
    Oct 2007
    Posts
    8
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Re: Updating the Grandstream GXP-2000 VOIP phone easily

    the server is on the lan as are the phones. I have tried setting the value on the lan, but i get the problem, so i tried to assign a public ip address to bypass my switch and go straight to the isp router. This also fails.

    so here is what i have tried:

    0. dynamic ip address on phone, connected to switch which is connected to cisco t1 router .. priority value set to 0 .. Phone works fine.

    1. dynamic ip address on phone, connected to switch which is connected to a cisco t1 router. priority value set to 6 ... result .. "starting network" (never gets on network)

    2. static ip address on phone ( from switch pool .. (i.e. 10.0.x.x) ) switch is connect to the t1 router. priority value set to 6.. result .. "gets passed starting network, but never connects to asterisk server" (never gets on network)

    3. Public IP address from T1 router. priority value set to 0 .. phone works fine. connects to asterisk server (also public ip address)

    4. Public IP address from T1 router. priority value set to 6 .. result .. "gets passed starting network, but never connects to asterisk server" (never gets on network)

    5. static Public IP address from Netopia DSL router (different ISP then the T1) priority value set to 6 .. result .. "gets passed starting network, but never connects to asterisk server" (never gets on network)

    6. dynamic ip address from dlink router connected to netopia dsl router (different ISP then the T1) priority value set to 6 .. result .. ""STARTING NETWORK" (never gets on network)

    so, as you can see i dont really have a clue about networks, but i can try stuff. and nothing has worked with either isp, so I am at a loss at this point.

  12. #12

    Join Date
    Oct 2007
    Posts
    8
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Re: Updating the Grandstream GXP-2000 VOIP phone easily

    well it seems that i will give up on 802.1p priority value and try to set the diffserv value instead. From what I can tell it seems that diffserv includes a TOS when you set it. If someone out there can confirm/deny this, that would be awesome.

    However, it seems the gxp2000 default value is 48, but all of the references I can find say that expidited service flag for diffserv is 46 (decimal), so I will try that and hope it is all i need to make sure the voip packets are getting priority.

    (http://www.voip-info.org/wiki/view/DiffServ)

  13. #13

    Join Date
    Oct 2007
    Posts
    8
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Re: Updating the Grandstream GXP-2000 VOIP phone easily

    well, i seem to have gotten diffserv to work. I set the value to 46 ( not the 48 that it defaults to), and using tshark, it reported the following for voice traffic packets coming from my gxp2000

    GNU nano 1.2.4 File: text Modified



    Header length: 20 bytes
    Differentiated Services Field: 0xb8 (DSCP 0x2e: Expedited Forwarding; ECN: 0x00)
    1011 10.. = Differentiated Services Codepoint: Expedited Forwarding (0x2e)
    .... ..0. = ECN-Capable Transport (ECT): 0
    .... ...0 = ECN-CE: 0
    Total Length: 200
    Identification: 0x00d6 (214)
    Flags: 0x00
    0... = Reserved bit: Not set
    .0.. = Don't fragment: Not set
    ..0. = More fragments: Not set
    Fragment offset: 0
    Time to live: 254
    Protocol: UDP (0x11)
    Header checksum: 0x5263 [correct]
    [Good: True]
    [Bad : False]


    So .. I am using a netopia router that supoprted diffserv, and I am going to buy a new switch that supports it (our current one is waay old).

    So next I will just need to figure out how to get the internal asterisk server to send out the packets marked correctly as well, but there seems to be lots of info out there for that.

  14. #14

    Join Date
    Oct 2007
    Posts
    8
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Re: Updating the Grandstream GXP-2000 VOIP phone easily

    well this may have just become a QOS for gxp2000/asterisk thread, but for those interested, I finally got DiffServ working on outbound SIP/RTP related packets from my trixbox/asterisk box. The wierd part, was I was having trouble getting the firewall to work at all. Every time i did a service iptables status, it would return "firewall stopped". Luckily I ran along the following:
    iptables Won't Start

    The iptables startup script expects to find the /etc/sysconfig/iptables before it starts. If none exists, then symptoms include the firewall status always being stopped and the /etc/init.d/iptables script running without the typical [OK] or [FAILED] messages.

    If you have just installed iptables and have never applied a policy, then you will face this problem. Unfortunately, running the service iptables save command before restarting won't help either. You have to create this file.

    [root@bigboy tmp]# service iptables start
    [root@bigboy tmp]#

    [root@bigboy tmp]# touch /etc/sysconfig/iptables
    [root@bigboy tmp]# chmod 600 /etc/sysconfig/iptables

    [root@bigboy tmp]# service iptables start
    Applying iptables firewall rules: [ OK ]
    [root@bigboy tmp]#

    from:
    http://www.linuxhomenetworking.com/w..._Won.27t_Start

    And then i just added the following to my iptables firewall script:

    echo "Load rules for mangle table ..."
    $IPT -t mangle -A POSTROUTING -p udp --sport 5004:5082 -j DSCP --set-dscp-class EF
    $IPT -t mangle -A POSTROUTING -p udp --sport 10000:20000 -j DSCP --set-dscp-class EF

    Im still not 100% sure of those port ranges, but I think they cover SIP/RTP just fine.

    anyway, a tshark inspection of outbound traffic from my server to gxpphones and my VOIP service providers show the following:

    Frame 4 (552 bytes on wire, 552 bytes captured)
    Arrival Time: Oct 26, 2007 10:36:15.055755000
    [Time delta from previous packet: 0.499513000 seconds]
    [Time since reference or first frame: 2.199214000 seconds]
    Frame Number: 4
    Packet Length: 552 bytes
    Capture Length: 552 bytes
    [Frame is marked: False]
    [Protocols in frame: eth:ip:udp:sip]
    Ethernet II, Src: AsustekC_, Dst: Cisco_3c)
    Destination: Cisco_3)
    Address: Cisco_3)
    .... ...0 .... .... .... .... = IG bit: Individual address (unicast)
    .... ..0. .... .... .... .... = LG bit: Globally unique address (factory default)
    Source: AsustekC_4)
    Address: AsustekC_4)
    .... ...0 .... .... .... .... = IG bit: Individual address (unicast)
    .... ..0. .... .... .... .... = LG bit: Globally unique address (factory default)
    Type: IP (0x0800)
    Internet Protocol, Src: [MY SERVER IP]( [MY SERVER IP]), Dst: [MY VOIP PROVIDER IP]([MY VOIP PROVIDER IP])
    Version: 4
    Header length: 20 bytes
    Differentiated Services Field: 0xb8 (DSCP 0x2e: Expedited Forwarding; ECN: 0x00)
    1011 10.. = Differentiated Services Codepoint: Expedited Forwarding (0x2e)
    .... ..0. = ECN-Capable Transport (ECT): 0
    .... ...0 = ECN-CE: 0
    Total Length: 538
    Identification: 0x15a0 (5536)
    Flags: 0x00
    0... = Reserved bit: Not set
    .0.. = Don't fragment: Not set
    ..0. = More fragments: Not set
    Fragment offset: 0
    Time to live: 64
    Protocol: UDP (0x11)
    Header checksum: 0x04df [correct]
    [Good: True]

    hooray.

SHARE:
+ Post New Thread

Similar Threads

  1. How to Message Everyone on the Domain? (easily).
    By roland in forum How do you do....it?
    Replies: 6
    Last Post: 6th June 2007, 10:36 AM
  2. Grandstream GXP-2000 and Asterisk
    By localzuk in forum Wireless Networks
    Replies: 6
    Last Post: 15th May 2007, 03:04 PM
  3. To VOIP or not to VOIP, that is the question
    By localzuk in forum Wireless Networks
    Replies: 10
    Last Post: 11th December 2006, 10:16 AM
  4. Updating SQL question
    By tosca925 in forum Windows
    Replies: 2
    Last Post: 11th October 2005, 10:28 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •