+ Post New Thread
Page 4 of 6 FirstFirst 123456 LastLast
Results 46 to 60 of 81
Home Access Plus+ Thread, [HAP+][v8] - Live Tiles in Projects:; Okay, reverting back to the source control versions and it works really nicely! It does some funny quirky resizing thing ...
  1. #46
    mattgrimley's Avatar
    Join Date
    Jun 2011
    Location
    Bedfordshire
    Posts
    316
    Thank Post
    35
    Thanked 21 Times in 19 Posts
    Blog Entries
    1
    Rep Power
    10
    Okay, reverting back to the source control versions and it works really nicely! It does some funny quirky resizing thing when i change the size of the window (in chrome), but ultimately it does work! lol

    Very nice indeed - back to proper testing now! Is there anything else i should be looking at?

  2. #47
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,477
    Thank Post
    37
    Thanked 485 Times in 417 Posts
    Rep Power
    109
    Ok, my version of HAP has a fixed width layout because of the school site, so that's why I didn't put the resize stuff in before

  3. Thanks to nickbro from:

    mattgrimley (3rd May 2012)

  4. #48
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,477
    Thank Post
    37
    Thanked 485 Times in 417 Posts
    Rep Power
    109
    Here's a question, coloured tiles? YAY or NAY?? The Colour is auto picked depending on the colour of the icon image, which is cached in a XML file as well as in memory. The icons are resized and cached in the app_data folder.

    Attachment 13955Attachment 13956

    Also, loading of thumbnails is slightly improved in this release

  5. #49
    mattgrimley's Avatar
    Join Date
    Jun 2011
    Location
    Bedfordshire
    Posts
    316
    Thank Post
    35
    Thanked 21 Times in 19 Posts
    Blog Entries
    1
    Rep Power
    10
    Well your screenie looks great!

  6. #50
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,477
    Thank Post
    37
    Thanked 485 Times in 417 Posts
    Rep Power
    109
    The new metro icons are available here: https://hap.codeplex.com/SourceContr.../changes/76370

  7. #51
    mattgrimley's Avatar
    Join Date
    Jun 2011
    Location
    Bedfordshire
    Posts
    316
    Thank Post
    35
    Thanked 21 Times in 19 Posts
    Blog Entries
    1
    Rep Power
    10
    Hey Nick,

    I might be jumping the gun (again), but i updated all my code from "source-code" and the icons display a bit funny..

    [HAP+][v8] - Live Tiles-untitled.png

  8. #52
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,477
    Thank Post
    37
    Thanked 485 Times in 417 Posts
    Rep Power
    109
    Odd it should work. The icon needs to be ~/images/icons/metro/xx/yyy.png, which in the UI should get translated to /api/iconcache/64/64/images/icons/metro/xx/yyy.png which actually is ~/app_data/iconcache/yyy-64x64.png

  9. #53
    mattgrimley's Avatar
    Join Date
    Jun 2011
    Location
    Bedfordshire
    Posts
    316
    Thank Post
    35
    Thanked 21 Times in 19 Posts
    Blog Entries
    1
    Rep Power
    10
    hmmm
    The icon loads full size if i enter the URL:
    https: //site.school.lea.sch.uk/beta/images/icons/metro/office/excel.png

    Should I be able to call the resized icon by entering the following, because i get a 404 - File or directory not found:
    https: //site.school.lea.sch.uk/beta/api/iconcache/64/64/images/icons/metro/office/excel.png

    The iconcache folder is empty (with the exception of the placeholder.txt file).
    Have I messed up a permission at some point on my test server? I dont have a physical api folder, but i presume i shouldnt.. right?

    Cheers,
    Matt

    (P.S. My HAP installs havent resized icons for as long as i can remember - i've always resized custom icons to 64x64 before uploading them..)

  10. #54
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,477
    Thank Post
    37
    Thanked 485 Times in 417 Posts
    Rep Power
    109
    Make the icon ~/images/icons/metro/office/excel.png instead of https: //site.school.lea.sch.uk/images/icons/metro/office/excel.png. It may not be iconcache, that was off the top of my head, it's actually api/tiles/icons/64/64/images/icons/metro/office/excel.png

  11. #55
    mattgrimley's Avatar
    Join Date
    Jun 2011
    Location
    Bedfordshire
    Posts
    316
    Thank Post
    35
    Thanked 21 Times in 19 Posts
    Blog Entries
    1
    Rep Power
    10
    Sorry, i wasnt clear - The reference in the config is exactly as you recommend: ~/images/icons/metro/office/excel.png.

    I still get the same errors when i try to load directly the api/tiles/icons/64/64/images/icons/metro/office/excel.png URL..
    Server Error
    404 - File or directory not found.
    The resource you are looking for might have been removed, had its name changed, or is temporarily unavailable.

    There must be something doohicky with my IIS... should i have an API folder in IIS?

  12. #56
    mattgrimley's Avatar
    Join Date
    Jun 2011
    Location
    Bedfordshire
    Posts
    316
    Thank Post
    35
    Thanked 21 Times in 19 Posts
    Blog Entries
    1
    Rep Power
    10
    Hey Nick,
    Thought i'd do a refresh with the SourceCode version as you've been playing with the API stuff more (I was hoping it might kick my back into life, but alas i've broken it more).. I presume i need updated DLL's? As I'm getting an "Object reference not set to an instance of an object" error on logging on..

    Code:
    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code. 
    
    Exception Details: System.NullReferenceException: Object reference not set to an instance of an object.
    
    Source Error: 
    
    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.
    
    Stack Trace: 
    
    
    [NullReferenceException: Object reference not set to an instance of an object.]
       HAP.Web.Controls.Announcement.Page_Load(Object sender, EventArgs e) +50
       System.Web.Util.CalliHelper.EventArgFunctionCaller(IntPtr fp, Object o, Object t, EventArgs e) +24
       System.Web.UI.Control.LoadRecursive() +70
       System.Web.UI.Control.LoadRecursive() +189
       System.Web.UI.Control.LoadRecursive() +189
       System.Web.UI.Control.LoadRecursive() +189
       System.Web.UI.Control.LoadRecursive() +189
       System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +3063
    i'll er...

  13. #57
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,477
    Thank Post
    37
    Thanked 485 Times in 417 Posts
    Rep Power
    109
    You need to update all of the file from source control, as some of the aspx and ascx files have changed, specifically in the ~/controls/ folder.

  14. #58
    mattgrimley's Avatar
    Join Date
    Jun 2011
    Location
    Bedfordshire
    Posts
    316
    Thank Post
    35
    Thanked 21 Times in 19 Posts
    Blog Entries
    1
    Rep Power
    10
    Still not working, sorry to be a pain @nickbro - i did copy all of the files (except the .cs and .csproj files) from the zip but still not working.. i even rebooted the server in case of any odd server-side caching etc.

    I also removed any files not in the zip (excluding the config and dll files), so i may have removed something inadvertently omitted..

    Any other ideas?

    Cheers,
    Matt

    P.S. This is not on my "production server", so my main site remains fully functional!
    Last edited by mattgrimley; 21st May 2012 at 04:39 PM.

  15. #59
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,477
    Thank Post
    37
    Thanked 485 Times in 417 Posts
    Rep Power
    109
    Most of the HAP+ dlls have been updated. The one that your looking for here is HAP.Web.dll. BUt you will also need HAP.BookingSystem, HAP.MyFiles, and HAP.HelpDesk, as well as the new HAP.Web.Configuration

  16. #60
    mattgrimley's Avatar
    Join Date
    Jun 2011
    Location
    Bedfordshire
    Posts
    316
    Thank Post
    35
    Thanked 21 Times in 19 Posts
    Blog Entries
    1
    Rep Power
    10
    Ahh okay mate. My bad. The dll's need to be compiled and my version of c# won't open the files (Visual C# 2010 Express) - I seem to remember it previously opened but wouldnt compile them as a limitation of the express editions anyway.
    I'll wait till proper releases in the future unless i get my mits on a fuller version of VS

    Matt

SHARE:
+ Post New Thread
Page 4 of 6 FirstFirst 123456 LastLast

Similar Threads

  1. HAP+ v8 Feature Requets
    By nickbro in forum Home Access Plus+
    Replies: 121
    Last Post: 17th September 2012, 03:15 PM
  2. [HAP+][v8] My Files
    By nickbro in forum Home Access Plus+
    Replies: 66
    Last Post: 26th February 2012, 05:01 PM
  3. [HAP+][v8] - File Server Resource Management Quota Testers
    By nickbro in forum Home Access Plus+
    Replies: 3
    Last Post: 18th February 2012, 10:07 PM
  4. [HAP+][v8] - Help Documents
    By nickbro in forum Home Access Plus+
    Replies: 11
    Last Post: 6th January 2012, 12:52 AM
  5. poptech being streamed live
    By russdev in forum General Chat
    Replies: 0
    Last Post: 28th September 2005, 07:50 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •