+ Post New Thread
Results 1 to 12 of 12
Home Access Plus+ Thread, 7.10 My Files Error in Projects:; I just upgraded to 7.10 today and everything is working ok with the exception of MyFiles beta. When I go ...
  1. #1

    Join Date
    Apr 2012
    Location
    Iowa
    Posts
    3
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    7.10 My Files Error

    I just upgraded to 7.10 today and everything is working ok with the exception of MyFiles beta. When I go to MyFiles I receive the following error

    Code:
    Server Error in '/HAP' Application.
    
    Parser Error
    
    Description: An error occurred during the parsing of a resource required to service this request. Please review the following specific parse error details and modify your source file appropriately. 
    
    Parser Error Message: Unknown server tag 'hap:LocalResource'.
    
    Source Error: 
    
    
    Line 13: 	<div style="overflow: hidden; clear: both; position: relative; height: 120px" id="myfilesheader">
    Line 14: 		<div class="tiles" style="position: absolute; left: 0; margin-top: 45px;">
    Line 15: 			<a class="button" href="../"><hap:LocalResource StringPath="homeaccessplus" runat="server" Seperator=" " StringPath2="home" /></a>
    Line 16: 		</div>
    Line 17: 		<div class="tiles" style="position: absolute; right: 0; text-align: right; margin-top: 45px;">
    
    Source File: /HAP/MyFiles/default.aspx    Line: 15 
    
    Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.0.30319.1
    Any help would be appreciated.

    Thanks,

    --Beau

  2. #2

    Join Date
    Apr 2012
    Location
    Iowa
    Posts
    3
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Anyone?

  3. #3

    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,691
    Thank Post
    43
    Thanked 560 Times in 468 Posts
    Rep Power
    124
    You haven't edited any HAP+ files have you? Also, what version of HAP+ are you running?

    Check this exists in the web.config file:

    HTML Code:
     <pages>
                <controls>
                    <add assembly="HAP.Web" namespace="HAP.Web.Controls" tagPrefix="hap" />
                </controls>
            </pages>

  4. #4

    Join Date
    Apr 2012
    Location
    Iowa
    Posts
    3
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Quote Originally Posted by nickbro View Post
    You haven't edited any HAP+ files have you? Also, what version of HAP+ are you running?
    No and version 7.10, that I downloaded 4/17 from hap.codeplex.com

    Quote Originally Posted by nickbro View Post
    Check this exists in the web.config file:
    That doesn't exist but I was able to figure out where to add it and it kind of works now.

    The issue now is I'm unable to upload files either via drap and drop or the upload button, it tells me

    Code:
    roper v simmons.docx is an restricted file type
    
    You can only upload
    
     Access Database - *.mdb;*.accdb
     Excel Documents - *.xls;*.xlsx;*.xlt;*.xltx
     HTML Files - *.html;*.htm
     Images - *.jpg;*.gif;*.png;*.bmp;*.jpeg
     Word Documents - *.doc;*.docx;*.dotx;*.dot;*.txt;*.rft;*.pdf
     ZIP Files - *.zip

    --Beau
    Last edited by bhuber; 19th April 2012 at 08:49 PM.

  5. #5

    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,691
    Thank Post
    43
    Thanked 560 Times in 468 Posts
    Rep Power
    124
    Odd, I'll look into it

  6. #6

    Join Date
    Jun 2012
    Posts
    19
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Quote Originally Posted by bhuber View Post
    ...

    The issue now is I'm unable to upload files either via drag and drop or the upload button, it tells me

    Code:
    roper v simmons.docx is an restricted file type
    
    You can only upload
    
     Access Database - *.mdb;*.accdb
     Excel Documents - *.xls;*.xlsx;*.xlt;*.xltx
     HTML Files - *.html;*.htm
     Images - *.jpg;*.gif;*.png;*.bmp;*.jpeg
     Word Documents - *.doc;*.docx;*.dotx;*.dot;*.txt;*.rft;*.pdf
     ZIP Files - *.zip
    --Beau
    Hello,
    I am also experiencing problems with uploading PDF files.
    even though they are allowed, and other file types (e.g. *.doc) upload just fine.
    Any suggestions?

  7. #7

    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,691
    Thank Post
    43
    Thanked 560 Times in 468 Posts
    Rep Power
    124
    Which version of My Files are you using and what version of HAP+ are you running

  8. #8

    Join Date
    Jun 2012
    Posts
    19
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    HAP+ 7.10, downloaded last week, and whatever MyFiles version was included with it... didn't change any files (where can I check what MyFiles version I have?)
    thanks!

  9. #9

    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,691
    Thank Post
    43
    Thanked 560 Times in 468 Posts
    Rep Power
    124
    Does it look like Windows 7, or does it look like Metro? The url, does it say /myfiles/ or /mycomputer.aspx

  10. #10

    Join Date
    Jun 2012
    Posts
    19
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    it looks like Windows 7 and it says /MyFiles (per your recommendation, which made it work to begin with).

  11. #11

    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,691
    Thank Post
    43
    Thanked 560 Times in 468 Posts
    Rep Power
    124
    I think I may of fixed something like this for the v8 release

  12. #12

    Join Date
    Jun 2012
    Posts
    19
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    do you mean MyFiles v.8 or HAP+ v.8? is it available for download?
    thanks!



SHARE:
+ Post New Thread

Similar Threads

  1. My Files and Invalid token error on logon
    By TheScarfedOne in forum Home Access Plus+
    Replies: 13
    Last Post: 20th February 2012, 07:30 PM
  2. Weird can't copy files error
    By mark in forum Windows
    Replies: 6
    Last Post: 16th June 2008, 05:19 PM
  3. Replies: 5
    Last Post: 12th December 2006, 07:06 AM
  4. Gremlins in my file system
    By woody in forum Windows
    Replies: 29
    Last Post: 29th September 2006, 04:35 PM
  5. Replies: 3
    Last Post: 25th September 2006, 01:27 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •