+ Post New Thread
Results 1 to 12 of 12
Home Access Plus+ Thread, Remote Apps in Projects:; Wondering if anyone can help me with this one. I have installed HAP and setup everything using various documents and ...
  1. #1

    Join Date
    Mar 2012
    Posts
    6
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Remote Apps

    Wondering if anyone can help me with this one.

    I have installed HAP and setup everything using various documents and you tube clips, and it all works fantastic.

    I am hoever having problems with remote apps, i wanted to add office to it, but have little knowledge of remote apps.

    I found a couple of microsoft articles and installed ts web access and remote app manger onto my file server, couldn't use the iis server as its also my domain controller. Using app manger i created an .rdp file and copied it to the iis server HAP folder, under a newly created rdweb foldwer

    I have created a new resource with the url ~/hap/rdweb/word.rdp and pointed it to the icon folder

    However when i click on the word icon that apears, i get 404 - File or directory not found. The resource you are looking for might have been removed, had its name changed, or is temporarily unavailable.

    Any ideas where i went wrong or does anyone have some idiot proof instructions i could follow.

    Thanks
    Paul

  2. #2
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,355
    Thank Post
    36
    Thanked 466 Times in 398 Posts
    Rep Power
    105
    You need to add the RDP mime type to IIS so it will distribute it

  3. #3

    Join Date
    Mar 2012
    Posts
    6
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Makes Sense and now works to a fashion

    Like i said i have little experiance of RDP but it is now giving me my hap login box when i click the icon, i enter the details then it opens a remoteapp credientials box to which i have to enter a username and password, is there somewhere i can say use the hap login details

    Thanks in advance

  4. #4
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,355
    Thank Post
    36
    Thanked 466 Times in 398 Posts
    Rep Power
    105
    There should be something under remote apps that says the username for remote apps starts with domain\ (or you can add that as a subtitle).

    The link could point to
    Code:
    javascript://alert('Please use xxx as to start your username');location.href='word.rdp';

  5. #5

    Join Date
    Mar 2012
    Posts
    6
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Thanks Nick

    Is that going to be located in the hapconfig file or somewhere else.

  6. #6
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,355
    Thank Post
    36
    Thanked 466 Times in 398 Posts
    Rep Power
    105
    HAP Setup Page > Home Page > Edit the Remote Apps Group > Enter a SubTitle

  7. #7

    Join Date
    Mar 2012
    Posts
    6
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Nick when you say enter a subtitle is in the target box, also what format would it be, is it \\domain name\

    Thanks

  8. #8
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,355
    Thank Post
    36
    Thanked 466 Times in 398 Posts
    Rep Power
    105
    My remote apps section sub title is
    Code:
    Username for remote apps needs to start with "crickhowell\"

  9. #9

    Join Date
    Mar 2012
    Posts
    6
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Excellent

    It now all works fantastic from within school, however when trying to access the apps from outside the network i get a message unable to read rd gateway server settings, i am now banging my head on the wall.

    Can you assist with this.

  10. #10


    Join Date
    Oct 2006
    Posts
    3,387
    Thank Post
    183
    Thanked 350 Times in 279 Posts
    Rep Power
    147
    Quote Originally Posted by gingerbread View Post
    Excellent

    It now all works fantastic from within school, however when trying to access the apps from outside the network i get a message unable to read rd gateway server settings, i am now banging my head on the wall.

    Can you assist with this.
    What is the gateway settings? Are they valide; point to a publicly accessable address? Unblocked by firewall? DNS?

  11. #11

    Join Date
    Mar 2012
    Posts
    6
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    This is where I think the problem lies, because the RD Gateway Manager does not have any settings, and if i try to connect to either a local or remote gateway I get the same error, unable to read rd gateway server, i have looked this up and all the suggestions are to remove the remote desktop role and reinstall which i have done 3 times. The rd gateway settings for remote app manger is set to automatic, i have also tried entering the rd gateway settings by naming the server but i think it all relates back to not haveing a physical server under the gateway manager. The server is the same one that hap and iis are installed on so all the relevent firewall and dns settings are correct.

  12. #12


    Join Date
    Oct 2006
    Posts
    3,387
    Thank Post
    183
    Thanked 350 Times in 279 Posts
    Rep Power
    147
    Want to post/PM your RDP file so we can have a look? Been working on RDweb and gateway a lot in the last 2 days so am familiar with how it should work

SHARE:
+ Post New Thread

Similar Threads

  1. remote apps problem
    By Uraken in forum Windows Server 2008
    Replies: 3
    Last Post: 28th June 2009, 10:39 PM
  2. Remote App Deployment
    By leo in forum Network and Classroom Management
    Replies: 7
    Last Post: 24th November 2008, 08:44 AM
  3. 2008 Server remote app & rdp dropping
    By garym2000 in forum Windows Server 2008
    Replies: 2
    Last Post: 11th November 2008, 11:40 AM
  4. 2008 TS Remote Apps - 60 second login
    By gjames in forum Windows Server 2008
    Replies: 11
    Last Post: 11th November 2008, 09:50 AM
  5. Remote Apps
    By cookie_monster in forum Windows Server 2008
    Replies: 6
    Last Post: 2nd May 2008, 03:12 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •