+ Post New Thread
Results 1 to 4 of 4
Home Access Plus+ Thread, Error in event logs - thumbnail generation? in Projects:; Hi Nick I seem to be getting quite a few errors appearing in my event logs on the server hosting ...
  1. #1

    Join Date
    Mar 2010
    Location
    Sheffield
    Posts
    37
    Thank Post
    2
    Thanked 1 Time in 1 Post
    Rep Power
    0

    Error in event logs - thumbnail generation?

    Hi Nick

    I seem to be getting quite a few errors appearing in my event logs on the server hosting HAP.

    The error that keeps appearing is:

    Event code: 3005
    Event message: An unhandled exception has occurred.
    Event time: 05/03/2012 17:54:00
    Event time (UTC): 05/03/2012 17:54:00
    Event ID: dcf324c9080a4eb6beba5f8560769446
    Event sequence: 44256
    Event occurrence: 891
    Event detail code: 0

    Application information:
    Application domain: /LM/W3SVC/2/Root/HAP-1-129750811636036986
    Trust level: Full
    Application Virtual Path: /HAP
    Application Path: D:\RMNetwork\RMManage\Web Components\HAP\
    Machine name:

    Process information:
    Process ID: 2056
    Process name: w3wp.exe
    Account name: NT AUTHORITY\NETWORK SERVICE

    Exception information:
    Exception type: NullReferenceException
    Exception message: Object reference not set to an instance of an object.
    at HAP.Web.API.Thumbs.ProcessRequest(HttpContext context) in H:\Documents\Visual Studio 2010\Projects\CHS Extranet\HAP.Web\API\Thumbs.cs:line 75
    at System.Web.HttpApplication.CallHandlerExecutionSte p.System.Web.HttpApplication.IExecutionStep.Execut e()
    at System.Web.HttpApplication.ExecuteStep(IExecutionS tep step, Boolean& completedSynchronously)



    Request information:
    Request URL: https://work2.st-maryshigh.derbyshire.sch.uk:443/HAP/api/mycomputer/thumb/W/olympics460.jpg
    Request path: /HAP/api/mycomputer/thumb/W/olympics460.jpg
    User host address:
    User:
    Is authenticated: True
    Authentication Type: Forms
    Thread account name: NT AUTHORITY\NETWORK SERVICE

    Thread information:
    Thread ID: 24
    Thread account name: NT AUTHORITY\NETWORK SERVICE
    Is impersonating: False
    Stack trace: at HAP.Web.API.Thumbs.ProcessRequest(HttpContext context) in H:\Documents\Visual Studio 2010\Projects\CHS Extranet\HAP.Web\API\Thumbs.cs:line 75
    at System.Web.HttpApplication.CallHandlerExecutionSte p.System.Web.HttpApplication.IExecutionStep.Execut e()
    at System.Web.HttpApplication.ExecuteStep(IExecutionS tep step, Boolean& completedSynchronously)


    Custom event details:

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
    I have tried browsing to the API page for this but receive the following error:

    Server Error in '/HAP' Application.

    Object reference not set to an instance of an object.

    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: System.NullReferenceException: Object reference not set to an instance of an object.

    Source Error:

    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

    Stack Trace:


    [NullReferenceException: Object reference not set to an instance of an object.]
    HAP.Web.API.ThumbsHandler.GetHttpHandler(RequestCo ntext requestContext) in H:\Documents\Visual Studio 2010\Projects\CHS Extranet\HAP.Web\API\Thumbs.cs:30
    System.Web.Routing.UrlRoutingModule.PostResolveReq uestCache(HttpContextBase context) +8948328
    System.Web.Routing.UrlRoutingModule.OnApplicationP ostResolveRequestCache(Object sender, EventArgs e) +86
    System.Web.SyncEventExecutionStep.System.Web.HttpA pplication.IExecutionStep.Execute() +148
    System.Web.HttpApplication.ExecuteStep(IExecutionS tep step, Boolean& completedSynchronously) +75

    Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.0.30319.1

    As far as I can tell - other than not having the icons for images (as it always seems to be a jpg or other image that it is happening on), the only other problem is the amount of entries it keeps putting in the event logs. Do you know how either we can A) Fix it or B) Stop it logging the error?

    Thanks in advance!

    Andy

  2. #2
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,471
    Thank Post
    37
    Thanked 483 Times in 415 Posts
    Rep Power
    109
    I'll look into this

  3. #3

    Join Date
    Mar 2010
    Location
    Sheffield
    Posts
    37
    Thank Post
    2
    Thanked 1 Time in 1 Post
    Rep Power
    0
    Hi Nick

    Have you had any luck with finding the fault here?

    Thanks in advance

    Andy

  4. #4
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,471
    Thank Post
    37
    Thanked 483 Times in 415 Posts
    Rep Power
    109
    Have you tried the latest HAP+ release? I know I put some fixes into one of the 7.1x relases

SHARE:
+ Post New Thread

Similar Threads

  1. Error free Event Logs
    By detjo in forum Windows Server 2008
    Replies: 3
    Last Post: 4th October 2011, 05:04 PM
  2. Logon No IP Address in Event Log?
    By BackCat3 in forum Windows
    Replies: 1
    Last Post: 13th August 2011, 07:40 PM
  3. GPO Error in Event Viewer
    By in forum Windows
    Replies: 4
    Last Post: 2nd October 2008, 01:45 PM
  4. Replies: 5
    Last Post: 11th July 2008, 02:43 PM
  5. ASP.NET in event log
    By kerrymoralee9280 in forum Windows
    Replies: 4
    Last Post: 6th May 2008, 12:49 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •