+ Post New Thread
Results 1 to 5 of 5
Home Access Plus+ Thread, Setting HAP Application Permissions web.config Error - Line 242 in Projects:; Hello, I'm installing HAP onto a vanilla Server 2008 (N.B. Not R2) server with freshly installed .NET4 and IIS7. The ...
  1. #1

    Join Date
    Mar 2007
    Posts
    3
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Question Setting HAP Application Permissions web.config Error - Line 242

    Hello,

    I'm installing HAP onto a vanilla Server 2008 (N.B. Not R2) server with freshly installed .NET4 and IIS7.

    The instructions are very comprehensive, but unfortunately I've encountered a problem. When I've reached the stage "28. Double Click on IIS Authentication" I'm getting an error (picture attached).

    EDIT - post count not high enough to post the attachment. I'll post back with it shortly.

    For future searchability it reads as follows:

    Authentication.

    There was an error while performing this operation,
    Details:
    Filename \\?\C:\inetpub\wwwroot\HAP\web.config
    Line number: 242
    Error: The configuration section 'standardEndpoints' cannot be read because it is missing a section declaration

    I've searched t'internet and found some evidence referring to "nested .NET 2.0 applications" but this isn't the case - all App pools (inc. DefaultAppPool) are configured to use version 4.

    EDIT - links not allowed either, sheesh!

    I'm more familiar with unix these days, and hence a little out of my depth with IIS7 - could anybody suggest what my problem might be?

    N.B. I'm aware that step 21 isn't possible with my version of Windows as the IIS App Pool doesn't show up in the user browser, hence I ran icacls c:\inetpub\wwwroot /grant "IIS APPPOOL\HAP"OI)(CI)(RX) and added the permissions afterwards.

    Thanks in advance.
    Attached Thumbnails Attached Thumbnails Setting HAP Application Permissions web.config Error - Line 242-screen-shot-2012-02-08-11.39.44.png  

  2. #2
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,561
    Thank Post
    38
    Thanked 507 Times in 437 Posts
    Rep Power
    114
    Try replacing the web.config file from one from codeplex. Make sure your using HTTPS. Try removing the SVG line in the web.config as well

  3. #3

    Join Date
    Mar 2007
    Posts
    3
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Quote Originally Posted by nickbro View Post
    Try replacing the web.config file from one from codeplex. Make sure your using HTTPS. Try removing the SVG line in the web.config as well
    Thanks for your response - I'm not sure that I fully understand what you're suggesting though.

    The web.config I'm using is the one from codeplex - a fresh install downloaded as the "7.9 Full" package. I've redownloaded and reinstalled from scratch, too with the same error.

    SSL is being used, and is working correctly. I've created a small test.htm file and when placed I can access it from both [won't let me post links but I type a URL Here]test.htm and also [won't let me post links but I type a URL Here]HAP/test.htm (until I copy all of the HAP+ file sin there of course, after which I get a HTTP 500).

    The only "SVG line" I could find in web.config was this one:

    <mimeMap fileExtension=".svg" mimeType="images/svg+xml" />

    I duly removed it but the error was still there (albeit reported on line earlier - 241).

    I've tried removing and reinstalling .NET4 Extended, too - no difference.

  4. #4

    Join Date
    Mar 2007
    Posts
    3
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Upon further research, when I'm creating the HAP Application pool I'm seeing some strange things...

    Firstly despite me selecting .NET v4 it firstly creates it as v2. When I then go edit it shows v4 selected and pressing OK shows it as v4.

    Under advanced settings --> Identity it displays NetworkService and not AppPoolIdentity. No amount of removing and recreating corrects this...

  5. #5
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,561
    Thank Post
    38
    Thanked 507 Times in 437 Posts
    Rep Power
    114
    You need to overright it, it will default to NetworkService, you just have to click on the three dots ... and choose Application Pool Identity

SHARE:
+ Post New Thread

Similar Threads

  1. Server Error in '/HAP' Application.
    By victory2009 in forum Home Access Plus+
    Replies: 17
    Last Post: 6th June 2012, 01:40 PM
  2. Replies: 19
    Last Post: 20th January 2012, 02:09 PM
  3. Setting up Citrix XenApp Web Interface 403 error issue
    By localzuk in forum Thin Client and Virtual Machines
    Replies: 0
    Last Post: 30th June 2011, 09:28 AM
  4. ubuntu error line 26
    By ful56_uk in forum *nix
    Replies: 2
    Last Post: 8th April 2009, 07:59 AM
  5. Kaleidos Config Errors
    By mikey_tyler in forum Virtual Learning Platforms
    Replies: 0
    Last Post: 17th July 2008, 08:55 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •