+ Post New Thread
Results 1 to 15 of 15
Home Access Plus+ Thread, Getting an error when opening IIS authentication during setup in Projects:; Hi, I am getting an error during the setup. I am on 2008r2 IISv7 and following the video. At the ...
  1. #1

    Join Date
    Apr 2010
    Posts
    2,104
    Thank Post
    95
    Thanked 189 Times in 156 Posts
    Rep Power
    84

    Getting an error when opening IIS authentication during setup

    Hi, I am getting an error during the setup. I am on 2008r2 IISv7 and following the video. At the stage I should be going into IIS authentication I receive the following error.

    There was an error while performing this operation
    Details
    Filename \\?\c:\inetpub\wwwroot\hap\webconfig
    line number 195
    error: the config section 'standardendpoints' cannot be read because it is missing a section declaration

    What should I do?

  2. #2

    Join Date
    Apr 2010
    Posts
    2,104
    Thank Post
    95
    Thanked 189 Times in 156 Posts
    Rep Power
    84
    Think its due to a windows update missing. Just downloading. Ill post back later

  3. #3

    Join Date
    Apr 2010
    Posts
    2,104
    Thank Post
    95
    Thanked 189 Times in 156 Posts
    Rep Power
    84
    I added all the updates but still get the error in first post.

  4. #4

    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,654
    Thank Post
    43
    Thanked 554 Times in 462 Posts
    Rep Power
    122
    Can you rerun the asp.net 4 install please. Are you running HAP+ on an SSL connection, if not you will need to remove some lines from the web.config which I think are the <security mode="transport" />

  5. #5

    Join Date
    Apr 2010
    Posts
    2,104
    Thank Post
    95
    Thanked 189 Times in 156 Posts
    Rep Power
    84
    Just re-installing .net. I am also setting up a new member server vm and will try and get HAP working on that. Does the SSL connection make any difference at this stage, as I am still configuring IIS and not at the stage of browsing to the website.

  6. #6

    Join Date
    Apr 2010
    Posts
    2,104
    Thank Post
    95
    Thanked 189 Times in 156 Posts
    Rep Power
    84
    Re-installing .net has not fixed my issue.

  7. #7

    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,654
    Thank Post
    43
    Thanked 554 Times in 462 Posts
    Rep Power
    122
    Ok, I'm at a loss to why this error is popping up.

    Change

    HTML Code:
     <system.serviceModel>
            <behaviors>
                <serviceBehaviors>
                    <behavior name="">
                        <serviceDebug includeExceptionDetailInFaults="true"/>
                        <serviceMetadata httpGetEnabled="false" httpsGetEnabled="true" />
                    </behavior>
                </serviceBehaviors>
            </behaviors>
            <bindings>
                <webHttpBinding>
                    <binding>
                        <security mode="Transport" />
                    </binding>
                </webHttpBinding>
            </bindings>
            <serviceHostingEnvironment aspNetCompatibilityEnabled="true" multipleSiteBindingsEnabled="true" />
            <standardEndpoints>
                <webHttpEndpoint>
                    <standardEndpoint name="" helpEnabled="true" automaticFormatSelectionEnabled="true" faultExceptionEnabled="true">
                        <security mode="Transport"/>
                    </standardEndpoint>
                </webHttpEndpoint>
            </standardEndpoints>
        </system.serviceModel>
    With

    HTML Code:
     <system.serviceModel>
            <behaviors>
                <serviceBehaviors>
                    <behavior name="">
                        <serviceDebug includeExceptionDetailInFaults="true"/>
                        <serviceMetadata httpGetEnabled="false" httpsGetEnabled="true" />
                    </behavior>
                </serviceBehaviors>
            </behaviors>
            <bindings>
                <webHttpBinding />
            </bindings>
            <serviceHostingEnvironment aspNetCompatibilityEnabled="true" multipleSiteBindingsEnabled="true" />
            <standardEndpoints>
                <webHttpEndpoint>
                    <standardEndpoint name="" helpEnabled="true" automaticFormatSelectionEnabled="true" faultExceptionEnabled="true" />
                </webHttpEndpoint>
            </standardEndpoints>
        </system.serviceModel>

  8. #8

    Join Date
    Apr 2010
    Posts
    2,104
    Thank Post
    95
    Thanked 189 Times in 156 Posts
    Rep Power
    84
    The error has moved to line 191 which is <standardEndpoints>

    Today I setup a new test server so tomorrow I'll put HAP on to it and see what happens, unless you have any other ideas.

  9. #9

    Join Date
    Apr 2010
    Posts
    2,104
    Thank Post
    95
    Thanked 189 Times in 156 Posts
    Rep Power
    84
    Just installing IIS7 onto my new vm server. Should I be leaving all the options as default or should I tick any extra options for HAP to work.

  10. #10

    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,654
    Thank Post
    43
    Thanked 554 Times in 462 Posts
    Rep Power
    122
    Should be all default, except for enabling asp.net, and the authentication methods you want

  11. #11

    Join Date
    Apr 2010
    Posts
    2,104
    Thank Post
    95
    Thanked 189 Times in 156 Posts
    Rep Power
    84
    Install got further on new server but when I browse to server/hap/setup.aspx I get

    Server error in application
    Http error 500.21 internal server error
    handler "pagehandlerfactory-integrated" has a bad block module
    "managed pipelinehandler" in its module list

    Any ideas?

  12. #12

    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,654
    Thank Post
    43
    Thanked 554 Times in 462 Posts
    Rep Power
    122
    1) Check .net 4 full has been installed
    2) Make sure you replicate the .net 4 app pool (not classic)
    3) Have a look on bing/google

  13. #13

    Join Date
    Apr 2010
    Posts
    2,104
    Thank Post
    95
    Thanked 189 Times in 156 Posts
    Rep Power
    84
    Fixed. Went to add remove programs clicked on .net 4 extended and selected to restore defaults.

  14. #14

    Join Date
    Apr 2010
    Posts
    2,104
    Thank Post
    95
    Thanked 189 Times in 156 Posts
    Rep Power
    84
    Sorry to take so much of your time but I have yet another issue. Most of the fields in the setup page have a red X. I cant write anything into the box's either. This includes site name and site address.

    Does this point to a folder security issue or something else.

  15. #15

    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,654
    Thank Post
    43
    Thanked 554 Times in 462 Posts
    Rep Power
    122
    Looks like javascript isn't loading correctly, can you press F12 in IE and look for any errors



SHARE:
+ Post New Thread

Similar Threads

  1. Why an I getting this error?
    By Jobos in forum East Midlands Broadband Consortium (EMBC)
    Replies: 4
    Last Post: 10th December 2010, 12:37 PM
  2. Replies: 4
    Last Post: 16th September 2010, 02:06 PM
  3. Authenticate when opening attachments
    By darrenu in forum Office Software
    Replies: 2
    Last Post: 27th January 2009, 01:02 PM
  4. Replies: 1
    Last Post: 31st August 2008, 04:07 PM
  5. We're getting an Ofsted Inspection
    By pete in forum School ICT Policies
    Replies: 20
    Last Post: 22nd March 2006, 08:35 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •