+ Post New Thread
Page 1 of 9 12345 ... LastLast
Results 1 to 15 of 135
Home Access Plus+ Thread, Basic Help Needed! in Projects:; I recently discovered this project, and it looks great, but I have a few questions about setting it up. I'm ...
  1. #1

    Join Date
    Nov 2010
    Location
    Liverpool, UK
    Posts
    178
    Thank Post
    10
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Basic Help Needed!

    I recently discovered this project, and it looks great, but I have a few questions about setting it up.

    I'm not very competent in coding/websites, so you'll have to bear with my noobish skills in that respect.

    The only features I'm interested in from this project are the Booking System, and the Help Desk. We already have solutions in place for emails, remote access and log trackers. I can nobble the pages so they don't display these features that I don't need, but I'm struggling in other areas of the setup.

    I am currently testing this on my local workstation (administrator computer/user) which is running Windows 7 and IIS 7. (Testing before we implement it on Server 2008R2) The Active Directory Connection is using a working domain admin account.

    1) I have it setup, but in the ~/setup.aspx page, I cannot remove Resources or Management features without the browser popping up and saying "Internal Server Error". (Happens on Chrome (latest), Firefox 8 and IE9.)

    2) The Booking System will not display the calendar in the browser, nothing appears at all. It shows the room, but no dates, so I cannot enter a booking.

    I may add more problems, (more like will!) when I find some, but some help would be great!

  2. #2

    Join Date
    Nov 2011
    Location
    Southampton
    Posts
    23
    Thank Post
    4
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    I haven't used the Booking system yet so can really comment on that but no.1 has been seen several times already. If saving the settings and retrying the delete doesn't work then you can go into the HAP\App_data\hapconfig.xml file directly and remove the relevant lines. Refresh the setup page and the entries should be gone.

  3. #3

    Join Date
    Nov 2010
    Location
    Liverpool, UK
    Posts
    178
    Thank Post
    10
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Ok, I've worked around 1) by manually editing the hapconfig.xml.

    Edit; I'm definitely on the right lines! Now need to sort the booking system.

  4. #4
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,483
    Thank Post
    37
    Thanked 490 Times in 422 Posts
    Rep Power
    110
    If you are experiencing issues with the setup page, you can try the v7.7 alpha build

  5. #5

    Join Date
    Nov 2010
    Location
    Liverpool, UK
    Posts
    178
    Thank Post
    10
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    I think I'll stick with getting this one setup, just as I'm feeling my way around. The setup age I've sorted now, but I'm having problems with the bookings section. The calendar simply will not show. It will display the room(s) down the left, but no dates.

    Edit; Just out of curiosity, how do you update to a newer version without losing all your config/personalised code?
    Last edited by CHiLL; 17th November 2011 at 11:22 AM.

  6. #6
    mattgrimley's Avatar
    Join Date
    Jun 2011
    Location
    Bedfordshire
    Posts
    316
    Thank Post
    35
    Thanked 21 Times in 19 Posts
    Blog Entries
    1
    Rep Power
    10
    Quote Originally Posted by CHiLL View Post
    I think I'll stick with getting this one setup, just as I'm feeling my way around. The setup age I've sorted now, but I'm having problems with the bookings section. The calendar simply will not show. It will display the room(s) down the left, but no dates.

    Edit; Just out of curiosity, how do you update to a newer version without losing all your config/personalised code?
    1> Could you post the "<bookingsystem /bookingsystem>" section from your hapconfig.xml here? We can see if there is something silly in there which is upsetting it..
    Also, post the contents of your TermDates.xml file (also in App_Data) and i can compare it to mine.. could be something simple in there which is stopping it from loading up nicely.. Presuming all that seems fine, can you try in some different browsers? and can you let us know the result for each? Sometimes Firefox or Chrome can give a more useful errror which helps the troubleshooting. (there is also an addon for Firefox called "firebug" which Nick may want info from if we fail to get anywhere with the basic config)

    2> The updates to the program should never contain the xml files from the App_Data folder, so your configuration will always be retained. It is however very good practice to back up the entire HAP folder prior to each upgrade - just in-case! - I just make a zip file before every upgrade and it has been useful more than once!

    Matt

  7. #7

    Join Date
    Nov 2010
    Location
    Liverpool, UK
    Posts
    178
    Thank Post
    10
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Code:
    <bookingsystem maxbookingsperweek="3" maxdays="14" admins="" keepxmlclean="True" twoweektimetable="True">
        <resources>
          <resource name="ICT1" type="Room" admins="" enabled="True" emailadmins="False" enablecharging="False" />
        </resources>
        <lessons />
        <subjects>
          <subject name="General" />
        </subjects>
      </bookingsystem>
    and

    Code:
    <?xml version="1.0" encoding="utf-8"?>
    <Terms>
      <Term name="Autum" startDate="07/08/2011" endDate="16/12/2011" startWeekNum="1">
        <HalfTerm startDate="26/10/2011" endDate="31/10/2011" />
      </Term>
      <Term name="Spring" startDate="04/01/2012" endDate="30/03/2012" startWeekNum="2">
        <HalfTerm startDate="10/02/2012" endDate="17/02/2012" />
      </Term>
      <Term name="Summer" startDate="16/04/2012" endDate="19/07/2012" startWeekNum="1">
        <HalfTerm startDate="01/05/2012" endDate="08/06/2012" />
      </Term>
    </Terms>

  8. #8
    mattgrimley's Avatar
    Join Date
    Jun 2011
    Location
    Bedfordshire
    Posts
    316
    Thank Post
    35
    Thanked 21 Times in 19 Posts
    Blog Entries
    1
    Rep Power
    10
    well you dont have any lessons defined in there by the look of it..

    between </resources> and <subjects>
    add something like:

    <lessons>
    <lesson name="1" type="Lesson" starttime="09:05" endtime="10:05" />
    <lesson name="2" type="Lesson" starttime="10:05" endtime="11:05" />
    <lesson name="3" type="Lesson" starttime="11:25" endtime="12:25" />
    <lesson name="4" type="Lesson" starttime="12:25" endtime="13:25" />
    <lesson name="5" type="Lesson" starttime="14:30" endtime="15:30" />
    </lessons>

    My booking system section looks like:

    Code:
      <bookingsystem maxbookingsperweek="5" maxdays="42" admins="HAP Timetablers" keepxmlclean="True" twoweektimetable="True">
        <resources>
          <resource name="Agency" type="Room" admins="" enabled="True" emailadmins="True" enablecharging="False" />
          <resource name="Bureau" type="Room" admins="" enabled="True" emailadmins="True" enablecharging="False" />
          <resource name="31" type="Room" admins="" enabled="True" emailadmins="True" enablecharging="False" />
        </resources>
        <lessons>
          <lesson name="1" type="Lesson" starttime="09:05" endtime="10:05" />
          <lesson name="2" type="Lesson" starttime="10:05" endtime="11:05" />
          <lesson name="3" type="Lesson" starttime="11:25" endtime="12:25" />
          <lesson name="4" type="Lesson" starttime="12:25" endtime="13:25" />
          <lesson name="5" type="Lesson" starttime="14:30" endtime="15:30" />
        </lessons>
        <subjects>
          <subject name="Art" />
          <subject name="Biology" />
          <subject name="Chemistry" />
          <subject name="Physics" />
          <subject name="Science" />
          <subject name="Photography" />
          <subject name="Design Technology" />
          <subject name="Food Tech" />
          <subject name="BTEC Sport" />
          <subject name="Textiles" />
          <subject name="ICT" />
          <subject name="PE" />
          <subject name="PSHCRE" />
          <subject name="EXAMS" />
          <subject name="Business Studies" />
          <subject name="Film Studies" />
          <subject name="History" />
          <subject name="Geography" />
          <subject name="RE" />
          <subject name="English" />
          <subject name="Latin" />
          <subject name="German" />
          <subject name="French" />
          <subject name="Classical Civilisations" />
          <subject name="SEN" />
          <subject name="Drama" />
          <subject name="Music" />
          <subject name="Maths" />
        </subjects>
      </bookingsystem>

  9. Thanks to mattgrimley from:

    CHiLL (17th November 2011)

  10. #9

    Join Date
    Nov 2010
    Location
    Liverpool, UK
    Posts
    178
    Thank Post
    10
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Oooh, that just makes me feel silly!

    I will populate the file with lessons tomorrow.

    Thanks! (may add more questions when i inevitably get stuck tomorrow)

    Edit; Is this part of the way to link SIMS into it? I know you can, somehow, and it would be amazing if I could. I'm just not that far/advanced in this stuff to understand yet!
    Last edited by CHiLL; 17th November 2011 at 06:14 PM.

  11. #10

    Join Date
    Nov 2010
    Location
    Liverpool, UK
    Posts
    178
    Thank Post
    10
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Having trouble importing from SIMS. I've imported the report, and ran it, and output the file as Timetable.xml into ~/App_Data. It's only produced English rooms, and doesn't know about AD. Any advice?

    Also, I only want this to run for a tiny amount of bookable rooms we have in the school.

  12. #11
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,483
    Thank Post
    37
    Thanked 490 Times in 422 Posts
    Rep Power
    110
    You may need to edit the report to look for more than just the rooms specified. I think I may of forgotten to prompt at run time on that. HAP+ will attempt to match bookings against users in AD, if it can't it wont import the booking

  13. #12

    Join Date
    Nov 2010
    Location
    Liverpool, UK
    Posts
    178
    Thank Post
    10
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    You video suggests v7 (I'm on 7.6) will have a conversion thing for SIMS to HAP. How is that coming along?

    How do I get HAP to understand Week 1 and Week 2 by manually editing it? Is is like SIMS and does HAP understand Day1:1 and Day 2:1 for example?

  14. #13
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,483
    Thank Post
    37
    Thanked 490 Times in 422 Posts
    Rep Power
    110
    There is an automated import method on the static bookings tab of the booking system control panel

  15. #14

    Join Date
    Nov 2010
    Location
    Liverpool, UK
    Posts
    178
    Thank Post
    10
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    I have tired that, but it won't work because of Active Directory names. Is the only way round this manually editing them in? That'd take a while!

    Does HAP also automatically understand two week timetables?

  16. #15
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,483
    Thank Post
    37
    Thanked 490 Times in 422 Posts
    Rep Power
    110
    The names in either the notes or display name need to be Mr Jones, or Mrs S Jones.

    HAP+ should work with a 2 week timetable

SHARE:
+ Post New Thread
Page 1 of 9 12345 ... LastLast

Similar Threads

  1. I need basic help with Thinstaion hard disk deployments.
    By snsweigel in forum Thin Client and Virtual Machines
    Replies: 9
    Last Post: 4th March 2008, 07:44 PM
  2. Replies: 8
    Last Post: 22nd February 2008, 12:34 PM
  3. Help! Need a BIOS re-flashed
    By ajbritton in forum Hardware
    Replies: 2
    Last Post: 28th December 2006, 12:16 PM
  4. Help needed to reconfig my DC's
    By tosca925 in forum Windows
    Replies: 16
    Last Post: 20th November 2006, 10:45 PM
  5. Help needed creating a DMZ
    By pooley in forum Wireless Networks
    Replies: 12
    Last Post: 11th January 2006, 10:42 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •