+ Post New Thread
Results 1 to 4 of 4
Home Access Plus+ Thread, Will HAP+ run on earlier versions of .net framework? in Projects:; Hi all, Is there anyway to get HAP+ running on .net framework 3.5 for its application pool instead or does ...
  1. #1

    Join Date
    Oct 2011
    Location
    England
    Posts
    15
    Thank Post
    6
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Angry Will HAP+ run on earlier versions of .net framework?

    Hi all,

    Is there anyway to get HAP+ running on .net framework 3.5 for its application pool instead or does it have to be 4? At all of our sites we've come across a major issue in that installing .net framework 4 and the security updates stops Sophos Enterprise Admin Console (the latest London grid version, 9.7) from running, and although my investigation lead me to believe these should all run independently of each other, the only way we've been able to restore Sophos' functionality is by removing .net framework 4.

    Obviously this is primarily a Sophos being out of date issue but it totally cripples my planned roll out of HAP, so I was wondering is it possible to get it going on .net 3.5 or is there an older version (6?) that will work? Or if anyone else has had similar problems and has any advice for getting HAP+ and Sophos working side by side that'd be great.

  2. #2
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,577
    Thank Post
    39
    Thanked 512 Times in 442 Posts
    Rep Power
    115
    This is odd, we run sophos enterprise console here, and our sophos server is also running SIMS (which requires .net 4 to run the latest version). There are no known issues with sophos.

    Unfortunatly HAP+ requires .net 4 to run.

    I think we're still on sophos 9.5 here

  3. #3

    Join Date
    Oct 2011
    Location
    England
    Posts
    15
    Thank Post
    6
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    After a lot of troubleshooting it turned out that this only affected 32 bit servers, and that downgrading IE from 8 or 9 back to 7 fixed the issue as ridiculous as it seems. Must be something to do with the way newer versions utilise the .net framework. We did this on 4 /5 different sites and the result was identical, so just thought I'd add it here in case anyone in the future has similar issues.

  4. #4
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,577
    Thank Post
    39
    Thanked 512 Times in 442 Posts
    Rep Power
    115
    Thanks @Iamthelaw

SHARE:
+ Post New Thread

Similar Threads

  1. Replies: 2
    Last Post: 16th November 2010, 01:35 PM
  2. [MS Office - 2003] Word error, file type blocked because written in earlier version of word, registry?
    By Darryl_Wilcox in forum Office Software
    Replies: 3
    Last Post: 20th May 2010, 08:09 AM
  3. Replies: 30
    Last Post: 13th April 2010, 02:07 PM
  4. XP mode on any version of 7
    By ajbritton in forum Windows 7
    Replies: 5
    Last Post: 24th February 2010, 04:27 PM
  5. SIMS Lesson Monitor - Will it run on a Linux OS?
    By i7tech01 in forum MIS Systems
    Replies: 3
    Last Post: 31st March 2008, 09:30 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •