+ Post New Thread
Page 1 of 5 12345 LastLast
Results 1 to 15 of 67
Home Access Plus+ Thread, [HAP+][v8] My Files in Projects:; The new MSCB (My Files) first look Attachment 11626...
  1. #1
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,483
    Thank Post
    37
    Thanked 490 Times in 422 Posts
    Rep Power
    110

    [HAP+][v8] My Files

    The new MSCB (My Files) first look
    Attachment 11626
    Last edited by nickbro; 3rd January 2012 at 08:46 PM.

  2. Thanks to nickbro from:

    gianzack (30th November 2011)

  3. #2
    mattgrimley's Avatar
    Join Date
    Jun 2011
    Location
    Bedfordshire
    Posts
    316
    Thank Post
    35
    Thanked 21 Times in 19 Posts
    Blog Entries
    1
    Rep Power
    10
    Looking great for the drives.. Will the file/folder browser remain pretty much as is? I cant imagine 50 tiles would be an easy browsing session to trawl through!

  4. #3
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,483
    Thank Post
    37
    Thanked 490 Times in 422 Posts
    Rep Power
    110
    I'll hopefully show something off this weekend with regards to that

  5. #4
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,483
    Thank Post
    37
    Thanked 490 Times in 422 Posts
    Rep Power
    110
    Hi all, as promissed, here is another screenshot of the new My Files (MSCB).

    Attachment 11664


    You will have something to play with in tonights v7.5 release. If you browse to /myfiles/ in HAP+ you will see some magic.

    Please note:
    THIS IS A DEVELOPER PREVIEW OF MY FILES
    It is not intended to be a fully working version, just a DEVELOPER PREVIEW!!!

  6. Thanks to nickbro from:

    gianzack (30th November 2011)

  7. #5
    Zebadee's Avatar
    Join Date
    Mar 2006
    Location
    Northamptonshire
    Posts
    55
    Thank Post
    2
    Thanked 2 Times in 2 Posts
    Rep Power
    18
    Hi Nick,

    I know you said it's a developer preview, but should I be able to see the different network drives? I click on 'My Drives' and just get a rotating set of red arrows - but nothing seems to load. Is this by design at this stage?

    Andy

  8. #6
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,483
    Thank Post
    37
    Thanked 490 Times in 422 Posts
    Rep Power
    110
    Odd, what does /hap/api/MyFiles/Drives give you?

  9. #7
    Zebadee's Avatar
    Join Date
    Mar 2006
    Location
    Northamptonshire
    Posts
    55
    Thank Post
    2
    Thanked 2 Times in 2 Posts
    Rep Power
    18
    <?xml version="1.0"?>
    -<ArrayOfDrive xmlns="http://schemas.datacontract.org/2004/07/HAP.Data.MyFiles" xmlns:i="http://www.w3.org/2001/XMLSchema-instance">-<Drive><Actions>Change</Actions><Icon>../images/icons/netdrive.png</Icon><Name>My Documents</Name><Path>N\</Path><Space>10.40</Space></Drive>-<Drive><Actions>Change</Actions><Icon>../images/icons/netdrive.png</Icon><Name>RMPublic</Name><Path>P\</Path><Space>-1</Space></Drive>-<Drive><Actions>Change</Actions><Icon>../images/icons/netdrive.png</Icon><Name>Admin Data</Name><Path>S\</Path><Space>-1</Space></Drive>-<Drive><Actions>Change</Actions><Icon>../images/icons/netdrive.png</Icon><Name>RMStaff</Name><Path>T\</Path><Space>-1</Space></Drive>-<Drive><Actions>Change</Actions><Icon>../images/icons/netdrive.png</Icon><Name>RMShared Documents</Name><Path>W\</Path><Space>-1</Space></Drive>-<Drive><Actions>Change</Actions><Icon>../images/icons/netdrive.png</Icon><Name>RMDelivery</Name><Path>X\</Path><Space>-1</Space></Drive></ArrayOfDrive>

    Hope that makes sense. Looks more spread out and easier to read on the web page, but it wouldn't copy that way!

    Andy -

  10. #8
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,483
    Thank Post
    37
    Thanked 490 Times in 422 Posts
    Rep Power
    110
    So the API is working correctly, however it isn't parsing that on the client to render the interface. Are there any javascript errors being reported? What browser are you using?

    If you are using firefox, are you able to use firebug, open it on the console and see if it is doing an JSON request to /hap/api/myfiles/drives, or in IE, F12, start the Network Capture and repeat, or Chrome, Developer Tools, Network and check for any actions

  11. #9
    mattgrimley's Avatar
    Join Date
    Jun 2011
    Location
    Bedfordshire
    Posts
    316
    Thank Post
    35
    Thanked 21 Times in 19 Posts
    Blog Entries
    1
    Rep Power
    10
    Loads fine for me in Chrome, though some of the spacing on the percentage bars is off in IE9 (as is most of the rest of the internet though!)
    The tiles work visually really well Nick - i was sceptical!!

  12. #10
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,483
    Thank Post
    37
    Thanked 490 Times in 422 Posts
    Rep Power
    110
    Quote Originally Posted by mattgrimley View Post
    Loads fine for me in Chrome, though some of the spacing on the percentage bars is off in IE9 (as is most of the rest of the internet though!)
    The tiles work visually really well Nick - i was sceptical!!
    lol, thanks, for me chrome is the only browser that doesn't render all of HAP+ correctly. The percentage bars in chrome are actually narrower that they are in IE9 and Firefox

  13. #11
    mattgrimley's Avatar
    Join Date
    Jun 2011
    Location
    Bedfordshire
    Posts
    316
    Thank Post
    35
    Thanked 21 Times in 19 Posts
    Blog Entries
    1
    Rep Power
    10
    Quote Originally Posted by nickbro View Post
    lol, thanks, for me chrome is the only browser that doesn't render all of HAP+ correctly. The percentage bars in chrome are actually narrower that they are in IE9 and Firefox
    Doh! Wouldn't the world be a better place if they all just rendered the bloody same!!

  14. #12
    Zebadee's Avatar
    Join Date
    Mar 2006
    Location
    Northamptonshire
    Posts
    55
    Thank Post
    2
    Thanked 2 Times in 2 Posts
    Rep Power
    18
    Hi Nick,

    Here is the capture from IE9 whilst navigating to /hap/myfiles and clicking on 'My Drives'

    [HAP+][v8] My Files-ie9-capture.png

    Andy -

  15. #13
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,483
    Thank Post
    37
    Thanked 490 Times in 422 Posts
    Rep Power
    110
    IT seems that for some reason your IIS install is returning an XML result instead of JSON. Are there any javascript errors being reported?

  16. #14
    Zebadee's Avatar
    Join Date
    Mar 2006
    Location
    Northamptonshire
    Posts
    55
    Thank Post
    2
    Thanked 2 Times in 2 Posts
    Rep Power
    18
    I don't think so. Have tried it in firefox and Chrome as well and get the same problem!

    I cherry picked the new 7.5 files from the update zip, and just went down the change log adding or removing them as necessary. I noticed that the myfiles folder was missing from the change log. Could i have missed something else, unless other people have done the same thing and it works ok for them...?

    Andy -

  17. #15
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,483
    Thank Post
    37
    Thanked 490 Times in 422 Posts
    Rep Power
    110
    Everything should of been part of the ~/myfiles/default.aspx document

SHARE:
+ Post New Thread
Page 1 of 5 12345 LastLast

Similar Threads

  1. HAP 7.8 Does not show my files when users logs in
    By ict_support in forum Home Access Plus+
    Replies: 0
    Last Post: 21st December 2011, 03:14 PM
  2. 2008R2 SP1 broke my file server
    By Simcfc73 in forum Windows Server 2008 R2
    Replies: 5
    Last Post: 16th March 2011, 09:06 PM
  3. Replies: 0
    Last Post: 28th February 2011, 01:56 PM
  4. Gremlins in my file system
    By woody in forum Windows
    Replies: 29
    Last Post: 29th September 2006, 03:35 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •