+ Post New Thread
Page 3 of 5 FirstFirst 12345 LastLast
Results 31 to 45 of 67
Home Access Plus+ Thread, [HAP+][v8] My Files in Projects:; My take on the same idea - as a WP7 user and someone who likes the idea of Metro/Microsoft Surface ...
  1. #31
    jamesfed's Avatar
    Join Date
    Sep 2009
    Location
    Reading
    Posts
    2,192
    Thank Post
    134
    Thanked 340 Times in 287 Posts
    Rep Power
    84
    My take on the same idea - as a WP7 user and someone who likes the idea of Metro/Microsoft Surface I've been trying to keep to the idea which Microsoft is using of 'Content not Chrome' so the way I see it the drive icons are secondary to the drive titles.

    Either way just an idea to help the creative process along

    [HAP+][v8] My Files-metrodrives.jpg

  2. #32
    Zebadee's Avatar
    Join Date
    Mar 2006
    Location
    Northamptonshire
    Posts
    55
    Thank Post
    2
    Thanked 2 Times in 2 Posts
    Rep Power
    18
    Oh well. Have done a completly fresh install including repopulating the setup.aspx but it didn't do anything.

    Will check through the IIS install video tomorrow to see if anything is not quite right. Hopefully something might jump out!

    Andy

  3. #33
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,483
    Thank Post
    37
    Thanked 490 Times in 422 Posts
    Rep Power
    110
    Quote Originally Posted by Zebadee View Post
    Still no joy I'm afraid. Getting the following error message when in 'myfiles' on firefox

    SyntaxError: JSON.parse

    Have attached a screengrab when running firebug

    Attachment 11688
    hi, in firebug can you expand the request to /api/myfiles/drives and tell me what is in each of the tabs

  4. #34
    Zebadee's Avatar
    Join Date
    Mar 2006
    Location
    Northamptonshire
    Posts
    55
    Thank Post
    2
    Thanked 2 Times in 2 Posts
    Rep Power
    18
    Hi Nick, from the console tab:

    All / Errors / Warnings / Info / Debug Info - all tabs blank

    There is some info from the Net tab. Do you want me to upload some screengrabs?

  5. #35
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,483
    Thank Post
    37
    Thanked 490 Times in 422 Posts
    Rep Power
    110
    This is what I'm looking for
    Attachment 11696

  6. #36
    Zebadee's Avatar
    Join Date
    Mar 2006
    Location
    Northamptonshire
    Posts
    55
    Thank Post
    2
    Thanked 2 Times in 2 Posts
    Rep Power
    18
    Ok, here are the headers, response & XML tabs. I don't have a JSON tab

    [HAP+][v8] My Files-headers.png

    [HAP+][v8] My Files-response.png

    [HAP+][v8] My Files-xml.png

  7. #37
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,483
    Thank Post
    37
    Thanked 490 Times in 422 Posts
    Rep Power
    110
    Quote Originally Posted by Zebadee View Post
    Ok, here are the headers, response & XML tabs. I don't have a JSON tab

    Click image for larger version. 

Name:	headers.png 
Views:	75 
Size:	173.3 KB 
ID:	11701

    Click image for larger version. 

Name:	response.png 
Views:	66 
Size:	170.1 KB 
ID:	11702

    Click image for larger version. 

Name:	xml.png 
Views:	79 
Size:	175.3 KB 
ID:	11703
    As I thought, it's returning XML instead of JSON. Are you using any reverse proxies? Special IIS settings that would stop IIS from handing the correct headers back to HAP+

    Have you removed anything from the original web.config?

    Can you try a reinstall of .net 4.0 full

  8. #38
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,483
    Thank Post
    37
    Thanked 490 Times in 422 Posts
    Rep Power
    110
    Another try, open ~/myfiles/default.aspx in notepad, do a find a replace on
    Code:
    ; charset=utf-8
    replacing with nothing i.e. ""

  9. #39
    Zebadee's Avatar
    Join Date
    Mar 2006
    Location
    Northamptonshire
    Posts
    55
    Thank Post
    2
    Thanked 2 Times in 2 Posts
    Rep Power
    18
    I've now tried a completely fresh install using the full 7.6 zip - including deleting all IIS stuff and starting from scratch. I'm still not able to see anything when going to ~/myfiles, but i've got this error message in IE8 from our FRDC. Does this help?

    Webpage error details

    User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.2; Trident/4.0; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.04506.648; .NET CLR 3.5.21022; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729; .NET4.0C; .NET4.0E)
    Timestamp: Tue, 1 Nov 2011 20:17:48 UTC


    Message: 'console' is undefined
    Line: 139
    Char: 4
    Code: 0
    URI: https://folders.kingswood-pri.northa...k/HAP/myfiles/


    Message: 'console' is undefined
    Line: 139
    Char: 4
    Code: 0
    URI: https://folders.kingswood-pri.northa...k/HAP/myfiles/

  10. #40
    Zebadee's Avatar
    Join Date
    Mar 2006
    Location
    Northamptonshire
    Posts
    55
    Thank Post
    2
    Thanked 2 Times in 2 Posts
    Rep Power
    18
    Just tried ~/myfiles in Firefox on my Windows 7 laptop. This is the firebug info.

    [HAP+][v8] My Files-myfiles.png

    Am getting the following error message: SyntaxError: JSON.parse: unexpected character

    This comes up as soon as i navigate to ~/myfiles. Don't have to click anything to get the error message.

  11. #41
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,483
    Thank Post
    37
    Thanked 490 Times in 422 Posts
    Rep Power
    110
    Makes no sense, your IIS server is sending XML when JSON was requested

  12. #42
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,483
    Thank Post
    37
    Thanked 490 Times in 422 Posts
    Rep Power
    110
    Hi all, here's another screenshot for My Files, you will be able to right click on files/folders and ask for properties

    Attachment 12178

  13. #43
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,483
    Thank Post
    37
    Thanked 490 Times in 422 Posts
    Rep Power
    110
    Another update on the development of this section:

    Drag and Dropping is now coded (via jQuery), so you can now move files around in the main window.

    Attachment 12314

    Little bits due to be in the v7.8 preview:

    1. Drag and Drop Move/Copy
    2. Drag and Drop Upload
    3. Right Click to Download
    4. Right Click Copy/Cut
    5. Right Click Paste


    What I'm still planning for:
    1. ZIP/Unzip
    2. Preview for (.docx, .xls, .xlsx, images, and hopefully .pdf)
    3. Inline Renaming
    4. Delete
    5. Drag and Drop into the Tree
    6. Updating the Tree When Folders are Renamed
    7. New Folder
    8. Homework Drop Box (will be another drive)
    9. Additional View Modes
    10. Drag and Drop Uploading using HTML5, as well as HTML4 upload option via right click
    11. About/Help/Tutorial Button
    12. Right Click to Download Folder (will zip the folder up temporarily)


    Feedback?

  14. #44
    mattgrimley's Avatar
    Join Date
    Jun 2011
    Location
    Bedfordshire
    Posts
    316
    Thank Post
    35
    Thanked 21 Times in 19 Posts
    Blog Entries
    1
    Rep Power
    10
    Looks great, cant wait!!

    Is there any chance that the "drag and drop" functionality can be an option at drive level? (I wish it could be in Windows too, a shared area + teachers is such a headache!!)

    Other than that, can't wait to start playing properly (having some issues with the 7.7 myfiles which i havent gotten round to troubelshooting yet)

  15. #45
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,483
    Thank Post
    37
    Thanked 490 Times in 422 Posts
    Rep Power
    110
    A little bit more news on My Files.

    I've adjusted the layout to work better on all browsers, complete with sticking tree/toolbar when you scroll. It should make viewing the page easier on smartphones.

    Also done today, was dragging and dropping into the tree, complete with Hover to load the sub tree

SHARE:
+ Post New Thread
Page 3 of 5 FirstFirst 12345 LastLast

Similar Threads

  1. HAP 7.8 Does not show my files when users logs in
    By ict_support in forum Home Access Plus+
    Replies: 0
    Last Post: 21st December 2011, 03:14 PM
  2. 2008R2 SP1 broke my file server
    By Simcfc73 in forum Windows Server 2008 R2
    Replies: 5
    Last Post: 16th March 2011, 09:06 PM
  3. Replies: 0
    Last Post: 28th February 2011, 01:56 PM
  4. Gremlins in my file system
    By woody in forum Windows
    Replies: 29
    Last Post: 29th September 2006, 03:35 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •