+ Post New Thread
Page 2 of 2 FirstFirst 12
Results 16 to 25 of 25
Home Access Plus+ Thread, HAP 7 Installation Problem - AppPool in Projects:; Code: icacls C:\inetpub\wwwroot\Hap /grant "IIS AppPool\HAP":(RX)...
  1. #16

    Join Date
    Nov 2010
    Location
    Lincolnshire
    Posts
    57
    Thank Post
    16
    Thanked 2 Times in 2 Posts
    Rep Power
    8
    Code:
    icacls C:\inetpub\wwwroot\Hap /grant "IIS AppPool\HAP":(RX)

  2. #17
    enjay's Avatar
    Join Date
    Apr 2007
    Location
    Reading, Berkshire, UK
    Posts
    4,456
    Thank Post
    279
    Thanked 196 Times in 167 Posts
    Rep Power
    75
    Thanks Gavlar, I'll give that a try...

  3. #18
    enjay's Avatar
    Join Date
    Apr 2007
    Location
    Reading, Berkshire, UK
    Posts
    4,456
    Thank Post
    279
    Thanked 196 Times in 167 Posts
    Rep Power
    75
    Quote Originally Posted by gavlar View Post
    Code:
    icacls C:\inetpub\wwwroot\Hap /grant "IIS AppPool\HAP":(RX)
    Perfect, that worked a treat. Thanks!

  4. #19
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,351
    Thank Post
    36
    Thanked 465 Times in 397 Posts
    Rep Power
    105
    Quote Originally Posted by gavlar View Post
    Code:
    icacls C:\inetpub\wwwroot\Hap /grant "IIS AppPool\HAP":(RX)
    Thanks @gavlar, I've posted this to the Home Access Plus&#43

  5. #20
    enjay's Avatar
    Join Date
    Apr 2007
    Location
    Reading, Berkshire, UK
    Posts
    4,456
    Thank Post
    279
    Thanked 196 Times in 167 Posts
    Rep Power
    75
    Other points worth adding to the documentation would be deleting the endpoint lines at the end of the web.config - you posted that to someone on here, and I had it too, so it is unlikely we're the only two.

    I also had the remove the line about svg MimeTypes, so if that is something wider then it would be worth documenting too.

    Awesome app, by the way, not sure I've said that enough yet!!

  6. #21
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,351
    Thank Post
    36
    Thanked 465 Times in 397 Posts
    Rep Power
    105
    I'll add them to the documentation tab on codeplex tonight

  7. #22

    Join Date
    Nov 2008
    Posts
    9
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    HAP + security issue

    Hi
    I have tried the cacls command as described thanks and it sets permissions on the HAP folder but the HAP user is not shown anywhere lower down in the structure. I also had the original issue where I do not get the option to see user, group.. in the object type.
    Last edited by carolynwhile; 14th October 2011 at 05:42 PM. Reason: Question already answered

  8. #23
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,351
    Thank Post
    36
    Thanked 465 Times in 397 Posts
    Rep Power
    105
    See: Home Access Plus&#43

    Code:
    icacls C:\inetpub\wwwroot\Hap /grant "IIS AppPool\HAP":(RX)
    Also

    Attachment 11648Attachment 11649

    Notice I select the local server, and just type the name in, no going to Advanced...

    If you are running this on a domain controller:

    STOP!

    1. can you run this on a member server?
    a. If Yes, do so, HAP+ v7+ works best on a member server, although v6- works best on the PDC.
    2. you need to enable interactive logons on the server. If your server is a Remote Desktop Server (which mine is), this is already set
    3. If you insist on a PDC, make sure Buit-in security principals are selected to search in.

  9. #24

    Join Date
    Nov 2008
    Posts
    9
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Hi
    Presumably this version is not reliant in any way on easylink so I could install onto a member server as long as I created a new external dns mapping to that server ie HAP.kes.org.uk? Would you recommend doing it like this?
    Thanks

  10. #25
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,351
    Thank Post
    36
    Thanked 465 Times in 397 Posts
    Rep Power
    105
    Yes, that would be a good thing. HAP+ has never relied on easylink since it was called Home Access Plus+. Back when it was CHS Extranet, it did have some ties, but that was over a year ago.

    Best solution is:

    Windows Server 2008 R2 acting as a remote desktop server (you can then use remote apps via remote desktop gateway, but that part is optional)
    IIS7.5
    Joined as a Member Server
    Directory on website called HAP in which HAP is installed
    Set up a DNS entry pointing to your server (hap.school.tld -> county issued ip -> reverse proxy or traffic routing -> your server, or hap.school.tld -> your external ip -> traffic route for 443 -> your server)
    Acquire a SSL Certificate for hap.school.tld, (StartSSL offers free ssl certs)
    Assign certificate to the IIS Website
    Install quota service on servers you will be accessing for My Files
    OPTIONAL: install SQL server, and create a database for the logon tracker database
    Set the security on the HAP folder
    Set additional rights on the APP_DATA folder

    This is the setup I have for my HAP+. I also then use this server as a reverse proxy to relay traffic to our RM Server so management console can be accessed, as well as a backup for our exchanger server. (www.iis.net/download/ApplicationRequestRouting is the extension for IIS7 I use for that)

SHARE:
+ Post New Thread
Page 2 of 2 FirstFirst 12

Similar Threads

  1. Sophos console installation problem
    By Number6 in forum Windows Server 2008
    Replies: 1
    Last Post: 26th August 2009, 07:34 PM
  2. Installation problem on Step 3
    By HMCTech in forum EduGeek Joomla 1.0 Package
    Replies: 1
    Last Post: 10th April 2008, 08:59 PM
  3. GLPI installation problem
    By WithoutMotive in forum Windows
    Replies: 9
    Last Post: 23rd September 2007, 07:27 PM
  4. Replies: 6
    Last Post: 28th August 2007, 04:41 PM
  5. isscript installation problem
    By adamyoung in forum Educational Software
    Replies: 5
    Last Post: 21st April 2006, 08:33 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •