+ Post New Thread
Page 5 of 5 FirstFirst 12345
Results 61 to 72 of 72
Home Access Plus+ Thread, installation problem v7 in Projects:; You answered both questions there, it's very strange that it isn't able to impersonate the current user, which is where ...
  1. #61
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,483
    Thank Post
    37
    Thanked 490 Times in 422 Posts
    Rep Power
    110
    You answered both questions there, it's very strange that it isn't able to impersonate the current user, which is where the error is coming from. Is there anything in the event logs on the server which may give a clue

  2. #62
    enjay's Avatar
    Join Date
    Apr 2007
    Location
    Reading, Berkshire, UK
    Posts
    4,485
    Thank Post
    282
    Thanked 196 Times in 167 Posts
    Rep Power
    75
    Application Event Viewer has two events from ASP:

    This "information":
    Log Name: Application
    Source: ASP.NET 4.0.30319.0
    Date: 9/23/2011 11:37:52 AM
    Event ID: 1315
    Task Category: Web Event
    Level: Information
    Keywords: Classic
    User: N/A
    Computer: 6002dc01c.SCH6002.Reading.sch.uk
    Description:
    Event code: 4005
    Event message: Forms authentication failed for the request. Reason: The ticket supplied has expired.
    Event time: 9/23/2011 11:37:52 AM
    Event time (UTC): 9/23/2011 10:37:52 AM
    Event ID: 798cc1720b4d430aadfc5e82398e5ccb
    Event sequence: 2
    Event occurrence: 1
    Event detail code: 50202

    Application information:
    Application domain: /LM/W3SVC/1/ROOT/HAP-1-129612478727483203
    Trust level: Full
    Application Virtual Path: /HAP
    Application Path: C:\inetpub\wwwroot\HAP\
    Machine name: 6002DC01C

    Process information:
    Process ID: 1880
    Process name: w3wp.exe
    Account name: IIS APPPOOL\HAP

    Request information:
    Request URL: http://localhost/HAP/
    Request path: /HAP/
    User host address: ::1
    User:
    Is authenticated: False
    Authentication Type:
    Thread account name: IIS APPPOOL\HAP

    Name to authenticate:

    Custom event details:

    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
    <System>
    <Provider Name="ASP.NET 4.0.30319.0" />
    <EventID Qualifiers="16384">1315</EventID>
    <Level>4</Level>
    <Task>3</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2011-09-23T10:37:52.000000000Z" />
    <EventRecordID>42643</EventRecordID>
    <Channel>Application</Channel>
    <Computer>6002dc01c.SCH6002.Reading.sch.uk</Computer>
    <Security />
    </System>
    <EventData>
    <Data>4005</Data>
    <Data>Forms authentication failed for the request. Reason: The ticket supplied has expired.</Data>
    <Data>9/23/2011 11:37:52 AM</Data>
    <Data>9/23/2011 10:37:52 AM</Data>
    <Data>798cc1720b4d430aadfc5e82398e5ccb</Data>
    <Data>2</Data>
    <Data>1</Data>
    <Data>50202</Data>
    <Data>/LM/W3SVC/1/ROOT/HAP-1-129612478727483203</Data>
    <Data>Full</Data>
    <Data>/HAP</Data>
    <Data>C:\inetpub\wwwroot\HAP\</Data>
    <Data>6002DC01C</Data>
    <Data>
    </Data>
    <Data>1880</Data>
    <Data>w3wp.exe</Data>
    <Data>IIS APPPOOL\HAP</Data>
    <Data>http://localhost/HAP/</Data>
    <Data>/HAP/</Data>
    <Data>::1</Data>
    <Data>
    </Data>
    <Data>False</Data>
    <Data>
    </Data>
    <Data>IIS APPPOOL\HAP</Data>
    <Data>
    </Data>
    </EventData>
    </Event>
    ... followed by this "warning":

    Log Name: Application
    Source: ASP.NET 4.0.30319.0
    Date: 9/23/2011 11:38:03 AM
    Event ID: 1309
    Task Category: Web Event
    Level: Warning
    Keywords: Classic
    User: N/A
    Computer: 6002dc01c.SCH6002.Reading.sch.uk
    Description:
    Event code: 3005
    Event message: An unhandled exception has occurred.
    Event time: 9/23/2011 11:38:03 AM
    Event time (UTC): 9/23/2011 10:38:03 AM
    Event ID: 3fc74ca032fd4ceeade4abed0e47765e
    Event sequence: 24
    Event occurrence: 1
    Event detail code: 0

    Application information:
    Application domain: /LM/W3SVC/1/ROOT/HAP-1-129612478727483203
    Trust level: Full
    Application Virtual Path: /HAP
    Application Path: C:\inetpub\wwwroot\HAP\
    Machine name: 6002DC01C

    Process information:
    Process ID: 1880
    Process name: w3wp.exe
    Account name: IIS APPPOOL\HAP

    Exception information:
    Exception type: Exception
    Exception message: Something is wrong
    at HAP.AD.User.Impersonate()
    at HAP.Web.Default.Page_Load(Object sender, EventArgs e)
    at System.Web.Util.CalliHelper.EventArgFunctionCaller (IntPtr fp, Object o, Object t, EventArgs e)
    at System.Web.UI.Control.LoadRecursive()
    at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)



    Request information:
    Request URL: http://localhost/HAP/default.aspx
    Request path: /HAP/default.aspx
    User host address: ::1
    User: JoeBloggs
    Is authenticated: True
    Authentication Type: Forms
    Thread account name: IIS APPPOOL\HAP

    Thread information:
    Thread ID: 7
    Thread account name: IIS APPPOOL\HAP
    Is impersonating: False
    Stack trace: at HAP.AD.User.Impersonate()
    at HAP.Web.Default.Page_Load(Object sender, EventArgs e)
    at System.Web.Util.CalliHelper.EventArgFunctionCaller (IntPtr fp, Object o, Object t, EventArgs e)
    at System.Web.UI.Control.LoadRecursive()
    at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)


    Custom event details:

    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
    <System>
    <Provider Name="ASP.NET 4.0.30319.0" />
    <EventID Qualifiers="32768">1309</EventID>
    <Level>3</Level>
    <Task>3</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2011-09-23T10:38:03.000000000Z" />
    <EventRecordID>42644</EventRecordID>
    <Channel>Application</Channel>
    <Computer>6002dc01c.SCH6002.Reading.sch.uk</Computer>
    <Security />
    </System>
    <EventData>
    <Data>3005</Data>
    <Data>An unhandled exception has occurred.</Data>
    <Data>9/23/2011 11:38:03 AM</Data>
    <Data>9/23/2011 10:38:03 AM</Data>
    <Data>3fc74ca032fd4ceeade4abed0e47765e</Data>
    <Data>24</Data>
    <Data>1</Data>
    <Data>0</Data>
    <Data>/LM/W3SVC/1/ROOT/HAP-1-129612478727483203</Data>
    <Data>Full</Data>
    <Data>/HAP</Data>
    <Data>C:\inetpub\wwwroot\HAP\</Data>
    <Data>6002DC01C</Data>
    <Data>
    </Data>
    <Data>1880</Data>
    <Data>w3wp.exe</Data>
    <Data>IIS APPPOOL\HAP</Data>
    <Data>Exception</Data>
    <Data>Something is wrong
    at HAP.AD.User.Impersonate()
    at HAP.Web.Default.Page_Load(Object sender, EventArgs e)
    at System.Web.Util.CalliHelper.EventArgFunctionCaller (IntPtr fp, Object o, Object t, EventArgs e)
    at System.Web.UI.Control.LoadRecursive()
    at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

    </Data>
    <Data>http://localhost/HAP/default.aspx</Data>
    <Data>/HAP/default.aspx</Data>
    <Data>::1</Data>
    <Data>JoeBloggs</Data>
    <Data>True</Data>
    <Data>Forms</Data>
    <Data>IIS APPPOOL\HAP</Data>
    <Data>7</Data>
    <Data>IIS APPPOOL\HAP</Data>
    <Data>False</Data>
    <Data> at HAP.AD.User.Impersonate()
    at HAP.Web.Default.Page_Load(Object sender, EventArgs e)
    at System.Web.Util.CalliHelper.EventArgFunctionCaller (IntPtr fp, Object o, Object t, EventArgs e)
    at System.Web.UI.Control.LoadRecursive()
    at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
    </Data>
    </EventData>
    </Event>
    Hopefully they mean more to you than they do to me!

  3. #63
    enjay's Avatar
    Join Date
    Apr 2007
    Location
    Reading, Berkshire, UK
    Posts
    4,485
    Thank Post
    282
    Thanked 196 Times in 167 Posts
    Rep Power
    75
    Hi Nick, do those Event Viewer messages help at all?

  4. #64
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,483
    Thank Post
    37
    Thanked 490 Times in 422 Posts
    Rep Power
    110
    Is interactive logons disabled on your server, as HAP+ uses interactive logons to impersonate the user

  5. #65
    enjay's Avatar
    Join Date
    Apr 2007
    Location
    Reading, Berkshire, UK
    Posts
    4,485
    Thank Post
    282
    Thanked 196 Times in 167 Posts
    Rep Power
    75
    Quote Originally Posted by nickbro View Post
    Is interactive logons disabled on your server, as HAP+ uses interactive logons to impersonate the user
    No, "allow logon locally" is defined just to administrative groups, and "impersonate a client after logon" is not configured. I'm somewhat cautious about changing settings at such a high level - what else am I potentially exposing myself to by changing this? Is there anything I need to be aware of once I've changed it?

  6. #66

    Join Date
    Nov 2010
    Location
    Lincolnshire
    Posts
    58
    Thank Post
    16
    Thanked 3 Times in 3 Posts
    Rep Power
    8
    I'm having the same propblem as you @enjay. Let me know if you find a solution.

  7. #67
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,483
    Thank Post
    37
    Thanked 490 Times in 422 Posts
    Rep Power
    110
    I've editted the HAP.AD to try interactive and network logon rights, see if the attached updated dll makes any difference

  8. Thanks to nickbro from:

    donutcat (30th September 2011)

  9. #68
    enjay's Avatar
    Join Date
    Apr 2007
    Location
    Reading, Berkshire, UK
    Posts
    4,485
    Thank Post
    282
    Thanked 196 Times in 167 Posts
    Rep Power
    75
    Thanks Nick, the updated hap.ad file does this trick. Now I just need to get this certificate sorted and I'm away (hopefully!!)

  10. #69
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,483
    Thank Post
    37
    Thanked 490 Times in 422 Posts
    Rep Power
    110
    Well I'll check the change in, this will make it into the v7.3 release for this weekend, if my internet at home is back on by then, DAM Sky

  11. #70

    Join Date
    Nov 2010
    Location
    Lincolnshire
    Posts
    58
    Thank Post
    16
    Thanked 3 Times in 3 Posts
    Rep Power
    8
    Thanks Nick, this stopped the error message i was getting. However i still can't access any of the Drives in the basic view with test student and staff accounts, i get an error that says "Error: Unauthorised Access You have attempted to access a restricted resource" and nothing shows in the extended view for these users.

    Any idea which settings i need to change?

  12. #71
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,483
    Thank Post
    37
    Thanked 490 Times in 422 Posts
    Rep Power
    110
    It's got to be because of the Interactive Logon Rights it needs to run properly. Best thing is to run HAP+ on a Server which isn't a domain controller

  13. #72
    donutcat's Avatar
    Join Date
    Dec 2006
    Location
    Bedford
    Posts
    115
    Thank Post
    7
    Thanked 12 Times in 11 Posts
    Rep Power
    22
    Quote Originally Posted by nickbro View Post
    I've editted the HAP.AD to try interactive and network logon rights, see if the attached updated dll makes any difference
    I had problems authenticating against, AD, and followed through this thread. Everything else worked, but as soon as I replaced the dll everything came to life.
    Excellent project, really impressed with the booking system concept, especially dealing with SIMS!

SHARE:
+ Post New Thread
Page 5 of 5 FirstFirst 12345

Similar Threads

  1. Sophos console installation problem
    By Number6 in forum Windows Server 2008
    Replies: 1
    Last Post: 26th August 2009, 07:34 PM
  2. Installation problem on Step 3
    By HMCTech in forum EduGeek Joomla 1.0 Package
    Replies: 1
    Last Post: 10th April 2008, 08:59 PM
  3. GLPI installation problem
    By WithoutMotive in forum Windows
    Replies: 9
    Last Post: 23rd September 2007, 07:27 PM
  4. Replies: 6
    Last Post: 28th August 2007, 04:41 PM
  5. isscript installation problem
    By adamyoung in forum Educational Software
    Replies: 5
    Last Post: 21st April 2006, 08:33 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •