+ Post New Thread
Page 2 of 2 FirstFirst 12
Results 16 to 25 of 25
Home Access Plus+ Thread, Help, Vanilla install issues in Projects:; Originally Posted by Wils86 Errors errors everywhere. I need your brains again sister_annex and Nickbro. 1. when downloading a file ...
  1. #16

    Join Date
    Jan 2009
    Location
    Tavistock
    Posts
    313
    Thank Post
    66
    Thanked 125 Times in 56 Posts
    Rep Power
    46
    Quote Originally Posted by Wils86 View Post
    Errors errors everywhere. I need your brains again sister_annex and Nickbro.

    1. when downloading a file under anyone from a drive I get
    Code:
    Server Error in '/Extranet' Application.
    --------------------------------------------------------------------------------
    
    Object reference not set to an instance of an object. 
    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code. 
    
    Exception Details: System.NullReferenceException: Object reference not set to an instance of an object.
    
    Source Error: 
    
    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.  
    
    Stack Trace: 
    
    
    [NullReferenceException: Object reference not set to an instance of an object.]
       HAP.Web.routing.Downloader.ProcessRequest(HttpContext context) +365
       System.Web.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() +100
       System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) +75
    
     
    
    
    --------------------------------------------------------------------------------
    Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.0.30319.1
    The user can access this drive and do what they want in windows and in HAP they can rename and upload new files to the location just cant download.

    UNC paths

    Code:
    <uncpaths>
    	  <add drive="H" name="My Documents" unc="\\curric-b\students\{0}" enablereadto="student" enablewriteto="Studnet" enablemove="True" />
    	  <add drive="I" name="My Documents" unc="\\curric-a\staff\{0}" enablereadto="Staff, Domain Admins" enablewriteto="Staff, Domain Admins" enablemove="True" />
                  <add drive="N" name="Subjects" unc="\\curric-b\newpublic\subjects\" enablereadto="students" enablewriteto="Staff, Domain Admins" enablemove="True" />
                 <add drive="S" name="Staff Drive" unc="\\curric-b\newpublic\" enablereadto="Staff, Domain Admins" enablewriteto="Staff, Domain Admins" enablemove="True" />
    	</uncpaths>
    2. Logon tracker does not log logons (lol so many logs) and the user card does this when you logon:

    Attachment 10105Attachment 10106

    web.config

    Attachment 10107


    As always thank you for your help, hopefully I'm able to repay the favour.
    I see in you web.config file you have a small error, not sure if it helps but im sure its not doing any good...
    <uncpaths>
    <add drive="H" name="My Documents" unc="\\curric-b\students\{0}" enablereadto="student" enablewriteto="Studnet"

    you have Studnet instead of student in the enablewriteto=

  2. #17

    Join Date
    Nov 2008
    Location
    Birmingham
    Posts
    127
    Thank Post
    27
    Thanked 15 Times in 14 Posts
    Rep Power
    14
    Morning ama178 No luck yet, being busy sorting FOG and the new machines for start of term, had to put this on the back burner for th time being which is a shame. Holding out for V7 and hope that may cure some of my errors fingers crossed. If any one does have a fix though were all ears.

    Oh and JAB1a good eyes I've being staring at that config file for days ad never noticed I did that. Didnt solve my error but still, good to have it all neat and the same (slightly OCD once I notice stuff).

    Cheers

  3. #18
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,561
    Thank Post
    38
    Thanked 507 Times in 437 Posts
    Rep Power
    114
    The logon tracker/usercard issue is due to a DNS issue, where it can't resolve moodle.astonmanor.bham.sch.uk internally.

    The main issue you will be facing is due to the home directory entry in AD not being present. You need to define this. HAP+ uses this behind the scene, even if you tell it not to. I'll try and do something to fix that, but it's not likely.

  4. #19

    Join Date
    Nov 2008
    Location
    Birmingham
    Posts
    127
    Thank Post
    27
    Thanked 15 Times in 14 Posts
    Rep Power
    14
    Quote Originally Posted by nickbro View Post
    The logon tracker/usercard issue is due to a DNS issue, where it can't resolve moodle.astonmanor.bham.sch.uk internally.

    The main issue you will be facing is due to the home directory entry in AD not being present. You need to define this. HAP+ uses this behind the scene, even if you tell it not to. I'll try and do something to fix that, but it's not likely.
    I get ya, I tried changing this to the internal address of the HAP server and it just changed the error message giving the new location. Any idea how to solve this?

    The second bit I get and will remedy this as soon as I have a chance you know what its like, the error occurs on shared drives as well if that helps.

    Any way Nickbro I think this is my first direct reponse to you so (you've heard it already) but this is an amazing piece of software and thank you for your help and support.

  5. #20
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,561
    Thank Post
    38
    Thanked 507 Times in 437 Posts
    Rep Power
    114
    thanks @Wils86. It's an odd one. The user card/logon tracker is set NOT to use the HTTP Proxy, and go directly to your HAP+ site. You can change this on by editing the .config file of the user card to enable the HTTP Proxy

  6. #21

    Join Date
    Nov 2008
    Location
    Birmingham
    Posts
    127
    Thank Post
    27
    Thanked 15 Times in 14 Posts
    Rep Power
    14
    Morning @nickbro, Just thought I'll let you know I decided to start from scratch and take your advice on the home directory. Worked great all users can access and download everything they should be able to in My Computer. Just some things I have noticed may be you could look at in the future.

    1. The basestyle.css in v6.3 is missing the following code at the end which is present in v6.2. It controls the tabs on the home screen if I am correct.

    Code:
    #hometabs { height: 250px; }
    #tabheaders a { float: left; height: 25px; line-height: 25px; margin: 6px 1px 0 1px; text-decoration: none; font-family: Segoe UI; text-align: center; border-bottom: solid 1px #dedede  }
    #tabheaders a:hover { border: solid 1px #dedede border-radius: 5px 5px 0 0; margin: 5px 0 0 0; }
    #tabheaders a.active { color: #000 border: solid 1px #dedede border-bottom: 0; margin: 0; height: 30px; line-height: 30px;  border-radius: 5px 5px 0 0; }
    #tabs { overflow: hidden; clear: both; }
    .tab { display: none; margin: 10px 50px; }
    .tab div { margin-bottom: 5px; }
    #tab_me_progress { width: 400px; height: 18px; border: solid 1px gray; border-radius: 3px; background: transparent url(images/progressbar.png) repeat-x top left; position: relative; overflow: hidden; margin: 5px 0 0 0; }
    #tab_me_progress div { height: 18px; background: transparent url(images/progressbar-active.png) repeat-x top left; }
    #tab_me_progress label { position: absolute; top: 0; left: 0; right: 0; bottom: 0; text-align: center; font-size: 14px; }
    
    .bookingtable { border: solid 1px #a0a0a0 border-collapse: collapse; padding: 0; margin: 0; background: #fff width: 100%; position: relative; }
    .bookingtable th { border-bottom: solid 1px #a0a0a0 border-top: 0; line-height: 20px; height: 20px; background: #f3f4f6 url(images/table-head-bg.gif) repeat-x top left; font-weight: normal; padding: 0; margin: 0; }
    .bookingtable td { font-size: 84%; padding: 0 2px; }
    .bookingtable.tickets td { font-size: 94%; text-align: center; }
    May be an amendment or something.

    2. It might be worth making an addition to the installation manual to say that for it to fully work the home directory needs to be in active directory as I never spotted this and know a few places that rely completely on login scripts for mapping drives. This would cause the unauthorised access and error I and others may experience.

    Just two things I hope you donít think I am being pushy or stepping on your toes, I would just like to help in whatever why I can. Oh and if anything I said above is wrong please ignore it.

    Thanks

  7. #22

    Join Date
    Nov 2008
    Location
    Birmingham
    Posts
    127
    Thank Post
    27
    Thanked 15 Times in 14 Posts
    Rep Power
    14
    Quote Originally Posted by ama178 View Post
    Wils86 have you had any luck resolving your last error. I am getting exactly the same thing.

    I can create new items, delete existing items but can't open/download existing or new items.

    Any help would be greatly appreciated.
    nickbro pointed me in the right direction, HAP+ uses the home profile location in AD to do the authentication even if you tell it not to. If you go to your user and select the profile tab and half way down is the Home Folder option. Select the drive letter and then type in UNC path to that specific users home folder. That will allow HAP+ top work. If you select multiple users to do it in bulk type ' \\server\staff\%username% ' if you use the username to map the home folder.

    This will fill in every ones home path with the correct location making HAP+ work.

    In other news nickbro I need help again. Any domain Admin who clicks on the booking system is presented with this:

    Code:
    Server Error in '/Extranet' Application.
    --------------------------------------------------------------------------------
    
    There is no such object on the server.
    
    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code. 
    
    Exception Details: System.DirectoryServices.DirectoryServicesCOMException: There is no such object on the server.
    
    
    Source Error: 
    
    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.  
    
    Stack Trace: 
    
    
    [DirectoryServicesCOMException (0x80072030): There is no such object on the server.
    ]
       System.DirectoryServices.DirectoryEntry.Bind(Boolean throwIfFail) +420085
       System.DirectoryServices.DirectoryEntry.Bind() +36
       System.DirectoryServices.DirectoryEntry.get_AdsObject() +31
       System.DirectoryServices.DirectorySearcher.FindAll(Boolean findMoreThanOne) +78
       System.DirectoryServices.DirectorySearcher.FindAll() +9
       HAP.AD.ADUtil.FindUsers(ouobject ou, String subou) +324
    
    [Exception: LDAP://CURRIC-B.astonmanor.bham.sch.uk/OU=Users,DC=astonmanor,DC=bham,DC=sch,DC=uk]
       HAP.AD.ADUtil.FindUsers(ouobject ou, String subou) +1119
       HAP.AD.ADUtil.FindUsers() +193
       HAP.Web.BookingSystem.BookingPopup.Page_Load(Object sender, EventArgs e) +100
       System.Web.Util.CalliHelper.EventArgFunctionCaller(IntPtr fp, Object o, Object t, EventArgs e) +14
       System.Web.Util.CalliEventHandlerDelegateProxy.Callback(Object sender, EventArgs e) +35
       System.Web.UI.Control.OnLoad(EventArgs e) +91
       System.Web.UI.Control.LoadRecursive() +74
       System.Web.UI.Control.LoadRecursive() +146
       System.Web.UI.Control.LoadRecursive() +146
       System.Web.UI.Control.LoadRecursive() +146
       System.Web.UI.Control.LoadRecursive() +146
       System.Web.UI.Control.LoadRecursive() +146
       System.Web.UI.Control.LoadRecursive() +146
       System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +2207
    
     
    
    
    --------------------------------------------------------------------------------
    Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.0.30319.1
    I tried adding a new AD group to access the admin bookings incase there was an issue with my admin account but the same happened again.

    Thank you as always and ama178 let me know how you get on.

  8. #23
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,561
    Thank Post
    38
    Thanked 507 Times in 437 Posts
    Rep Power
    114
    The system uses OUs not AD Groups for getting a listing users.

  9. #24

    Join Date
    Nov 2008
    Location
    Birmingham
    Posts
    127
    Thank Post
    27
    Thanked 15 Times in 14 Posts
    Rep Power
    14
    Quote Originally Posted by nickbro View Post
    The system uses OUs not AD Groups for getting a listing users.
    My mistake I meant OU. I still have the issue as when the domain admin clicks on the bookings icon this appears:
    Code:
    Server Error in '/Extranet' Application.
    --------------------------------------------------------------------------------
    
    There is no such object on the server.
    
    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code. 
    
    Exception Details: System.DirectoryServices.DirectoryServicesCOMException: There is no such object on the server.
    
    
    Source Error: 
    
    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.  
    
    Stack Trace: 
    
    
    [DirectoryServicesCOMException (0x80072030): There is no such object on the server.
    ]
       System.DirectoryServices.DirectoryEntry.Bind(Boolean throwIfFail) +420085
       System.DirectoryServices.DirectoryEntry.Bind() +36
       System.DirectoryServices.DirectoryEntry.get_AdsObject() +31
       System.DirectoryServices.DirectorySearcher.FindAll(Boolean findMoreThanOne) +78
       System.DirectoryServices.DirectorySearcher.FindAll() +9
       HAP.AD.ADUtil.FindUsers(ouobject ou, String subou) +324
    
    [Exception: LDAP://CURRIC-B.astonmanor.bham.sch.uk/OU=Users,DC=astonmanor,DC=bham,DC=sch,DC=uk]
       HAP.AD.ADUtil.FindUsers(ouobject ou, String subou) +1119
       HAP.AD.ADUtil.FindUsers() +193
       HAP.Web.BookingSystem.BookingPopup.Page_Load(Object sender, EventArgs e) +100
       System.Web.Util.CalliHelper.EventArgFunctionCaller(IntPtr fp, Object o, Object t, EventArgs e) +14
       System.Web.Util.CalliEventHandlerDelegateProxy.Callback(Object sender, EventArgs e) +35
       System.Web.UI.Control.OnLoad(EventArgs e) +91
       System.Web.UI.Control.LoadRecursive() +74
       System.Web.UI.Control.LoadRecursive() +146
       System.Web.UI.Control.LoadRecursive() +146
       System.Web.UI.Control.LoadRecursive() +146
       System.Web.UI.Control.LoadRecursive() +146
       System.Web.UI.Control.LoadRecursive() +146
       System.Web.UI.Control.LoadRecursive() +146
       System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +2207
    
     
    
    
    --------------------------------------------------------------------------------
    Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.0.30319.1
    I have spoken with a freind at another school and he has the same issue. Apart from that I'm all done thank you.

  10. #25

    Join Date
    Nov 2008
    Location
    Birmingham
    Posts
    127
    Thank Post
    27
    Thanked 15 Times in 14 Posts
    Rep Power
    14
    deleted
    Last edited by Wils86; 8th June 2011 at 03:18 PM. Reason: entered in error

SHARE:
+ Post New Thread
Page 2 of 2 FirstFirst 12

Similar Threads

  1. RM Connector (Install issues)
    By gpjt in forum Network and Classroom Management
    Replies: 4
    Last Post: 24th December 2009, 11:57 AM
  2. Citrix XenApp 5 Farm install issues
    By keogk in forum Thin Client and Virtual Machines
    Replies: 0
    Last Post: 20th October 2009, 08:24 PM
  3. Adobe CS3 install issues (yes, again!)
    By deKay in forum Windows
    Replies: 12
    Last Post: 21st November 2008, 09:55 AM
  4. Install Issues.
    By rob_coles in forum EduGeek Joomla 1.0 Package
    Replies: 6
    Last Post: 2nd April 2008, 08:20 AM
  5. Squid issues new install
    By ChrisH in forum *nix
    Replies: 5
    Last Post: 10th November 2005, 03:09 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •