+ Post New Thread
Page 28 of 53 FirstFirst ... 1824252627282930313238 ... LastLast
Results 406 to 420 of 785
Home Access Plus+ Thread, Home Access Plus+ in Projects:; Originally Posted by AngryTechnician I hope your school appreciates how fortunate they are to have a talented coder on staff, ...
  1. #406
    dgsmith's Avatar
    Join Date
    Nov 2007
    Location
    Merseyside, England
    Posts
    1,104
    Thank Post
    118
    Thanked 90 Times in 78 Posts
    Rep Power
    36
    Quote Originally Posted by AngryTechnician View Post
    I hope your school appreciates how fortunate they are to have a talented coder on staff, and of the enormous benefit to the community of releasing it freely. I know plenty of schools would be very eager to cash in, especially right now, and it's a testament to you and your school's management that they haven't done so.

    Thanks,
    AT
    Very well said. Totally agree here - it is a fantastic product!

    On a side note, thanks AT for publishing your testing with a standard user account. I too am very concerned about using the domain admin account (not least, as you say, about having the credentials in the web.config file too), so it is promising to see it may not cause problems to use an account with somewhat lesser priviledges, which i'd imagine would certainly be safer.
    Last edited by dgsmith; 26th December 2010 at 04:04 PM.

  2. #407
    dgsmith's Avatar
    Join Date
    Nov 2007
    Location
    Merseyside, England
    Posts
    1,104
    Thank Post
    118
    Thanked 90 Times in 78 Posts
    Rep Power
    36
    Quote Originally Posted by nickbro View Post
    Security wise, the Admin Username/Password is only for AD calls, it is not used anywhere else. The web.config file cannot be accessed through http. You can use a standard user, that is fine, but delegate access would be needed for something to work (mainly in the booking system/help desk). The updating of user info is done under identity impersonate, so it's accessing AD using the users own credentials.
    If we do not use the booking system/helpdesk, is there any reason at all why we should be (or is there any benefit in) using a/the domain admin account vs a standard user account?

  3. #408
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,483
    Thank Post
    37
    Thanked 490 Times in 422 Posts
    Rep Power
    110
    Quote Originally Posted by dgsmith View Post
    If we do not use the booking system/helpdesk, is there any reason at all why we should be (or is there any benefit in) using a/the domain admin account vs a standard user account?
    None at all.

    Really as long as you give some form of delegate access you can use a standard account. (The system just needs to be able to get a user list and perform queries in AD (what roles a user has, what OU a user is in etc...)

  4. #409

    AngryTechnician's Avatar
    Join Date
    Oct 2008
    Posts
    3,730
    Thank Post
    698
    Thanked 1,211 Times in 761 Posts
    Rep Power
    394
    Quote Originally Posted by nickbro View Post
    Silverlight using a port, well that should be already working, since the way my silverlight app works, it uses the web browsers URL and just rewrites the end of it for the API calls.
    I tried it, but the rewriting seems to be dropping the alternate port definition off the end at some point. If I'm at the root of My Computer (https://internal.angrytech.com:8443/Extranet/MyComputerSL.aspx) and double click the N: drive, the N: drive flashes up for a second but is then redirected to https://internal.angrytech.com/Extranet/MyComputerSL.aspx#n - without the :8443 port definition.

    Quote Originally Posted by nickbro View Post
    RE: The Application Request Routing problem, can you try the attached ZIP file and give feedback. It contains an updated HAP.web.dll file
    No change I'm afraid.
    Last edited by AngryTechnician; 27th December 2010 at 11:49 AM.

  5. #410
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,483
    Thank Post
    37
    Thanked 490 Times in 422 Posts
    Rep Power
    110
    Quote Originally Posted by AngryTechnician View Post
    I tried it, but the rewriting seems to be dropping the alternate port definition off the end at some point. If I'm at the root of My Computer (https://internal.angrytech.com:8443/...omputerSL.aspx) and double click the N: drive, the N: drive flashes up for a second but is then redirected to https://internal.angrytech.com/Extra...puterSL.aspx#n - without the :8443 port definition.
    Try the attached silverlight version, extract the XAP file into the client bin folder
    Attachment 8989

  6. Thanks to nickbro from:

    AngryTechnician (1st January 2011)

  7. #411

    AngryTechnician's Avatar
    Join Date
    Oct 2008
    Posts
    3,730
    Thank Post
    698
    Thanked 1,211 Times in 761 Posts
    Rep Power
    394
    Quote Originally Posted by nickbro View Post
    Try the attached silverlight version, extract the XAP file into the client bin folder
    Attachment 8989
    Alternate port works great with that, many thanks! Given the bank holiday I should really say 'stop doing work', but that would be slightly hypocritical of me...

  8. #412

    john's Avatar
    Join Date
    Sep 2005
    Location
    London
    Posts
    10,511
    Thank Post
    1,493
    Thanked 1,050 Times in 919 Posts
    Rep Power
    302
    Just wanted to post that, for some reason I've managed to overlook and not realise that we had this amazing product linked to on here! (or if I had done in the past it had escaped my mind!!) anyway, I've just set it up tonight on my system at work, and fine I need to sort an SSL out for it and get the LA to do a DNS entry, but I've got it working fine over my ADSL link to work, and accessing files fine, it really is a great tool so well done on it and sharing it with us

  9. #413
    mrbios's Avatar
    Join Date
    Jun 2007
    Location
    Stroud, Gloucestershire
    Posts
    2,449
    Thank Post
    349
    Thanked 255 Times in 210 Posts
    Rep Power
    98
    First day back, just got around to updating, thank you very much for the last update nickbro im very happy with how ours looks now
    Attached Thumbnails Attached Thumbnails Home Access Plus+-hap.png  

  10. #414
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,483
    Thank Post
    37
    Thanked 490 Times in 422 Posts
    Rep Power
    110
    Quote Originally Posted by mrbios View Post
    First day back, just got around to updating, thank you very much for the last update nickbro im very happy with how ours looks now
    Wow, that looks really cool. How much does the Office TS licenses cost?

  11. #415
    mrbios's Avatar
    Join Date
    Jun 2007
    Location
    Stroud, Gloucestershire
    Posts
    2,449
    Thank Post
    349
    Thanked 255 Times in 210 Posts
    Rep Power
    98
    Quote Originally Posted by nickbro View Post
    Wow, that looks really cool. How much does the Office TS licenses cost?
    Well that's an issue, i'm unsure of the legality with it, most teachers have purchased the home use program which we have via our MSVL so they would be covered, we have excess licenses too as we always expand the amount of PCs year on year, i assume that also means we're covered. I assume we should be purchasing an extra 150 (assuming that's the number of staff we have) office licenses on top of our usual required amount.

    I was unaware as to whether there was any terminal server specific licenses though? could they be cheaper than the way we're doing it now? (adding on to our VL)

  12. #416
    mrbios's Avatar
    Join Date
    Jun 2007
    Location
    Stroud, Gloucestershire
    Posts
    2,449
    Thank Post
    349
    Thanked 255 Times in 210 Posts
    Rep Power
    98
    Found a problem mentioned by a member of staff this morning, see the image below, could it be to do with the "+" symbol in the folder name?
    Attached Thumbnails Attached Thumbnails Home Access Plus+-haperror.png  

  13. #417

    Join Date
    Mar 2010
    Location
    Leeds
    Posts
    418
    Thank Post
    77
    Thanked 46 Times in 41 Posts
    Rep Power
    17
    yes this is true, + and & symbols do not work in home access plus for file or folders.

  14. #418
    mrbios's Avatar
    Join Date
    Jun 2007
    Location
    Stroud, Gloucestershire
    Posts
    2,449
    Thank Post
    349
    Thanked 255 Times in 210 Posts
    Rep Power
    98
    Quote Originally Posted by jonnykewell1 View Post
    yes this is true, + and & symbols do not work in home access plus for file or folders.
    Ah ok, mildly annoying but not a huge issue i guess and easily resolved

  15. #419
    sister_annex's Avatar
    Join Date
    Jan 2009
    Location
    Wolverhampton
    Posts
    593
    Thank Post
    99
    Thanked 135 Times in 119 Posts
    Rep Power
    49
    From the hap website Home Access Plus

    Problem with + in folder/file name
    Run:
    Code:
    %windir%\system32\inetsrv\appcmd set config "Default Web Site" -section:system.webServer/security/requestFiltering -allowDoubleEscaping:true
    HTH

    Mark

  16. 3 Thanks to sister_annex:

    AngryTechnician (7th January 2011), jonnykewell1 (7th January 2011), mrbios (7th January 2011)

  17. #420

    AngryTechnician's Avatar
    Join Date
    Oct 2008
    Posts
    3,730
    Thank Post
    698
    Thanked 1,211 Times in 761 Posts
    Rep Power
    394
    If like me you are afraid of the command line, here's where the setting is in IIS7:

    Home Access Plus+-filtering.png Home Access Plus+-feature.png

  18. 3 Thanks to AngryTechnician:

    mrbios (7th January 2011), sister_annex (14th January 2011), themightymrp (10th January 2011)

SHARE:
+ Post New Thread

Similar Threads

  1. Home Access
    By nickbro in forum Internet Related/Filtering/Firewall
    Replies: 0
    Last Post: 7th July 2010, 10:48 PM
  2. o2 Home Access
    By russdev in forum General Chat
    Replies: 5
    Last Post: 21st November 2009, 09:08 PM
  3. Access from home
    By button_ripple in forum How do you do....it?
    Replies: 30
    Last Post: 15th October 2008, 07:35 PM
  4. Home Access
    By FragglePete in forum How do you do....it?
    Replies: 14
    Last Post: 15th October 2008, 03:18 PM
  5. Access from home???
    By Outpost in forum Wireless Networks
    Replies: 3
    Last Post: 11th February 2006, 12:01 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •