+ Post New Thread
Page 24 of 53 FirstFirst ... 1420212223242526272834 ... LastLast
Results 346 to 360 of 785
Home Access Plus+ Thread, Home Access Plus+ in Projects:; Nickbro, seeing as you said you could not get it to work with the Windows Authentication I am attaching a ...
  1. #346
    themightymrp's Avatar
    Join Date
    Dec 2009
    Location
    Leeds, West Yorkshire
    Posts
    1,269
    Thank Post
    218
    Thanked 235 Times in 203 Posts
    Rep Power
    75

    Setting up via Windows Authentication

    Nickbro, seeing as you said you could not get it to work with the Windows Authentication I am attaching a setup guide to show what I did. I have actually sent this to a technician in another school as he wants to use this software too!
    Attached Files Attached Files

  2. 3 Thanks to themightymrp:

    box_l (6th December 2010), jonnykewell1 (30th November 2010), sister_annex (29th November 2010)

  3. #347

    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,675
    Thank Post
    43
    Thanked 557 Times in 465 Posts
    Rep Power
    122
    Quote Originally Posted by themightymrp View Post
    Hi, thanks for the response. Just realised though from reading my first post that I actually asked the wrong question! What I would like to be able to do is have Administrators and Staff be able to update their email address but hide that feature from students. The reason for this is that our ISP provides seperate usernames and passwords to log onto the internet/email that bear no resemblance to our Domain logon names I would like staff to be able to enter their emails so that they receive confirmation when they book resources (I know this will work because I tried it as me). Is it easy to add some code to do this?
    Look under homepage links. The Update My Details entry, you can add showto="" in there

  4. #348

    Join Date
    Mar 2010
    Location
    Leeds
    Posts
    433
    Thank Post
    85
    Thanked 48 Times in 43 Posts
    Rep Power
    18
    Hi, iv almost got the home access fully configured, the only problem im having is when i click on the mapped network drive it comes up saying Error:Unauthorised access.

    Any help would be very much appreciated.

  5. #349
    Luke_T's Avatar
    Join Date
    Mar 2008
    Location
    St Albans, Herts
    Posts
    336
    Thank Post
    56
    Thanked 20 Times in 17 Posts
    Rep Power
    18
    I found this was due to an extra backslash on the end of the mapped drive location that wasn't needed eg:

    \\server\share\ is incorrect
    \\server\share is correct

    Otherwise there's the regular permissions, security group issues detailed in previous posts

  6. #350

    Join Date
    Mar 2010
    Location
    Leeds
    Posts
    433
    Thank Post
    85
    Thanked 48 Times in 43 Posts
    Rep Power
    18
    iv got it pointing to \\servername\users$\administrators then i need to to select my stored drive which i thought would be %username% or %user% ?

  7. #351
    themightymrp's Avatar
    Join Date
    Dec 2009
    Location
    Leeds, West Yorkshire
    Posts
    1,269
    Thank Post
    218
    Thanked 235 Times in 203 Posts
    Rep Power
    75
    In this code you use {0} to represent the username, not %username%. Therefore you would need \\servername\users$\administrators\{0}

  8. #352
    themightymrp's Avatar
    Join Date
    Dec 2009
    Location
    Leeds, West Yorkshire
    Posts
    1,269
    Thank Post
    218
    Thanked 235 Times in 203 Posts
    Rep Power
    75
    Quote Originally Posted by nickbro View Post
    Look under homepage links. The Update My Details entry, you can add showto="" in there
    I can see that part, unfortunately on the update my details popup screen there is no option for email address!

  9. #353

    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,675
    Thank Post
    43
    Thanked 557 Times in 465 Posts
    Rep Power
    122
    Quote Originally Posted by themightymrp View Post
    I can see that part, unfortunately on the update my details popup screen there is no option for email address!
    Yer I don't update the email ad settings. Since in our school the staff's emails are exchange based. The kids are hmailserver based, on a sub domain, which is where this updating thing comes from.

  10. #354

    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,675
    Thank Post
    43
    Thanked 557 Times in 465 Posts
    Rep Power
    122
    Quote Originally Posted by themightymrp View Post
    Nickbro, seeing as you said you could not get it to work with the Windows Authentication I am attaching a setup guide to show what I did. I have actually sent this to a technician in another school as he wants to use this software too!
    Looks good. You need to note however that %username% needs to be replaced with {0}. {0} gets the username populated at runtime, %username% does not

  11. #355
    Zenden's Avatar
    Join Date
    Mar 2009
    Location
    Manchester
    Posts
    154
    Thank Post
    71
    Thanked 32 Times in 25 Posts
    Rep Power
    17
    Just installed this and I have to say it really is very ver well done, big thanks for this! Just wondering, we have HAP and Moodle both using LDAP for the authentication, would it be possible to allow SSO from HAP to moodle (as moodle hosts our helpdesk and booking system?).

    Thanks in advance and thanks again for a truely great piece of work!

  12. #356
    dgsmith's Avatar
    Join Date
    Nov 2007
    Location
    Merseyside, England
    Posts
    1,110
    Thank Post
    119
    Thanked 90 Times in 78 Posts
    Rep Power
    37
    Just installed this over and weekend, and after fixing a few minor issues in the config file, got it working fine now. I am not too happy with using basic authentication though. I tried switching over to digest but now it seems only domain admin accounts can authenticate and it won't accept the credentials of non-admin accounts.

    Am I naive in thinking it is that easy? Is there a reason why we should be using basic and not digest? Is there a reason why only domain admin accounts only work on digest, but any valid account will work on basic?

    I also tried to enable forms authentication but got an error about an invalid/non-existant login script file, so reverted that for the time being. All I need now is to get our LEA to open up access to it externally and we're ready to go, but just a bit concerned about using basic authentication! Also quite annoying that you need to close the broswer to log off - can this be improved upon in a future release to have an actual logoff procedure? I see it has been discussed already but merely stating the point I am making!

  13. #357
    themightymrp's Avatar
    Join Date
    Dec 2009
    Location
    Leeds, West Yorkshire
    Posts
    1,269
    Thank Post
    218
    Thanked 235 Times in 203 Posts
    Rep Power
    75
    See my instruction file at the top of this page as to how to set up using Windows Authentication. I have it working here

  14. #358
    dgsmith's Avatar
    Join Date
    Nov 2007
    Location
    Merseyside, England
    Posts
    1,110
    Thank Post
    119
    Thanked 90 Times in 78 Posts
    Rep Power
    37
    Would Windows Authentication mean that we wouldn't be able to specify a user/pass when logging on within school? Is it much improved from a security angle than basic (talking about logging on externally/from home)?

  15. #359
    themightymrp's Avatar
    Join Date
    Dec 2009
    Location
    Leeds, West Yorkshire
    Posts
    1,269
    Thank Post
    218
    Thanked 235 Times in 203 Posts
    Rep Power
    75
    You are right about the logging on in school part, within the school it recognises who is logged onto the machine and uses those credentials to bring up the page automatically. As from a security standpoint, I'm not 100% certain but surely anything other than basic has to be more secure? It's encrypted with Kerberos isn't it??
    If anyone else knows I would be happy to find out.

  16. #360
    dgsmith's Avatar
    Join Date
    Nov 2007
    Location
    Merseyside, England
    Posts
    1,110
    Thank Post
    119
    Thanked 90 Times in 78 Posts
    Rep Power
    37
    I suppose, though would like a login box regardless of where they're logging on!

    Something else I noticed too - our staff have Mr/Mrs Bloggs at their display name (for obvious reasons not having first name), but when they change their department or just update their details, it changes the display name as well to what they put in the first name. This isn't good! Fine that it replaced the first and last name fields and even the surname in display name, but we don't want their full names showing up to everyone (including students) in outlook. Can this be fixed asap?

    Also, how can we pull down extra details in the home page from the AD (like we have name, form/dept and email now)? I take it this is hard coded in a dll somewhere?



SHARE:
+ Post New Thread

Similar Threads

  1. Home Access
    By nickbro in forum Internet Related/Filtering/Firewall
    Replies: 0
    Last Post: 7th July 2010, 11:48 PM
  2. o2 Home Access
    By russdev in forum General Chat
    Replies: 5
    Last Post: 21st November 2009, 10:08 PM
  3. Access from home
    By button_ripple in forum How do you do....it?
    Replies: 30
    Last Post: 15th October 2008, 08:35 PM
  4. Home Access
    By FragglePete in forum How do you do....it?
    Replies: 14
    Last Post: 15th October 2008, 04:18 PM
  5. Access from home???
    By Outpost in forum Wireless Networks
    Replies: 3
    Last Post: 11th February 2006, 01:01 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •