+ Post New Thread
Page 1 of 2 12 LastLast
Results 1 to 15 of 18
Home Access Plus+ Thread, Home Access Plus Version 10 Issues in Projects:; Hi Nick/ Everyone, I have just installed HAP and love it. I only seem to be having 2 issues with ...
  1. #1

    Join Date
    Sep 2013
    Location
    Worcestershire
    Posts
    104
    Thank Post
    2
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Home Access Plus Version 10 Issues

    Hi Nick/ Everyone,

    I have just installed HAP and love it. I only seem to be having 2 issues with it at the moment. The first issue is the timetable.
    I have exported the data using the report into the correct location for hap. I then made sure the student had a UPN Number in their employee ID ADDS account and clicked the convert Sims.net Export Button. Nothing seemed to happen but i carried on loggin in as the student. Tried to view the timetable and get a little red message "Invalid URL, The host name could not be phased"

    how can i fix this and get the timetable to work?

    My second Problem is the booking system Gives me an error on import that it cannot find the teacher. I have made sure the ADDS display name is the same as sims and still no luck!

    Thanks ALL

    P.s LOVE HAP

  2. #2

    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,690
    Thank Post
    43
    Thanked 560 Times in 468 Posts
    Rep Power
    124
    You need to store UPN's in the employeeID field in AD.

    Also, looks like you've enabled EWS, remove the https bit from the exchange attribute of the SMTP element in the hapConfig.

  3. #3

    Join Date
    Sep 2013
    Location
    Worcestershire
    Posts
    104
    Thank Post
    2
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Thanks for the reply Nick ! I havnt enable ews or any of the smtp settings. I have set the UPN in the employeeID. And it just doesn't load anything on the time table ?

    Thanks Nick !

  4. #4

    Join Date
    Sep 2013
    Location
    Worcestershire
    Posts
    104
    Thank Post
    2
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Hi nick, Still cannot get this timetable to work. its giving me the "invalid Url " Error

    Home Access Plus Version 10 Issues-hap-timetable-error.png

    I have ran the timetable report and put it into \inetpub\wwwroot\HAP\App_Data\timetableexport.xml

    I have made sure the UPN Number is in the Employee ID Field and still no joy.

    Thanks !

  5. #5

    Join Date
    Sep 2013
    Location
    Worcestershire
    Posts
    104
    Thank Post
    2
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Just Debugged the Invalid URL Error with Firebug and this is the error
    "NetworkError: 400 An WCF Error has Occured - https://OURSCHOOLURL/HAP/api/Timetable/Load/16-6-2014/20-6-2014?1403206606031"

    Does this help at all ?

  6. #6

    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,690
    Thank Post
    43
    Thanked 560 Times in 468 Posts
    Rep Power
    124
    1) Are you logged on a student or staff
    2) Have you converted the export?
    3) do you have exchange?
    4) do you have your timetable in the calendar?

  7. #7

    Join Date
    Sep 2013
    Location
    Worcestershire
    Posts
    104
    Thank Post
    2
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    I'm logged on as a domain admin with a student upn in my employee I'd field for testing purposes.

    I have clicked covert Sims.net export

    We are running exchange 2013

    Not yet but could be something to look into

    Thanks Nick

  8. #8

    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,690
    Thank Post
    43
    Thanked 560 Times in 468 Posts
    Rep Power
    124
    Ok, you will need to use Options -> Impersonate user, enter the upn and click UPN. The system checks the user's ad group

  9. #9

    Join Date
    Sep 2013
    Location
    Worcestershire
    Posts
    104
    Thank Post
    2
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Managed to get the booking system working kind of, I am having an issue with the import of the sims.net data. Sims is exporting the data like this:

    Code:
    <SuperStarReport>
    <Record>
    <Name>AR1</Name>
    <MainTeacher>Mrs R M L Evans</MainTeacher>
    <Description>Art</Description>
    <Name1>AMon:3</Name1>
    <YearGroup>Year 09</YearGroup>
    </Record> 
    </SuperStarReport>
    I think format of the <Name1> is the issue as hap is then importing the booking like this:

    Code:
    <?xml version="1.0" encoding="utf-8"?>
    <Bookings>
      <Booking day="-1" lesson="Period 3" room="AR1" name="Year 09 Art" username="evansr" />
    </Bookings>

    This may have been covered before but cant seem to find a fix or work around ?

    Thanks!

  10. #10

    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,690
    Thank Post
    43
    Thanked 560 Times in 468 Posts
    Rep Power
    124
    So a find and replace, AMon to Mon1 etc... BMon to Mon2 etc, and see if that works then

  11. #11

    Join Date
    Sep 2013
    Location
    Worcestershire
    Posts
    104
    Thank Post
    2
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Hi Nick, Thanks for the reply,

    I have done a find and replace so the Sims export looks like this:
    Code:
    <?xml version="1.0" standalone="yes"?>
    <SuperStarReport>
      <Record>
        <Name>AR1</Name>
        <MainTeacher>Mrs R M L Evans</MainTeacher>
        <Description>Art</Description>
        <Name1>Mon1:3</Name1>
        <YearGroup>Year 09</YearGroup>
      </Record>
      <Record>
        <Name>AR1</Name>
        <MainTeacher>Mrs R M L Evans</MainTeacher>
        <Description>Art</Description>
        <Name1>Tue1:3</Name1>
        <YearGroup>Year 12</YearGroup>
      </Record>
      <Record>
        <Name>AR1</Name>
        <MainTeacher>Mrs R M L Evans</MainTeacher>
        <Description>Art</Description>
        <Name1>Tue1:3</Name1>
        <YearGroup>Year 13</YearGroup>
      </Record>
      <Record>
        <Name>AR1</Name>
        <MainTeacher>Mrs R M L Evans</MainTeacher>
        <Description>Art</Description>
        <Name1>Tue1:4</Name1>
        <YearGroup>Year 12</YearGroup>
      </Record>
      <Record>
        <Name>AR1</Name>
        <MainTeacher>Mrs R M L Evans</MainTeacher>
        <Description>Art</Description>
        <Name1>Tue1:4</Name1>
        <YearGroup>Year 13</YearGroup>
      </Record>
      <Record>
        <Name>AR1</Name>
        <MainTeacher>Mrs R M L Evans</MainTeacher>
        <Description>Art</Description>
        <Name1>Thu1:3</Name1>
        <YearGroup>Year 09</YearGroup>
      </Record>
      <Record>
        <Name>AR1</Name>
        <MainTeacher>Mrs R M L Evans</MainTeacher>
        <Description>Art</Description>
        <Name1>Fri1:1</Name1>
        <YearGroup>Year 13</YearGroup>
      </Record>
      <Record>
        <Name>AR1</Name>
        <MainTeacher>Mrs R M L Evans</MainTeacher>
        <Description>Art</Description>
        <Name1>Fri1:2</Name1>
        <YearGroup>Year 12</YearGroup>
      </Record>
      <Record>
        <Name>AR1</Name>
        <MainTeacher>Mrs R M L Evans</MainTeacher>
        <Description>Art</Description>
        <Name1>Fri1:2</Name1>
        <YearGroup>Year 13</YearGroup>
      </Record>
      <Record>
        <Name>AR1</Name>
        <MainTeacher>Mrs R M L Evans</MainTeacher>
        <Description>Art</Description>
        <Name1>Tue2:3</Name1>
        <YearGroup>Year 09</YearGroup>
      </Record>
      <Record>
        <Name>AR1</Name>
        <MainTeacher>Mrs R M L Evans</MainTeacher>
        <Description>Art</Description>
        <Name1>Tue2:4</Name1>
        <YearGroup>Year 12</YearGroup>
      </Record>
      <Record>
        <Name>AR1</Name>
        <MainTeacher>Mrs R M L Evans</MainTeacher>
        <Description>Art</Description>
        <Name1>Tue2:4</Name1>
        <YearGroup>Year 13</YearGroup>
      </Record>
    </SuperStarReport>
    Hap then seems to convert it to :
    Code:
    <?xml version="1.0" encoding="utf-8"?>
    <Bookings>
      <Booking day="1" lesson="Period 3" room="AR1" name="Year 09 Art" username="evansr" />
      <Booking day="1" lesson="Period 4" room="AR1" name="Year 13 Art" username="evansr" />
      <Booking day="1" lesson="Period 1" room="AR1" name="Year 13 Art" username="evansr" />
      <Booking day="1" lesson="Period 2" room="AR1" name="Year 13 Art" username="evansr" />
      <Booking day="2" lesson="Period 3" room="AR1" name="Year 09 Art" username="evansr" />
      <Booking day="2" lesson="Period 4" room="AR1" name="Year 13 Art" username="evansr" />
    </Bookings>
    The booking day is showing the week rather than the day, We have a two week timetable.
    Thanks !

  12. #12

    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,690
    Thank Post
    43
    Thanked 560 Times in 468 Posts
    Rep Power
    124
    The day part of the bookings list is the day number, 1-5 or 1-10 (2 week timetable)

  13. #13

    Join Date
    Sep 2013
    Location
    Worcestershire
    Posts
    104
    Thank Post
    2
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Yeah, I can't work out why HAP is converting MON2 to day 2 instead of day 6 as it's the second Monday in the two week timetable

  14. #14

    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,690
    Thank Post
    43
    Thanked 560 Times in 468 Posts
    Rep Power
    124
    O, wrong format, doh, it requires DayX:Y

    So Day1:1, Day2:1, Day6:1, Da10:10 etc.

  15. #15

    Join Date
    Sep 2013
    Location
    Worcestershire
    Posts
    104
    Thank Post
    2
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Brilliant will have a play shortly and let you know thanks Nick !



SHARE:
+ Post New Thread
Page 1 of 2 12 LastLast

Similar Threads

  1. Home Access Plus+
    By nickbro in forum Home Access Plus+
    Replies: 784
    Last Post: 24th February 2014, 04:39 PM
  2. Home Access Plus Issue
    By kefw in forum Home Access Plus+
    Replies: 3
    Last Post: 20th June 2013, 03:05 PM
  3. Home Access Plus v7.2 - Outstanding Issues
    By mattgrimley in forum Home Access Plus+
    Replies: 7
    Last Post: 4th October 2011, 10:38 AM
  4. Home Access Plus+ V7 Booking System Issues
    By wdwm in forum Home Access Plus+
    Replies: 20
    Last Post: 24th September 2011, 09:23 PM
  5. Home Access Plus - How Secure?
    By andy_d in forum Internet Related/Filtering/Firewall
    Replies: 9
    Last Post: 31st March 2011, 01:30 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •