+ Post New Thread
Results 1 to 5 of 5
Home Access Plus+ Thread, HAP+ v10 Preview 4 in Projects:; Morning I've popped the preview 4 on to my beta server. The only difference for me was the dll's - ...
  1. #1
    mattgrimley's Avatar
    Join Date
    Jun 2011
    Location
    Bedfordshire
    Posts
    321
    Thank Post
    36
    Thanked 22 Times in 20 Posts
    Blog Entries
    1
    Rep Power
    10

    HAP+ v10 Preview 4

    Morning

    I've popped the preview 4 on to my beta server. The only difference for me was the dll's - but my beta server is now behaving oddly..
    Probably all related, but here is what i can see

    1> Login and it starts to load, but no tiles appear - i don't get the NTLM authenticated splash screen either. I can see the top groups, but no tiles.
    Firebug says:
    ReferenceError: hap is not defined / hap.load = hap.loadtypes.help; /beta/ (line 466)
    ReferenceError: hap is not defined / hap.livetiles.Init([ /beta/ (line 145)
    ReferenceError: hap is not defined / hap.help.Load('impmsg'); return false; onclick (line 2)
    2> Using a non NTLM-Auth connection, on the login page the "Home Access Plus+" button is visible at the top left.
    3> Using a non NTLM-Auth connection, on the login page the "Login" button is not a button, just a hyper-link.


    If i revert the HAP.Web.dll back to my previous version it works again..

    Hope this helps!

    Matt

  2. #2

    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,649
    Thank Post
    43
    Thanked 553 Times in 461 Posts
    Rep Power
    122
    That teaches me for not testing the new minification code, switched to using a Microsoft dll. Updated the release, HAP.Web.dll and HAP.Web.Controls.dll are all that needs updating, and the new AJAXMini.dll
    Last edited by nickbro; 1st April 2014 at 05:55 PM.

  3. Thanks to nickbro from:

    mattgrimley (2nd April 2014)

  4. #3
    mattgrimley's Avatar
    Join Date
    Jun 2011
    Location
    Bedfordshire
    Posts
    321
    Thank Post
    36
    Thanked 22 Times in 20 Posts
    Blog Entries
    1
    Rep Power
    10
    Looking good from here, thanks!


    Can I ask a totally unrelated question?
    When a user attempts to login with an expired password, does HAP know it's expired rather than just wrong? I.e. Can the message returned to the user be different in each case?

    I've enabled password changing on our exchange server, so I'd ideally like to be able to redirect them to that page in the event of an expired password.. The page is https://exchange-server/owa/auth/expiredpassword.aspx


    FYI: Documentation on enabling password changing on exchange: So you want to change your expired passwords in OWA... - Exchange Team Blog - Site Home - TechNet Blogs

    Failing that, i guess i could put a permanent link to the password change page under the login on the homepage?

  5. #4

    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,649
    Thank Post
    43
    Thanked 553 Times in 461 Posts
    Rep Power
    122
    Done, will be in the final release. The system will check to see if the user's password has expired, account is disabled or locked out before attempting to logon

    The strings will be in the strings.xml file so you can customize them
    Last edited by nickbro; 2nd April 2014 at 06:26 PM.

  6. #5
    mattgrimley's Avatar
    Join Date
    Jun 2011
    Location
    Bedfordshire
    Posts
    321
    Thank Post
    36
    Thanked 22 Times in 20 Posts
    Blog Entries
    1
    Rep Power
    10
    oh wow! Amazing!! Thanks Nick

SHARE:
+ Post New Thread

Similar Threads

  1. Help Desk using SQL - HAP v10 Preview 3
    By Paul-K in forum Home Access Plus+
    Replies: 2
    Last Post: 28th March 2014, 10:03 AM
  2. HAP+ 10 Preview 2 install issue - Service Activated Error
    By Paul-K in forum Home Access Plus+
    Replies: 12
    Last Post: 23rd March 2014, 03:11 PM
  3. HAP+ v10 Preview 2 - /api/tiles/ 404
    By deebee in forum Home Access Plus+
    Replies: 15
    Last Post: 20th March 2014, 04:22 PM
  4. HAP+ 10 Preview 2 Uploading files
    By toffee in forum Home Access Plus+
    Replies: 6
    Last Post: 16th March 2014, 03:24 PM
  5. [HAP+][v10] - New Helpdesk
    By nickbro in forum Home Access Plus+
    Replies: 14
    Last Post: 22nd February 2014, 08:32 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •