+ Post New Thread
Page 1 of 2 12 LastLast
Results 1 to 15 of 20
Home Access Plus+ Thread, Booking System: Error: Unauthorised Access in Projects:; We are currently using HAP Booking system for two of our locations. I am setting up the third location and ...
  1. #1

    Join Date
    Mar 2014
    Location
    Connecticut
    Posts
    10
    Thank Post
    1
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Booking System: Error: Unauthorised Access

    We are currently using HAP Booking system for two of our locations. I am setting up the third location and the staff can not access the Booking System. I can since I am an administrator. I am truly stuck. I have tried changing the show to "All" and then back to my staff Group. Below is the web.config from the booking system folder and then web from the root folder.


    <?xml version="1.0"?>
    <configuration>
    <system.web>
    <authorization>
    <allow users="*" />
    <deny users="?" />
    </authorization>
    </system.web>
    <location path="Default.aspx">
    <system.web>
    <authorization>
    <allow roles="MOH Staff, Domain Admins" />
    <deny users="*" />
    </authorization>
    </system.web>
    </location>
    <location path="New.aspx">
    <system.web>
    <authorization>
    <allow roles="MOH Staff, Domain Admins" />
    <deny users="*" />
    </authorization>
    </system.web>
    </location>
    </configuration>


    <?xml version="1.0" encoding="utf-8"?>
    <!--
    Under IIS7.5, the application pool identity will be IIS APPPOOL\$apppool$, where $apppool$ is the application pool have is running under. You will need to grant permission to the App_Data folder to this user
    -->
    <configuration>
    <connectionStrings>
    <add name="SQLConnectionString" connectionString="Server=localhost;Database=hap;Tr usted_Connection=True;" />
    </connectionStrings>
    <system.web>
    <sessionState mode="InProc" compressionEnabled="true" />
    <pages>
    <controls>
    <add assembly="HAP.Web" namespace="HAP.Web.Controls" tagPrefix="hap" />
    </controls>
    </pages>
    <compilation debug="true">
    <assemblies>
    <add assembly="System.DirectoryServices, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A" />
    <add assembly="System.DirectoryServices.Protocols, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A" />
    <add assembly="System.DirectoryServices.AccountManageme nt, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" />
    </assemblies>
    </compilation>
    <authentication mode="Forms">
    <forms loginUrl="~/login.aspx" defaultUrl="~/" requireSSL="true" protection="All" />
    </authentication>
    <membership defaultProvider="admp">
    <providers>
    <clear />
    <add name="admp" type="HAP.AD.MembershipProvider" />
    </providers>
    </membership>
    <roleManager defaultProvider="adrp" enabled="true">
    <providers>
    <clear />
    <add name="adrp" type="HAP.AD.RoleProvider" />
    </providers>
    </roleManager>
    <authorization>
    <deny users="?" />
    </authorization>
    <customErrors mode="Off" />
    <globalization culture="en-GB" uiCulture="en-GB" />
    </system.web>
    <!--
    The system.webServer section is required for running ASP.NET AJAX under Internet
    Information Services 7.0. It is not necessary for previous version of IIS.
    -->
    <system.webServer>
    <modules runAllManagedModulesForAllRequests="true" />
    <validation validateIntegratedModeConfiguration="false" />
    <security>
    <requestFiltering>
    <hiddenSegments>
    <remove segment="App_WebReferences" />
    <remove segment="App_LocalResources" />
    <remove segment="App_GlobalResources" />
    <remove segment="App_code" />
    <remove segment="bin" />
    <remove segment="web.config" />
    <remove segment="App_Browsers" />
    </hiddenSegments>
    <fileExtensions>
    <remove fileExtension=".vsdisco" />
    <remove fileExtension=".sdmDocument" />
    <remove fileExtension=".sdm" />
    <remove fileExtension=".sd" />
    <remove fileExtension=".refresh" />
    <remove fileExtension=".msgx" />
    <remove fileExtension=".mdf" />
    <remove fileExtension=".lsaprototype" />
    <remove fileExtension=".ldf" />
    <remove fileExtension=".lddprototype" />
    <remove fileExtension=".ldd" />
    <remove fileExtension=".exclude" />
    <remove fileExtension=".dsprototype" />
    <remove fileExtension=".dd" />
    <remove fileExtension=".compiled" />
    <remove fileExtension=".cd" />
    <remove fileExtension=".adprototype" />
    <remove fileExtension=".ad" />
    <remove fileExtension=".ssmap" />
    <remove fileExtension=".ssdgm" />
    <remove fileExtension=".dsdgm" />
    <remove fileExtension=".ldb" />
    <remove fileExtension=".jsl" />
    <remove fileExtension=".java" />
    <remove fileExtension=".vjsproj" />
    <remove fileExtension=".mdb" />
    <remove fileExtension=".resources" />
    <remove fileExtension=".resx" />
    <remove fileExtension=".licx" />
    <remove fileExtension=".webinfo" />
    <remove fileExtension=".vbproj" />
    <remove fileExtension=".vb" />
    <remove fileExtension=".csproj" />
    <remove fileExtension=".skin" />
    <remove fileExtension=".ascx" />
    <remove fileExtension=".master" />
    <remove fileExtension=".browser" />
    <remove fileExtension=".sitemap" />
    <remove fileExtension=".cs" />
    <remove fileExtension=".lsad" />
    <remove fileExtension=".asax" />
    <remove fileExtension=".config" />
    </fileExtensions>
    </requestFiltering>
    </security>
    <staticContent>
    <!--For IIS8 Remove this Section -->
    <mimeMap fileExtension=".mp4" mimeType="video/mp4" />
    <mimeMap fileExtension=".m4v" mimeType="video/m4v" />
    <mimeMap fileExtension=".ogg" mimeType="video/ogg" />
    <mimeMap fileExtension=".ogv" mimeType="video/ogg" />
    <mimeMap fileExtension=".webm" mimeType="video/webm" />
    <mimeMap fileExtension=".oga" mimeType="audio/ogg" />
    <mimeMap fileExtension=".spx" mimeType="audio/ogg" />
    <mimeMap fileExtension=".svgz" mimeType="images/svg+xml" />
    <remove fileExtension=".eot" />
    <mimeMap fileExtension=".eot" mimeType="application/vnd.ms-fontobject" />
    <mimeMap fileExtension=".otf" mimeType="font/otf" />
    <mimeMap fileExtension=".woff" mimeType="font/x-woff" />
    </staticContent>
    </system.webServer>
    <!--File Upload Limits-->
    <location path="uploadh.aspx">
    <system.web>
    <httpRuntime maxRequestLength="2097151" executionTimeout="7200" />
    <!--2gb upload limit, 2 hours timeout-->
    </system.web>
    </location>
    <location path="api/myfiles-upload">
    <system.web>
    <httpRuntime maxRequestLength="2097151" executionTimeout="7200" />
    </system.web>
    </location>
    <location path="myfiles/default.aspx">
    <system.web>
    <httpRuntime maxRequestLength="2097151" executionTimeout="7200" />
    </system.web>
    </location>
    <!--End of File Upload Limits-->
    <!--Start of Override Permissions-->
    <location path="api.asmx">
    <system.web>
    <authorization>
    <allow users="*" />
    </authorization>
    </system.web>
    </location>
    <location path="api/bookingsystem/loadroom">
    <system.web>
    <authorization>
    <allow users="*" />
    </authorization>
    </system.web>
    </location>
    <location path="api/js">
    <system.web>
    <authorization>
    <allow users="*" />
    </authorization>
    </system.web>
    </location>
    <location path="api/test">
    <system.web>
    <authorization>
    <allow users="*" />
    </authorization>
    </system.web>
    </location>
    <location path="api/setup">
    <system.web>
    <authorization>
    <allow users="*" />
    </authorization>
    </system.web>
    </location>
    <location path="app_data">
    <system.web>
    <authorization>
    <deny users="*" />
    </authorization>
    </system.web>
    </location>
    <location path="bin">
    <system.web>
    <authorization>
    <deny users="*" />
    </authorization>
    </system.web>
    </location>
    <location path="favicon.ico">
    <system.web>
    <authorization>
    <allow users="*" />
    </authorization>
    </system.web>
    </location>
    <location path="kerberos.aspx">
    <system.web>
    <authorization>
    <allow users="*" />
    </authorization>
    </system.web>
    </location>
    <location path="Login.aspx">
    <system.web>
    <authorization>
    <allow users="*" />
    </authorization>
    </system.web>
    </location>
    <location path="setup.aspx">
    <system.web>
    <authorization>
    <allow users="Domain Admins" />
    </authorization>
    </system.web>
    </location>
    <!--End of Override Permissions-->
    <system.serviceModel>
    <extensions>
    <behaviorExtensions>
    <add name="jsonWebHttp" type="HAP.Web.Logging.JsonErrorWebHttpBehaviorElem ent, HAP.Web.Logging" />
    </behaviorExtensions>
    </extensions>
    <behaviors>
    <endpointBehaviors>
    <behavior name="">
    <jsonWebHttp />
    </behavior>
    </endpointBehaviors>
    <serviceBehaviors>
    <behavior name="">
    <serviceDebug includeExceptionDetailInFaults="true" />
    <serviceMetadata httpGetEnabled="false" httpsGetEnabled="true" />
    </behavior>
    </serviceBehaviors>
    </behaviors>
    <bindings>
    <webHttpBinding />
    </bindings>
    <serviceHostingEnvironment aspNetCompatibilityEnabled="true" multipleSiteBindingsEnabled="true" />
    <standardEndpoints>
    <webHttpEndpoint>
    <standardEndpoint name="" helpEnabled="true" automaticFormatSelectionEnabled="false" faultExceptionEnabled="true" defaultOutgoingResponseFormat="Json" />
    </webHttpEndpoint>
    </standardEndpoints>
    </system.serviceModel>
    </configuration>

  2. #2
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,520
    Thank Post
    37
    Thanked 501 Times in 432 Posts
    Rep Power
    113
    It will show unauthorized if the user has no resources visible to them

  3. #3

    Join Date
    Mar 2014
    Location
    Connecticut
    Posts
    10
    Thank Post
    1
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    I have resources. Do I need to change something else?

  4. #4
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,520
    Thank Post
    37
    Thanked 501 Times in 432 Posts
    Rep Power
    113
    Check the visible to bit in hapConfig.xml

  5. #5

    Join Date
    Mar 2014
    Location
    Connecticut
    Posts
    10
    Thank Post
    1
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Looks ok to me.

    hapConfig version="9.3.727.300" local="en-GB" firstrun="False">
    <AD username="wservices" password="t1IKy1STdjCgCEd1VLXnFQ==" upn="montvilleschools.org" studentsgroup="MPS Users" usenestedlookups="True" secureldap="False" maxlogonattempts="4" maxrecursions="10">
    <OUs>
    <OU name="IT Staff" path="ldap://OU=Staff,OU=IT,OU=MPS Users,DC=montvilleschools,DC=org" visibility="BookingSystem" />
    <OU name="MOH Staff" path="ldap://OU=Staff,OU=MOH,OU=MPS Users,DC=montvilleschools,DC=org" visibility="BookingSystem" />
    </OUs>
    </AD>
    <Homepage>
    <Links>
    <Group name="Resources" showto="All" subtitle="" hidehomepage="False" hidetopmenu="False" hidehomepagelink="False">
    <Link name="Me" showto="Inherit" description="About Me and Change My Password" url="#me" icon="~/images/icons/metro/folders-os/UserNo-Frame.png" target="" type="me" width="1" height="1" />
    <Link name="Staff Email" showto="Inherit" description="Access Email" url="https://webmail.montvilleschools.org/owa/" icon="~/images/icons/metro/office-15/outlook.png" target="1" width="1" height="" />
    <Link name="Files" showto="Inherit" description="Access your School My Files" url="~/myfiles/" icon="~/images/icons/metro/folders-os/DocumentsFolder.png" target="" type="myfiles" width="1" height="1" />
    <Link name="Google Drive" showto="Inherit" description="Access Google Drive" url="https://drive.google.com/" icon="~/_MPS/images/icons/google-drive_64-64.png" target="1" width="1" height="" />
    <Link name="Aspen" showto="Inherit" description="Access your Aspen Account" url="https://ct-montville.myfollett.com/" icon="~/_MPS/images/icons/aspen_64-64.png" target="1" width="1" height="1" />
    <Link name="Destiny" showto="Inherit" description="Library Catalog" url="Welcome to Montville Board of Education" icon="~/_MPS/images/icons/destiny_100x100.png" target="1" width="1" height="1" />
    <Link name="Booking System" showto="Inherit" description="Reserve laptops, computer labs, and other equipment." url="~/BookingSystem/" icon="~/images/icons/metro/applications/calendar.png" target="" width="1" height="1" />
    </Group>
    <Group name="Management" showto="Domain Admins" subtitle="" hidehomepage="False" hidetopmenu="False" hidehomepagelink="False">
    <Link name="Help Desk" showto="Inherit" description="Log/View a Support Ticket" url="~/helpdesk/" icon="~/images/icons/metro/folders-os/help.png" target="" type="helpdesk" width="2" height="1" />
    <Link name="Booking System" showto="Inherit" description="Book an IT Resource" url="~/bookingsystem/" icon="~/images/icons/metro/applications/calendar.png" target="" type="bookings" width="2" height="1" />
    <Link name="Logon Tracker" showto="Domain Admins" description="View the Logon History" url="~/tracker/" icon="~/images/icons/metro/other/History.png" target="1" width="1" height="" />
    <Link name="HAP+ Config" showto="Domain Admins" description="Home Access Plus+ Config" url="~/setup.aspx" icon="~/images/icons/metro/folders-os/Configurealt1.png" target="1" width="1" height="" />
    </Group>
    <Group name="Me" showto="All" subtitle="#me" hidehomepage="False" hidetopmenu="False" hidehomepagelink="False">
    <Link name="Me" showto="Inherit" description="" url="" icon="" target="1" width="1" height="" />
    <Link name="Password" showto="Inherit" description="" url="" icon="" target="1" width="1" height="" />
    </Group>
    </Links>
    <AnnouncementBox showto="All" enableeditto="Domain Admins" />
    </Homepage>
    <ProxyServer address="" port="0" enabled="False" />
    <SMTP server="" port="25" enabled="False" ssl="False" from="admin" fromaddress="admin@localhost.com" user="" exchange="" impersonationdomain="" impersonationuser="" />
    <Tracker maxstudentlogons="1" maxstafflogons="4" overridecode="3600" provider="XML" />
    <School name="Mohegan Elementary" website="Montville Public Schools | PowerIT" photohandler="" />
    <bookingsystem maxbookingsperweek="40" maxdays="14" admins="" keepxmlclean="False" twoweektimetable="False" enablemultilesson="false" archive="False" maxmultilesson="0">
    <resources>
    <resource name="Red Laptop Cart" type="Room" admins="nsavoie" enabled="True" emailadmins="True" enablecharging="False" showto="MOHStaff" hidefrom="" years="Mohegan" quantities="25" readonlyto="" readwriteto="" disclaimer="" canshare="True" enablenotes="false" />
    <resource name="Blue Laptop Cart" type="Room" admins="nsavoie" enabled="True" emailadmins="True" enablecharging="False" showto="MOHStaff" hidefrom="" years="Mohegan" quantities="25" readonlyto="" readwriteto="" disclaimer="" canshare="True" enablenotes="false" />
    <resource name="White Laptop Cart" type="Room" admins="nsavoie" enabled="True" emailadmins="True" enablecharging="False" showto="MOHStaff" hidefrom="" years="Mohegan" quantities="10" readonlyto="" readwriteto="" disclaimer="" canshare="True" enablenotes="false" />
    </resources>
    <lessons>
    <lesson name="9:00 AM - 9:30 AM" type="Lesson" starttime="09:00" endtime="09:30" />
    <lesson name="9:30 AM - 10:00 AM" type="Lesson" starttime="09:31" endtime="10:00" />
    <lesson name="10:00 AM - 10:30 AM" type="Lesson" starttime="10:00" endtime="10:30" />
    <lesson name="10:30 AM - 11:00 AM" type="Lesson" starttime="10:30" endtime="11:00" />
    <lesson name="11:00 AM - 11:30 AM" type="Lesson" starttime="11:00" endtime="11:30" />
    <lesson name="11:30 AM - 12:00 PM" type="Lesson" starttime="11:31" endtime="12:00" />
    <lesson name="12:00 PM - 12:30 PM" type="Lesson" starttime="12:01" endtime="12:30" />
    <lesson name="12:30 PM - 1:00 PM" type="Lesson" starttime="12:31" endtime="13:00" />
    <lesson name="1:00 PM - 1:30 PM" type="Lesson" starttime="13:01" endtime="13:30" />
    <lesson name="1:30 PM - 2:00 PM" type="Lesson" starttime="13:31" endtime="14:00" />
    <lesson name="2:00 PM - 2:30 PM" type="Lesson" starttime="14:01" endtime="14:30" />
    <lesson name="2:30 PM - 3:00 PM" type="Lesson" starttime="14:31" endtime="15:00" />
    <lesson name="3:00 PM - 4:00 PM" type="AfterSchool" starttime="15:00" endtime="16:00" />
    </lessons>
    <subjects>
    <subject name="Art" />
    <subject name="Extra Curricular" />
    <subject name="General" />
    <subject name="Grade 1" />
    <subject name="Grade 2" />
    <subject name="Grade 3" />
    <subject name="Grade 4" />
    <subject name="Grade 5" />
    <subject name="Grade Kindergarten" />
    <subject name="Health and Physical Education" />
    <subject name="Media Center" />
    <subject name="Music" />
    <subject name="Special Services" />
    </subjects>
    </bookingsystem>
    <myfiles hideextensions=".lnk,.ini" writechecks="True" LiveAppId="">
    <mappings>
    <mapping drive="H" name="Home Folder" enablereadto="All" enablewriteto="All" enablemove="True" usagemode="Quota">%homedir%</mapping>
    <mapping drive="S" name="Share Folder" enablereadto="All" enablewriteto="All" enablemove="True" usagemode="Quota">\\montvilleschools.org\FS\Share</mapping>
    </mappings>
    <filters>
    <filter name="Access Database" expression="*.mdb;*.accdb" enablefor="All" />
    <filter name="Excel Documents" expression="*.xls;*.xlsx;*.xlt;*.xltx" enablefor="All" />
    <filter name="HTML Files" expression="*.html;*.htm" enablefor="All" />
    <filter name="Images" expression="*.jpg;*.gif;*.png;*.bmp;*.jpeg" enablefor="All" />
    <filter name="Powerpoint Files" expression="*.ppt;*.pptx;*.pptx;*.ppt" enablefor="All" />
    <filter name="Word Documents" expression="*.doc;*.docx;*.dotx;*.dot;*.txt;*.rtf; *.pdf" enablefor="All" />
    <filter name="ZIP Files" expression="*.zip" enablefor="All" />
    <filter name="All Files" expression="*.*" enablefor="Domain Admins" />
    </filters>
    <quotaservers />
    </myfiles>
    <HelpDesk admins="Domain Admins" firstlineemails="" />
    </hapConfig>

  6. #6

    Join Date
    Mar 2014
    Location
    Connecticut
    Posts
    10
    Thank Post
    1
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Does anyone else have any other ideas. I need to get this to work or have to move away from it. Any help will be fine.

  7. #7

    Join Date
    Apr 2012
    Posts
    45
    Thank Post
    0
    Thanked 6 Times in 5 Posts
    Rep Power
    6
    showto="MOHStaff"

    <OU name="MOH Staff"

    Taking a stab here, but are you missing a space on your showto lines?

  8. #8

    Join Date
    Mar 2014
    Location
    Connecticut
    Posts
    10
    Thank Post
    1
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    I fixed the spacing and still get Error: unauthorised Access page

  9. #9
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,520
    Thank Post
    37
    Thanked 501 Times in 432 Posts
    Rep Power
    113
    v10 or v9? if v10, please try the attached dll
    Attached Files Attached Files

  10. #10

    Join Date
    Mar 2014
    Location
    Connecticut
    Posts
    10
    Thank Post
    1
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Nick, I am run Version 9.4.727.300. Should I upgrade to 10?

  11. #11
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,520
    Thank Post
    37
    Thanked 501 Times in 432 Posts
    Rep Power
    113
    ah, in that case, hmm. Can you try setting the resource to showto="All". I want to try and figure out if it's a HAP+ ad issue or a resource issue

  12. #12

    Join Date
    Mar 2014
    Location
    Connecticut
    Posts
    10
    Thank Post
    1
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    I tried setting the resource to all already and got the same thing.

  13. #13
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,520
    Thank Post
    37
    Thanked 501 Times in 432 Posts
    Rep Power
    113
    Ok. that sounds like a AD issue with the role provider, can you have a look at ~/bookingsystem/web.config and check they are AD groups, not AD OUs

  14. #14

    Join Date
    Mar 2014
    Location
    Connecticut
    Posts
    10
    Thank Post
    1
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    MOH Staff is a group. I included a screen shot.
    Attached Thumbnails Attached Thumbnails Booking System: Error: Unauthorised Access-moh-group.jpg  

  15. #15
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,520
    Thank Post
    37
    Thanked 501 Times in 432 Posts
    Rep Power
    113
    ok, can I see a copy of the web.config from the bookingsystem folder please?

SHARE:
+ Post New Thread
Page 1 of 2 12 LastLast

Similar Threads

  1. HAP Error: Unauthorised Access
    By sadams1980 in forum Home Access Plus+
    Replies: 9
    Last Post: 10th March 2014, 09:07 AM
  2. Booking system error
    By ncoules in forum Home Access Plus+
    Replies: 1
    Last Post: 18th September 2013, 03:55 PM
  3. Booking System v9 - Unauthorised Access for staff.
    By calwyn in forum Home Access Plus+
    Replies: 2
    Last Post: 23rd May 2013, 11:36 AM
  4. [HAP+][v9] Booking System Error
    By mrbios in forum Home Access Plus+
    Replies: 18
    Last Post: 22nd April 2013, 12:38 AM
  5. Home Access Plus+ V7 Booking System Issues
    By wdwm in forum Home Access Plus+
    Replies: 20
    Last Post: 24th September 2011, 08:23 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •