+ Post New Thread
Results 1 to 5 of 5
Home Access Plus+ Thread, Helpdesk hdadmin error in Projects:; Hi all, We have been configuring and testing HAP+ prior to rolling it out for staff to use. We want ...
  1. #1

    Join Date
    Mar 2014
    Posts
    3
    Thank Post
    1
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Helpdesk hdadmin error

    Hi all,

    We have been configuring and testing HAP+ prior to rolling it out for staff to use.

    We want to use the Help Desk for both ICT and site Maintenance tickets. So we have created a Help desk admin group in Active Directory and assigned several staff from across the school. We have added this security group to the Help Desk Admins field on the Tracker / Other tab within the config page.

    We have found that with hdadmin set to 'True' in hap.web.js the Help desk administrators can Create, Assign and close tickets without any problems. However when a staff member goes to open a new ticket or update an existing ticket they receive the following error on trying to Save or Update the ticket:

    'Index was outside the bounds of the array' (The Server Application Event log is shown at the end).

    If I have hdadmin set to 'false' then staff can create and update their tickets with no errors, however my Help desk administrators can no longer assign or close a ticket, the assign button disappears and the fixed slider does not work in that you can slide it to on but the ticket does not move to the closed tab.

    Only a member of Domain Admins can assign or close a ticket with hdadmin set to 'false'.

    We need our ICT staff, Head of Maintenance and Head of Catering to be able to administer tickets and not be domain administrators.

    Any guidance on a fix for this would be most appreciated.


    Event Log:
    An error occurred in Home Access Plus+
    Page: HAP.HelpDesk
    Index was outside the bounds of the array.
     

    System.IndexOutOfRangeException: Index was outside the bounds of the array.
    at HAP.HelpDesk.API.FileAdminTicket(String Subject, String Room, String Note, String ShowTo, String Priority, String User)
    at SyncInvokeFileAdminTicket(Object , Object[] , Object[] )
    at System.ServiceModel.Dispatcher.SyncMethodInvoker.I nvoke(Object instance, Object[] inputs, Object[]& outputs)
    at System.ServiceModel.Dispatcher.DispatchOperationRu ntime.InvokeBegin(MessageRpc& rpc)
    at System.ServiceModel.Dispatcher.ImmutableDispatchRu ntime.ProcessMessage5(MessageRpc& rpc)
    at System.ServiceModel.Dispatcher.MessageRpc.Process( Boolean isOperationContextSet)
    at HAP.HelpDesk.API.FileAdminTicket(String Subject, String Room, String Note, String ShowTo, String Priority, String User)
    at SyncInvokeFileAdminTicket(Object , Object[] , Object[] )
    at System.ServiceModel.Dispatcher.SyncMethodInvoker.I nvoke(Object instance, Object[] inputs, Object[]& outputs)
    at System.ServiceModel.Dispatcher.DispatchOperationRu ntime.InvokeBegin(MessageRpc& rpc)
    at System.ServiceModel.Dispatcher.ImmutableDispatchRu ntime.ProcessMessage5(MessageRpc& rpc)
    at System.ServiceModel.Dispatcher.MessageRpc.Process( Boolean isOperationContextSet)

  2. #2
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,484
    Thank Post
    37
    Thanked 490 Times in 422 Posts
    Rep Power
    110
    hdadmins in hap.web.js is set automatically by the server for each user. Check they have been set as HDadmins in the hapConfig.xml file.

    Which version of HAP are you using?

  3. Thanks to nickbro from:

    719rpl (27th March 2014)

  4. #3

    Join Date
    Mar 2014
    Posts
    3
    Thank Post
    1
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Hi

    Yes the group is set as admins under <heldesk admins= "... in the hapconfig file anlong with the Domain Admins.

    We did the full install of 9 and then upgraded it to 9.7, the issue happens in both versions.

    Regards

  5. #4

    Join Date
    Mar 2014
    Posts
    3
    Thank Post
    1
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Hi

    I'm guessing there is no answer to this then?

    Regards

  6. #5
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,484
    Thank Post
    37
    Thanked 490 Times in 422 Posts
    Rep Power
    110
    Fixed in the v10 preview releases

SHARE:
+ Post New Thread

Similar Threads

  1. HAP 10 Preview 3 - New Helpdesk Ticket - Error Not Found
    By mattgrimley in forum Home Access Plus+
    Replies: 9
    Last Post: 26th March 2014, 10:28 AM
  2. Helpdesk error
    By Danp in forum Home Access Plus+
    Replies: 1
    Last Post: 8th October 2013, 08:55 AM
  3. Liberum Helpdesk error message updating/closing problems
    By El_Nombre in forum Network and Classroom Management
    Replies: 1
    Last Post: 4th May 2010, 09:26 AM
  4. Adduser.conf parse errors
    By ChrisH in forum *nix
    Replies: 4
    Last Post: 18th November 2005, 11:10 AM
  5. Kerberos error - All policies disappeared
    By ajbritton in forum Windows
    Replies: 13
    Last Post: 2nd November 2005, 02:13 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •