+ Post New Thread
Results 1 to 10 of 10
Home Access Plus+ Thread, HAP 10 Preview 3 - New Helpdesk Ticket - Error Not Found in Projects:; Morning Gents! Spectacular jobs on Friday night - Preview 3 is nothing short of amazing! I'm running through some functionality ...
  1. #1
    mattgrimley's Avatar
    Join Date
    Jun 2011
    Location
    Bedfordshire
    Posts
    316
    Thank Post
    35
    Thanked 21 Times in 19 Posts
    Blog Entries
    1
    Rep Power
    10

    HAP 10 Preview 3 - New Helpdesk Ticket - Error Not Found

    Morning Gents!

    Spectacular jobs on Friday night - Preview 3 is nothing short of amazing! I'm running through some functionality tests on my test server and getting an issue creating a new helpdesk ticket.

    To replicate:
    Help Desk
    New Ticket
    Issue: test 2
    PC/Room: laphp-01 (pre-filled! nice!)
    Note: This is another test
    Ticket for: mrg
    Priority: High
    Click File Ticket

    Error:
    Not Found

    Firebug:
    POST https://portal.freman.org.uk/beta/ap...k/AdminTicket/ 404 Not Found 6ms jquery.min.js (line 13)

    Can't see much else of interest there.. I presume it's part of the "plugin migration?

    Cheers,
    Matt

  2. #2
    mattgrimley's Avatar
    Join Date
    Jun 2011
    Location
    Bedfordshire
    Posts
    316
    Thank Post
    35
    Thanked 21 Times in 19 Posts
    Blog Entries
    1
    Rep Power
    10
    related?

    Logging on as a staff-user and trying to create a ticket, i get the "Ticket for:" option, but the drop-down is empty. WHen i click "File Ticket", i get "The parameter address cannot be an empty string. Parameter name: address."

    Cheers,
    Matt

  3. #3
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,483
    Thank Post
    37
    Thanked 488 Times in 420 Posts
    Rep Power
    110
    Open ~/scripts/hap.helpdesk.js, line 126

    Remove the last /, so it reads "~/api/helpdesk/adminticket"

    - - - Updated - - -

    Open ~/scripts/hap.helpdesk.js, line 126

    Remove the last /, so it reads "~/api/helpdesk/adminticket"

  4. #4
    mattgrimley's Avatar
    Join Date
    Jun 2011
    Location
    Bedfordshire
    Posts
    316
    Thank Post
    35
    Thanked 21 Times in 19 Posts
    Blog Entries
    1
    Rep Power
    10
    Hey Nick,

    Thx.. Didn't initially work, but i applied the same logic to the other entries for HelpDesk/AdminTicket/ (On lines 64, 84, 104 and 126).
    Should i do the same for the references to HelpDesk/Ticket/ (on lines 84 and 104)?

    The issue in the second post remains though.

    Cheers,
    Matt

  5. #5
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,483
    Thank Post
    37
    Thanked 488 Times in 420 Posts
    Rep Power
    110
    It should only be on that one, as the other references need the / to split the url.

    I've updated the Plugin

  6. #6
    mattgrimley's Avatar
    Join Date
    Jun 2011
    Location
    Bedfordshire
    Posts
    316
    Thank Post
    35
    Thanked 21 Times in 19 Posts
    Blog Entries
    1
    Rep Power
    10
    Okay mate, have replaced from your updated version

    The issue I reported in post #2 was caused by my stafftest user not having an email address. I can't imagine production reasons for some having email and some not, so disregard it unless someone else has the problem!

    I have a few more issues, so i'll start a list!

    1> Helpdesk - The top of the ticket seems to be obscured by the ticket summary.
    HAP 10 Preview 3 - New Helpdesk Ticket - Error Not Found-capture1.png
    2> Helpdesk - There appears to be no "close ticket" button.. is this just obscured by issue 1 above?
    3> Helpdesk - Assign isn't working. It just refreshes the page without prompting for a user to assign the ticket too.
    4> Helpdesk - A staff user with no email address generates errors when updating / creating tickets (see post 2 for further details)
    5> Booking System - "Make Static" switch state persists (set it to on once and it defaults to on for further bookings).
    6> Booking System - User with Admin rights on a resource CAN now use "make static" and "recurrence". Can they have the "User to Book For" too?

    related feature requests:
    1> Booking System/Cal.aspx - Love this view. Can the left-hand axis be limited to the school day rather than the full 24 hours?
    2> Booking System/Cal.aspx - Can the Week / Day and room filters be accessible via URL? i.e. cal.aspx?view=day&Rooms=ict1,ict2,ict3&date=today

    I've had a good old play with the rest of the booking and helpdesk and will be ready to deploy live when the helpdesk tickets can be closed

    Thanks for everything you both do - HAP is awesome!

  7. #7
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,483
    Thank Post
    37
    Thanked 488 Times in 420 Posts
    Rep Power
    110
    1> Will look into that one
    2> Look at the status, see the drop down box (click on the text next to status to change it)
    3> I need to remove that button, see the assigned to (click on the text next to assigned to --- to assign)
    4> Will add code to stop that
    5> Will add code to fix that
    6> Will add code to add that feature

    1> Cal.aspx? WeekView.aspx? OverviewCalendar.aspx?
    2> Not currently planned will see what I can do though

  8. #8
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,483
    Thank Post
    37
    Thanked 488 Times in 420 Posts
    Rep Power
    110
    1> Cal has been set with Min/Max times so it only displays what lessons are defined
    Last edited by ZeroHour; 28th March 2014 at 04:16 PM.

  9. #9
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,483
    Thank Post
    37
    Thanked 488 Times in 420 Posts
    Rep Power
    110

  10. Thanks to nickbro from:

    mattgrimley (26th March 2014)

  11. #10
    mattgrimley's Avatar
    Join Date
    Jun 2011
    Location
    Bedfordshire
    Posts
    316
    Thank Post
    35
    Thanked 21 Times in 19 Posts
    Blog Entries
    1
    Rep Power
    10
    Mate, that all looks awesome.. Everything discussed looks to be working.. will test a bit more today and then make live tonight

    Thanks so much!

    Matt

SHARE:
+ Post New Thread

Similar Threads

  1. HAP+ 10 Preview 2 install issue - Service Activated Error
    By Paul-K in forum Home Access Plus+
    Replies: 12
    Last Post: 23rd March 2014, 03:11 PM
  2. HAP+ 10 Preview 2 Uploading files
    By toffee in forum Home Access Plus+
    Replies: 6
    Last Post: 16th March 2014, 03:24 PM
  3. [HAP+][v10] - New Helpdesk
    By nickbro in forum Home Access Plus+
    Replies: 14
    Last Post: 22nd February 2014, 08:32 PM
  4. Replies: 5
    Last Post: 18th September 2012, 03:53 PM
  5. GPResult returns "Error: Not Found"
    By philjones2000 in forum Windows
    Replies: 15
    Last Post: 18th November 2011, 09:47 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •