+ Post New Thread
Page 2 of 3 FirstFirst 123 LastLast
Results 16 to 30 of 36
Home Access Plus+ Thread, NLB HAP Errors in Projects:; It's going to be in v10, it's not there yet...
  1. #16

    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,690
    Thank Post
    43
    Thanked 560 Times in 468 Posts
    Rep Power
    124
    It's going to be in v10, it's not there yet

  2. #17

    Join Date
    Aug 2012
    Location
    Solihull
    Posts
    123
    Thank Post
    2
    Thanked 4 Times in 4 Posts
    Rep Power
    5
    ahhh OK - I'll hold my horses then I'll leave my 2008R2 HAP install where it is for now

    Any ETA on v10?

    Cheers Nick

  3. #18

    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,690
    Thank Post
    43
    Thanked 560 Times in 468 Posts
    Rep Power
    124
    End of the month, hopefully

  4. #19

    Join Date
    Aug 2012
    Location
    Solihull
    Posts
    123
    Thank Post
    2
    Thanked 4 Times in 4 Posts
    Rep Power
    5
    I'd like to offer my cluster for testing if you need it mate , it's not doing an awful lot else right now 😁

  5. #20

    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,690
    Thank Post
    43
    Thanked 560 Times in 468 Posts
    Rep Power
    124
    Right, the plan is you will need a key and a salt, as well as doing the asp.net machine key stuff.

    The plan is, by default these will not be visible or shown or have any value, at which point HAP+ auto generates them based on the machine name, but you can override HAP+.

    Suggestion is go to Random String Generator | Strong Password Generator

    The Salt will be one of the Alphanumeric + special character strings
    The Key will be all of the Alphanumeric + special character strings on the page

    So at the time of writing a test Salt would be: dfcjtyxYA!l#3um1 and the Key would be: eGGb49-nZ+JFo.?2emQEHifDKlG@oiEDZ7O@fBc1oWFNTzO?VrypKN@g! w6iPKVARwq=!C=jly=1!H!Q_s2F3%W.n*g,y,zbuZ5po.IJvBJ q5D31=5F__o=ic0hL8QWC

  6. #21

    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,690
    Thank Post
    43
    Thanked 560 Times in 468 Posts
    Rep Power
    124
    You could of course use just alphanumeric

  7. #22

    Join Date
    Aug 2012
    Location
    Solihull
    Posts
    123
    Thank Post
    2
    Thanked 4 Times in 4 Posts
    Rep Power
    5
    OK buddy, so where do I put this - i'll test with the test ones you listed above and then generate my own when its working

  8. #23

    Join Date
    Aug 2012
    Location
    Solihull
    Posts
    123
    Thank Post
    2
    Thanked 4 Times in 4 Posts
    Rep Power
    5
    Also - I take it the ASP machine key stuff is simply the machine key setting in ASP.net for the site?

    NLB HAP Errors-machine_key2.jpg


    NLB HAP Errors-machine_key.jpg

  9. #24

    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,690
    Thank Post
    43
    Thanked 560 Times in 468 Posts
    Rep Power
    124
    Machine Key: Yep

    The other won't be out until v10, so hold off on that for a mo

  10. #25

    Join Date
    Aug 2012
    Location
    Solihull
    Posts
    123
    Thank Post
    2
    Thanked 4 Times in 4 Posts
    Rep Power
    5
    to be honest, I don't have a clue where to put the salt and key, the machine key for IIS auto adds the Encryption and decryption key to the HAP config.... can you elaborate for me?

  11. #26

    Join Date
    Aug 2012
    Location
    Solihull
    Posts
    123
    Thank Post
    2
    Thanked 4 Times in 4 Posts
    Rep Power
    5
    I have DFS replication setup with the HAP folder - so the key gets replicated (As do all the config files) - I've tried this and still get the same errors....

    Does the machine key need to be unique to each server?

    Thanks for all the advice so far

    Thanks

    Stephen

  12. #27

    Join Date
    Aug 2012
    Location
    Solihull
    Posts
    123
    Thank Post
    2
    Thanked 4 Times in 4 Posts
    Rep Power
    5
    Hi Nick, How is the v10 work coming?

  13. #28

    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,690
    Thank Post
    43
    Thanked 560 Times in 468 Posts
    Rep Power
    124
    v10 is scheduled for the end of Half Term, so end of the Month

  14. #29

    Join Date
    Aug 2012
    Location
    Solihull
    Posts
    123
    Thank Post
    2
    Thanked 4 Times in 4 Posts
    Rep Power
    5
    Cheers buddy... Looking forward to it

  15. #30
    fairm010's Avatar
    Join Date
    Jun 2010
    Location
    C:/Windows/System32/
    Posts
    1,441
    Thank Post
    62
    Thanked 207 Times in 179 Posts
    Rep Power
    56
    Quote Originally Posted by nickbro View Post
    v10 is scheduled for the end of Half Term, so end of the Month
    Ie, Friday next week? Would prefer to do the update at the weekend



SHARE:
+ Post New Thread
Page 2 of 3 FirstFirst 123 LastLast

Similar Threads

  1. Replies: 5
    Last Post: 9th July 2013, 02:37 PM
  2. Replies: 7
    Last Post: 19th April 2013, 09:04 PM
  3. Replies: 2
    Last Post: 7th January 2013, 02:58 PM
  4. HAP+ error 500 on new web server install
    By magic2119 in forum Home Access Plus+
    Replies: 12
    Last Post: 19th September 2012, 09:11 AM
  5. HAP Error: System.NullReferenceException
    By bclarke in forum Home Access Plus+
    Replies: 4
    Last Post: 3rd February 2012, 08:50 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •