+ Post New Thread
Results 1 to 9 of 9
Home Access Plus+ Thread, HAP SQL Login Tracker Problem in Projects:; Hello, Been trying to get SQL Login Tracker working but for some reason the following page is displayed when logging ...
  1. #1

    Join Date
    Jan 2012
    Posts
    127
    Thank Post
    0
    Thanked 1 Time in 1 Post
    Rep Power
    0

    Angry HAP SQL Login Tracker Problem

    Hello,

    Been trying to get SQL Login Tracker working but for some reason the following page is displayed when logging on to the site.

    The SQL database is hosted on a different server to the HAP server. I have put the following into the Web.config to specify the SQL Connection to no avail:

    "SQLConnectionString" connectionString="Server=SQL2\HAP;Database=hap_DB; User Id=hapDB_user;Password=<top secret word>;"

    If anyone has any bright ideas, I would be most grateful.

    J.Worth
    Attached Thumbnails Attached Thumbnails HAP SQL Login Tracker Problem-error.png  

  2. #2

    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,691
    Thank Post
    43
    Thanked 560 Times in 468 Posts
    Rep Power
    124
    Have you run the hap.sql script in the app_data folder to create the tables?

  3. #3

    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,691
    Thank Post
    43
    Thanked 560 Times in 468 Posts
    Rep Power
    124
    Can you post the tracker section of the hapConfig.xml file please

  4. #4

    Join Date
    Jan 2012
    Posts
    127
    Thank Post
    0
    Thanked 1 Time in 1 Post
    Rep Power
    0
    Attached to this post is a screenshot showing the tables that have been created in the HAP database.

    Below is the tracker section from the hapConfig.xml file:

    <Tracker maxstudentlogons="20" maxstafflogons="10" overridecode="3600" provider="SQL" />

    Thanks for your prompt reply
    Attached Thumbnails Attached Thumbnails HAP SQL Login Tracker Problem-tables.png  

  5. #5

    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,691
    Thank Post
    43
    Thanked 560 Times in 468 Posts
    Rep Power
    124
    Set the provider in the tracker to "SQLConnectionString"

  6. #6

    Join Date
    Jan 2012
    Posts
    127
    Thank Post
    0
    Thanked 1 Time in 1 Post
    Rep Power
    0
    I have now changed it to SQLConnectionString in hapConfig.xml. However, I am now getting a Login Failed error. I have double checked the password and the hapDB_user has owner permissions to the HAP database.

    Are there any other permissions/configuration that needs to be done.

    Your help is very much appreciated.

    Thanks again.
    Attached Thumbnails Attached Thumbnails HAP SQL Login Tracker Problem-loginerror.png  

  7. #7

    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,691
    Thank Post
    43
    Thanked 560 Times in 468 Posts
    Rep Power
    124
    shouldn't do, that should be it.

    Have a look at Evonet | Setting up SQL Server 2008 for an ASP.NET website on IIS 7.0 - To set up SQL Authentication

    Under Database Role Membership select db_datareader (and db_datawriter if your users are performing INSERT and UPDATE SQL queries).

  8. #8

    Join Date
    Jan 2012
    Posts
    127
    Thank Post
    0
    Thanked 1 Time in 1 Post
    Rep Power
    0
    Got it working!

    I didn't have Windows & SQL Authentication selected on the properties of the SQL Instance. Once I changed it to that, it worked straight away!

    Thank you very much for all your help - much appreciated.

    J.Worth.

  9. #9

    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,691
    Thank Post
    43
    Thanked 560 Times in 468 Posts
    Rep Power
    124
    Brilliant news



SHARE:
+ Post New Thread

Similar Threads

  1. FSRM Quota and SQL Logon Tracker Setup
    By J_Worth in forum Home Access Plus+
    Replies: 1
    Last Post: 25th January 2013, 02:02 AM
  2. [SIMS] Nova T 4 prompting for SQL login details
    By d-taylor in forum MIS Systems
    Replies: 2
    Last Post: 3rd July 2012, 02:12 PM
  3. Just setting up HAP+ Home Drive mapping problem
    By Cools in forum Home Access Plus+
    Replies: 4
    Last Post: 16th February 2012, 09:31 PM
  4. WSUS - SQL - SCCM 2007 problem
    By sultan966 in forum Enterprise Software
    Replies: 6
    Last Post: 25th January 2012, 10:16 PM
  5. Login script problem
    By SpuffMonkey in forum Windows
    Replies: 55
    Last Post: 4th February 2006, 10:27 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •