+ Post New Thread
Results 1 to 2 of 2
Home Access Plus+ Thread, Services activated red cross in Projects:; I have searched all the other threads that relate to this but I can't find anything that relates to my ...
  1. #1
    cromertech's Avatar
    Join Date
    Dec 2007
    Location
    Cromer by the coast
    Posts
    731
    Thank Post
    177
    Thanked 109 Times in 97 Posts
    Rep Power
    55

    Services activated red cross

    I have searched all the other threads that relate to this but I can't find anything that relates to my problem.

    I have https only access to the site and when I navigate to /api/setup I get the following errors alternately

    Server Error in '/' Application.
    Configuration Error
    Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

    Parser Error Message: An endpoint reference cycle was detected in your configuration. The following reference cycle must be removed: webHttpEndpoint/, webHttpEndpoint/.

    Source Error:


    Line 250: <standardEndpoints>
    Line 251: <webHttpEndpoint>
    Line 252: <standardEndpoint name="" helpEnabled="true" automaticFormatSelectionEnabled="false" faultExceptionEnabled="true" defaultOutgoingResponseFormat="Json" />
    Line 253: </webHttpEndpoint>
    Line 254: </standardEndpoints>


    Source File: C:\HAP\web.config Line: 252

    Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.0.30319.1016
    Server Error in '/' Application.
    Could not find a base address that matches scheme http for the endpoint with binding WebHttpBinding. Registered base address schemes are [https].
    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: System.InvalidOperationException: Could not find a base address that matches scheme http for the endpoint with binding WebHttpBinding. Registered base address schemes are [https].

    Source Error:

    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

    Stack Trace:


    [InvalidOperationException: Could not find a base address that matches scheme http for the endpoint with binding WebHttpBinding. Registered base address schemes are [https].]
    System.ServiceModel.ServiceHostBase.MakeAbsoluteUr i(Uri relativeOrAbsoluteUri, Binding binding, UriSchemeKeyedCollection baseAddresses) +12393964
    System.ServiceModel.Description.ConfigLoader.Confi gureEndpointAddress(ServiceEndpointElement serviceEndpointElement, ServiceHostBase host, ServiceEndpoint endpoint) +54
    System.ServiceModel.Description.ConfigLoader.Confi gureEndpoint(StandardEndpointElement standardEndpointElement, ServiceEndpointElement serviceEndpointElement, ContextInformation context, ServiceHostBase host, ServiceDescription description, ServiceEndpoint& endpoint, Boolean omitSettingEndpointAddress) +487
    System.ServiceModel.Description.ConfigLoader.Looku pEndpoint(ServiceEndpointElement serviceEndpointElement, ContextInformation context, ServiceHostBase host, ServiceDescription description, Boolean omitSettingEndpointAddress) +616
    System.ServiceModel.Web.WebServiceHost.AddAutomati cWebHttpBindingEndpoints(ServiceHost host, IDictionary`2 implementedContracts, String multipleContractsErrorMessage, String standardEndpointKind) +711
    System.ServiceModel.Web.WebServiceHost.OnOpening() +244
    System.ServiceModel.Channels.CommunicationObject.O pen(TimeSpan timeout) +274
    System.ServiceModel.HostingManager.ActivateService (String normalizedVirtualPath) +206
    System.ServiceModel.HostingManager.EnsureServiceAv ailable(String normalizedVirtualPath) +651

    [ServiceActivationException: The service '/api/setup' cannot be activated due to an exception during compilation. The exception message is: Could not find a base address that matches scheme http for the endpoint with binding WebHttpBinding. Registered base address schemes are [https]..]
    System.Runtime.AsyncResult.End(IAsyncResult result) +688702
    System.ServiceModel.Activation.HostedHttpRequestAs yncResult.End(IAsyncResult result) +190
    System.ServiceModel.Activation.AspNetRouteServiceH ttpHandler.EndProcessRequest(IAsyncResult result) +6
    System.Web.CallHandlerExecutionStep.OnAsyncHandler Completion(IAsyncResult ar) +96


    Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.0.30319.1016
    I had a working V8 on this same server with the same configuration so I'm at a loss to see what was changed. When I upgraded I made a backup of the whole HAP folder and started from scratch. I haven't copied my config back yet so this is just like a fresh install. When I put my version 8 files back as active it all works again.

    From the error above if I change the following
    Code:
    <standardEndpoint name="" helpEnabled="true" automaticFormatS...
    to
    Code:
    <standardEndpoint name="{anything}" helpEnabled="true" automaticFormatS...
    the error at least goes away but the service status says endpoint not found of course.

    Any help greatly appreciated

  2. #2
    cromertech's Avatar
    Join Date
    Dec 2007
    Location
    Cromer by the coast
    Posts
    731
    Thank Post
    177
    Thanked 109 Times in 97 Posts
    Rep Power
    55
    Have found my answer.

    change this in web.config
    Code:
    <system.serviceModel> <behaviors> <serviceBehaviors> <behavior name=""> <serviceMetadata httpGetEnabled="false" httpsGetEnabled="true" /> </behavior> </serviceBehaviors> </behaviors> <bindings> <webHttpBinding> <binding> <security mode="Transport" /> </binding> </webHttpBinding> </bindings> <serviceHostingEnvironment aspNetCompatibilityEnabled="true" multipleSiteBindingsEnabled="true" /> <standardEndpoints> <webHttpEndpoint> <standardEndpoint name="" helpEnabled="true" automaticFormatSelectionEnabled="true" faultExceptionEnabled="true"> <security mode="Transport"/> </standardEndpoint> </webHttpEndpoint> </standardEndpoints> </system.serviceModel>



SHARE:
+ Post New Thread

Similar Threads

  1. HAP - Red cross on Services Activated - Also API error
    By Femi in forum Home Access Plus+
    Replies: 3
    Last Post: 21st November 2013, 04:18 PM
  2. Services Activated red cross
    By glennda in forum Home Access Plus+
    Replies: 40
    Last Post: 7th December 2012, 09:21 AM
  3. Another Services Activated: RED X
    By Marshall_IT in forum Home Access Plus+
    Replies: 2
    Last Post: 15th October 2012, 03:33 PM
  4. Replies: 2
    Last Post: 24th February 2012, 05:06 PM
  5. SynchronEyes 7 - Red Crosses through students?
    By TheydonBois in forum Educational Software
    Replies: 1
    Last Post: 6th October 2009, 12:27 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •