+ Post New Thread
Results 1 to 4 of 4
Home Access Plus+ Thread, Upgrading to 9.6 failed! in Projects:; Hi, I just tried going from 9.5 to 9.6. I'm not sure what the error was but when I tried ...
  1. #1
    reggiep's Avatar
    Join Date
    Apr 2008
    Location
    In the vast area of space and time
    Posts
    1,548
    Thank Post
    517
    Thanked 56 Times in 50 Posts
    Rep Power
    29

    Upgrading to 9.6 failed!

    Hi,
    I just tried going from 9.5 to 9.6. I'm not sure what the error was but when I tried to roll back I got a similar error.
    So I restored from backup, upgraded from 8.3 to 8.6 but when I try to go to 9.0 now I get this error...

    Code:
    [NullReferenceException: Object reference not set to an instance of an object.]
       HAP.Web.Configuration.hapConfig.doUpgrade(Version version) +9258
       HAP.Web.Configuration.hapConfig..ctor() +666
       HAP.Web.Configuration.hapConfig.get_Current() +135
       HAP.Web.Global.Application_Start(Object sender, EventArgs e) +52
    
    [HttpException (0x80004005): Object reference not set to an instance of an object.]
       System.Web.HttpApplicationFactory.EnsureAppStartCalledForIntegratedMode(HttpContext context, HttpApplication app) +4057141
       System.Web.HttpApplication.RegisterEventSubscriptionsWithIIS(IntPtr appContext, HttpContext context, MethodInfo[] handlers) +191
       System.Web.HttpApplication.InitSpecial(HttpApplicationState state, MethodInfo[] handlers, IntPtr appContext, HttpContext context) +352
       System.Web.HttpApplicationFactory.GetSpecialApplicationInstance(IntPtr appContext, HttpContext context) +407
       System.Web.Hosting.PipelineRuntime.InitializeApplication(IntPtr appContext) +375
    
    [HttpException (0x80004005): Object reference not set to an instance of an object.]
       System.Web.HttpRuntime.FirstRequestInit(HttpContext context) +11700896
       System.Web.HttpRuntime.EnsureFirstRequestInit(HttpContext context) +141
       System.Web.HttpRuntime.ProcessRequestNotificationPrivate(IIS7WorkerRequest wr, HttpContext context) +4869125
    With my limited skills it looks like it is looking for version +9258 of something!

    Can anyone help?

    Thanks

  2. #2
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,483
    Thank Post
    37
    Thanked 490 Times in 422 Posts
    Rep Power
    110
    That's a known error with the v9.0 upgrade script, you will need to delete your hapConfig.xml file and create a new one

  3. Thanks to nickbro from:

    reggiep (30th September 2013)

  4. #3
    reggiep's Avatar
    Join Date
    Apr 2008
    Location
    In the vast area of space and time
    Posts
    1,548
    Thank Post
    517
    Thanked 56 Times in 50 Posts
    Rep Power
    29
    Cheers Nick. I did look through here before I asked! On a side note how do I find the hap app in the windows phone 8 store?

  5. #4
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,483
    Thank Post
    37
    Thanked 490 Times in 422 Posts
    Rep Power
    110

SHARE:
+ Post New Thread

Similar Threads

  1. [SIMS] [SOLUS3] - Force a upgrade to "failed"
    By Rawns in forum MIS Systems
    Replies: 1
    Last Post: 16th July 2013, 09:23 AM
  2. Replies: 3
    Last Post: 12th October 2011, 11:52 AM
  3. Exchange 2010 upgrade to SP1 - Fails on Prerequisites.
    By harriuk in forum Enterprise Software
    Replies: 2
    Last Post: 23rd March 2011, 07:05 PM
  4. Replies: 10
    Last Post: 26th October 2006, 08:07 AM
  5. Upgrading to dual core
    By ajbritton in forum Hardware
    Replies: 3
    Last Post: 19th May 2006, 11:06 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •