+ Post New Thread
Results 1 to 5 of 5
Home Access Plus+ Thread, HAP+ V9.x - Method is only supported if the user name parameter matches current user in Projects:; Hi. Still having fun setting up HAP+ Completed setup.aspx ok.. everything talks to AD and shows my OU's, groups etc. ...
  1. #1
    Mr_P's Avatar
    Join Date
    Mar 2009
    Location
    London
    Posts
    11
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    HAP+ V9.x - Method is only supported if the user name parameter matches current user

    Hi.

    Still having fun setting up HAP+

    Completed setup.aspx ok.. everything talks to AD and shows my OU's, groups etc.

    So.. go to the login screen and tried my first login as admin..

    Page logs in.. but I get the message
    "
    Error: Unauthorised Access

    You have attempted to access a restricted resource
    "

    At this point any option I click on the screen I am presented with the below error.


    [ProviderException: Method is only supported if the user name parameter matches the user name in the current Windows Identity.]
    System.Web.Security.WindowsTokenRoleProvider.GetCu rrentWindowsIdentityAndCheckName(String userName) +782
    System.Web.Security.WindowsTokenRoleProvider.GetCu rrentTokenAndCheckName(String userName) +49
    System.Web.Security.WindowsTokenRoleProvider.GetRo lesForUser(String username) +99
    HAP.AD.RoleProvider.GetRolesForUser(String username) +93
    System.Web.Security.RolePrincipal.IsInRole(String role) +322
    HAP.Web.Default.Page_Load(Object sender, EventArgs e) +692
    System.Web.UI.Control.LoadRecursive() +116
    System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +2910
    -------------------------------------------------------------------------------
    Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.0.30319.17929

    Any ideas what is going on here.?

    In my IIS authentication I have only Anonymous Authentication Enabled and using IIS_AppPool creds, I also have forms authentication enabled.. . the remaining 4 methods are disabled.

    I have also checked my local policy and domains users are set to login locally.

    Any pointers would be appreaciated.

    Rgds

    Mr_P

  2. #2
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,520
    Thank Post
    37
    Thanked 501 Times in 432 Posts
    Rep Power
    113
    Hmm, that's an odd one.

    Check the Admin user you used on the AD tab is the Administrator, or such like.

    Try deleting ~/app_Data/hapConfig.xml and remake it using the setup page

  3. #3
    Mr_P's Avatar
    Join Date
    Mar 2009
    Location
    London
    Posts
    11
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Quote Originally Posted by nickbro View Post
    Hmm, that's an odd one.

    Check the Admin user you used on the AD tab is the Administrator, or such like.

    Try deleting ~/app_Data/hapConfig.xml and remake it using the setup page

    Hi.. tried as you said.. this time during setup I now get a message at the point of clicking in the Students Group part of Active Directory Tabs.

    The error appears in a Message From Webpage alert box.
    The error is: System.ServiceModel.ServiceActivationException

    Now cant get any further.. got much further before.

  4. #4
    Mr_P's Avatar
    Join Date
    Mar 2009
    Location
    London
    Posts
    11
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    event viewer.. shows.

    Event code: 3005
    Event message: An unhandled exception has occurred.
    Event time: 01/10/2013 12:27:22
    Event time (UTC): 01/10/2013 11:27:22
    Event ID: 488dd104b4b040fd9dc78aafd9ba6623
    Event sequence: 86
    Event occurrence: 4
    Event detail code: 0

    Application information:
    Application domain: /LM/W3SVC/1/ROOT/hap-1-130250999308161749
    Trust level: Full
    Application Virtual Path: /hap
    Application Path: C:\inetpub\wwwroot\hap\
    Machine name: SERVER1

    Process information:
    Process ID: 6288
    Process name: w3wp.exe
    Account name: IIS APPPOOL\HAP

    Exception information:
    Exception type: InvalidOperationException
    Exception message: A binding instance has already been associated to listen URI 'https://server1/hap/api/setup'. If two endpoints want to share the same ListenUri, they must also share the same binding object instance. The two conflicting endpoints were either specified in AddServiceEndpoint() calls, in a config file, or a combination of AddServiceEndpoint() and config.
    at System.ServiceModel.Description.DispatcherBuilder. InitializeServiceHost(ServiceDescription description, ServiceHostBase serviceHost)
    at System.ServiceModel.ServiceHostBase.InitializeRunt ime()
    at System.ServiceModel.ServiceHostBase.OnOpen(TimeSpa n timeout)
    at System.ServiceModel.Channels.CommunicationObject.O pen(TimeSpan timeout)
    at System.ServiceModel.ServiceHostingEnvironment.Host ingManager.ActivateService(ServiceActivationInfo serviceActivationInfo, EventTraceActivity eventTraceActivity)
    at System.ServiceModel.ServiceHostingEnvironment.Host ingManager.EnsureServiceAvailable(String normalizedVirtualPath, EventTraceActivity eventTraceActivity)



    Request information:
    Request URL: https://server1:443/hap/api/setup/help
    Request path: /hap/api/setup/help
    User host address: 10.25.3.254
    User:
    Is authenticated: False
    Authentication Type:
    Thread account name: IIS APPPOOL\HAP

    Thread information:
    Thread ID: 31
    Thread account name: IIS APPPOOL\HAP
    Is impersonating: False
    Stack trace: at System.ServiceModel.Description.DispatcherBuilder. InitializeServiceHost(ServiceDescription description, ServiceHostBase serviceHost)
    at System.ServiceModel.ServiceHostBase.InitializeRunt ime()
    at System.ServiceModel.ServiceHostBase.OnOpen(TimeSpa n timeout)
    at System.ServiceModel.Channels.CommunicationObject.O pen(TimeSpan timeout)
    at System.ServiceModel.ServiceHostingEnvironment.Host ingManager.ActivateService(ServiceActivationInfo serviceActivationInfo, EventTraceActivity eventTraceActivity)
    at System.ServiceModel.ServiceHostingEnvironment.Host ingManager.EnsureServiceAvailable(String normalizedVirtualPath, EventTraceActivity eventTraceActivity)


    Custom event details:

  5. #5
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,520
    Thank Post
    37
    Thanked 501 Times in 432 Posts
    Rep Power
    113
    I can't help with that error, it's an IIS error

SHARE:
+ Post New Thread

Similar Threads

  1. script to only run if it cant ping a host
    By RabbieBurns in forum Scripts
    Replies: 8
    Last Post: 3rd November 2012, 08:44 PM
  2. Replies: 73
    Last Post: 27th April 2012, 09:37 AM
  3. [Fog] When i restore image the partition is only 18gb on a 320gb drive
    By danny0001uk in forum O/S Deployment
    Replies: 1
    Last Post: 26th August 2010, 09:55 PM
  4. Replies: 7
    Last Post: 1st December 2009, 10:45 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •