+ Post New Thread
Results 1 to 3 of 3
Home Access Plus+ Thread, User Card API Lockdown & Kerberos Issues in Projects:; Hi @ nickbro I have followed instructions from your videos for the User Card API lockdown and Kerberos setups. Both ...
  1. #1

    Join Date
    Apr 2013
    Location
    Birmingham
    Posts
    119
    Thank Post
    5
    Thanked 4 Times in 4 Posts
    Rep Power
    4

    User Card API Lockdown & Kerberos Issues

    Hi @nickbro

    I have followed instructions from your videos for the User Card API lockdown and Kerberos setups. Both work internally if I use https://<server name>/hap but if I use the external address of https://www.schoolname.sch.uk/hap internally then kerberos authentication fails to work and automatically login and the User Card API gives me a 403 Access Denied. Any ideas on what would be causing this and where I should begin to look to resolve it. Is it something to do with reverse DNS lookups? if so do I need to enable this in my IIS config under the IP and domain restrictions? or is it to do with my main DC that deals with DNS.

  2. #2

    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,644
    Thank Post
    43
    Thanked 549 Times in 458 Posts
    Rep Power
    121
    Yep reverse lookups, you may want to add internal DNS on your DNS server for your hap install, so internally it uses the internal IP, externally it uses the public ones then

  3. Thanks to nickbro from:

    Paul-K (22nd August 2013)

  4. #3

    Join Date
    Apr 2013
    Location
    Birmingham
    Posts
    119
    Thank Post
    5
    Thanked 4 Times in 4 Posts
    Rep Power
    4
    Cheers Nick,

    Hadn't even considered the simple option off adding a DNS entry. For anyone else wondering on this one:

    1 - I added a DNS entry on our DNS server for the website hosting HAP+ and created the PTR record to
    2 - Added the HAP website that I just created a DNS entry for to the proxy exception list
    3 - My website has a plugin that doesn't like compatibility mode so I then enabled "Turn on Internet Explorer Standards mode for intranet" in GP, this stops IE loading intranet sites in compatibility mode. This policy can be found under "Computer Configuration - Policies - Administrative Templates - Windows Components - Internet Explorer - Compatibility View".

    Big thanks as always to @nickbro

SHARE:
+ Post New Thread

Similar Threads

  1. User Card Issue
    By mmoseley in forum Home Access Plus+
    Replies: 11
    Last Post: 3rd June 2011, 11:10 PM
  2. [CLOSED] Bug/Error: User map API problem
    By localzuk in forum EduGeek.net Site Problems
    Replies: 2
    Last Post: 10th March 2010, 03:03 PM
  3. Transfer User Area's - Permissions Issues ??
    By mac_shinobi in forum Wireless Networks
    Replies: 24
    Last Post: 21st May 2008, 12:36 PM
  4. Configuring Desktops: default user; sysprep - ISSUES!!
    By monsterplastic in forum Windows
    Replies: 4
    Last Post: 25th January 2007, 11:27 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •