+ Post New Thread
Results 1 to 6 of 6
Home Access Plus+ Thread, Help needed Getting my HAP setup to the outside world in Projects:; Hi all. I have hit the limit of my knowledge of IIS (little to no knowledge for a fact). I ...
  1. #1

    Join Date
    Jan 2009
    Location
    Tavistock
    Posts
    300
    Thank Post
    61
    Thanked 120 Times in 52 Posts
    Rep Power
    34

    Help needed Getting my HAP setup to the outside world

    Hi all.
    I have hit the limit of my knowledge of IIS (little to no knowledge for a fact). I have HAP setup on Windows web server 2008 R2 (server is called HOMEACCESS) using https with a self certificate and all works fine, home directory and mapped drives are displaying fine etc. When I log onto the site using address https://homeaccess/HAP/login.aspx it says the 'SSL certificate is invalid and meant to another site' but I can ignore it and carry on, the only place I found in IIS to add a SSL cert was to right click on the servers name in IIS and add it to there, my HAP application is inside a subfolder of 'Default website' in IIS, is that correct?

    I have given the server with HAP installed a static internal IP address 10.*.*.2 and have got SWGFL to assign that address an external static IP address and open port 443, this is all done now. I have applied to https://www.startssl.com/ but waiting for them to get back to me. I have setup a subdomain of our school website (www.*school name*.org.uk) called 'HAP.*school name*.org.uk' and got that subdomain to point to my fixed external IP address of my HAP server that SWGFL setup (nslookup confirms this).

    My main question is how to I get my internal server to talk to the outside world via my external address, so when I am in the outside world all I need to type is https://hap.*school name*.org.uk to login? I have searched but I can not find the steps needed for this to happen. One section said to add the external IP address to the bindings of the site, I have tried but I can only add bindings to the default website not to my hap folder and also I can not seem to enter an IP address to bind anyway, I must be missing something simple.

    I hope I have provided enough information for anyone to help me. Please make any explanation or instructions very simple as I have never got this far with setting up HAP and have very little knowledge of IIS etc

    P.S this is all a result of Merlin shutting down soon so that teachers can access all their work at home.
    Last edited by JAB1a; 26th July 2013 at 03:12 PM.

  2. #2
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,477
    Thank Post
    37
    Thanked 485 Times in 417 Posts
    Rep Power
    109
    Contact SWGFL they need to do the stuff

  3. #3

    Join Date
    Jan 2009
    Location
    Tavistock
    Posts
    300
    Thank Post
    61
    Thanked 120 Times in 52 Posts
    Rep Power
    34
    Quote Originally Posted by nickbro View Post
    Contact SWGFL they need to do the stuff
    Cheers for the reply Nick . What 'Stuff' do I need to ask SWGFL to do? sorry I need simple but informative instructions please

    SWGFL have setup my external address and 'NATed' (not sure that the right term) it to my internal address and opened port 443, I have contacted our website host who have setup the subdomain and have pointed it at the external IP address SWGFL setup. I have checked this by using nslookup which provides the IP SWGFL setup.

  4. #4
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,477
    Thank Post
    37
    Thanked 485 Times in 417 Posts
    Rep Power
    109
    Ok, it may only work externally, not internally. I don't know how SWGFL works, I'm a Powys CC LA school, so can't really help much more.

    It's along the right lines though.

  5. #5

    Join Date
    Jan 2009
    Location
    Tavistock
    Posts
    300
    Thank Post
    61
    Thanked 120 Times in 52 Posts
    Rep Power
    34
    Cheers Nick,

    My main question is how to I get my internal server to talk to the outside world via my external address, so when I am in the outside world all I need to type is https://hap.*school name*.org.uk to login? I have searched but I can not find the steps needed for this to happen. One section said to add the external IP address to the bindings of the site, I have tried but I can only add bindings to the default website not to my hap folder and also I can not seem to enter an IP address to bind anyway, I must be missing something simple?

  6. #6

    FN-GM's Avatar
    Join Date
    Jun 2007
    Location
    UK
    Posts
    15,816
    Thank Post
    873
    Thanked 1,675 Times in 1,458 Posts
    Blog Entries
    12
    Rep Power
    444
    1. Obtain external IP Address
    2. On the firewall Port forward port 443 to your HAP server
    3. Setup DNS for your external doamin so that hap.school.com points to your IP external IP in step 1

  7. Thanks to FN-GM from:

    JAB1a (30th July 2013)

SHARE:
+ Post New Thread

Similar Threads

  1. How Do I Get My Domain Controllers To Replicate
    By dgrams in forum How do you do....it?
    Replies: 4
    Last Post: 31st January 2010, 04:42 PM
  2. Getting from Preston Rail to The Ibis
    By CAM in forum EduGeek May 2009 Conference
    Replies: 8
    Last Post: 27th May 2009, 03:26 PM
  3. Replies: 17
    Last Post: 23rd February 2009, 11:26 AM
  4. Replies: 7
    Last Post: 1st August 2007, 09:47 PM
  5. Get Exchange Server talking to the outside world.
    By OverWorked in forum How do you do....it?
    Replies: 7
    Last Post: 5th September 2006, 10:16 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •