+ Post New Thread
Results 1 to 3 of 3
Home Access Plus+ Thread, [HAP+ v9.0] Access control on MyFiles mapped drives in Projects:; Hello, me again! Got another oddity - when I try to change 'Enable Read to' or 'Enable Write to' to ...
  1. #1
    FishCustard's Avatar
    Join Date
    Feb 2013
    Location
    Croydon
    Posts
    426
    Thank Post
    74
    Thanked 43 Times in 39 Posts
    Rep Power
    19

    [HAP+ v9.0] Access control on MyFiles mapped drives

    Hello, me again!

    Got another oddity - when I try to change 'Enable Read to' or 'Enable Write to' to something other than the default 'All', I click on 'Custom' in the popup box, typing something into the search field and then click to search. The 'Active Directory Browser' pops up but remains blank and inert.

    [HAP+ v9.0] Access control on MyFiles mapped drives-hapweird1.png

    If I try typing a group name into the box, clicking 'Add' and then saving, I get the following error:

    Code:
    The  formatter threw an exception while trying to deserialize the message:  There was an error while trying to deserialize parameter  HAP.Web.API:origunc. The InnerException message was 'There was an error  deserializing the object of type System.String. Encountered unexpected  character 'S'.'.  Please see InnerException for more details.
    This happens whether I use a bare group name, or the Distinguished Name. I've tried Chrome, Firefox, IE 8 and 9 - same results.

    Any ideas?

    ----

    EDIT: Found what is probably the root weirdness: My AD credentials aren't being saved (properly?).

    I enter the username and password, click 'Save' and everything goes through okay, but when the page reloads there's still a red cross next to 'Basic settings'.

    I see the below in Firebug if it helps.

    [HAP+ v9.0] Access control on MyFiles mapped drives-hapweird2.png

    What's odd is that other things that rely on AD connectivity (like file uploads) work, so... 'wat?!'

    ----

    Okay, this is going to be the last edit, promise! I can get the browser to work by putting in the PW on the Basic Settings screen, not clicking Save and then going straight to the MyFiles tab, but when I add a group to the list through the browser and click 'Save', I still get the deserialization error as above. My group names have spaces in them if that's relevant.
    Last edited by FishCustard; 22nd July 2013 at 02:24 PM.

  2. #2

    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,675
    Thank Post
    43
    Thanked 557 Times in 465 Posts
    Rep Power
    122
    You may want to directly edit the hapConfig.xml file

  3. #3
    FishCustard's Avatar
    Join Date
    Feb 2013
    Location
    Croydon
    Posts
    426
    Thank Post
    74
    Thanked 43 Times in 39 Posts
    Rep Power
    19
    Quote Originally Posted by nickbro View Post
    You may want to directly edit the hapConfig.xml file
    Thanks - is there a schema for what I should put in the MyFiles section?



SHARE:
+ Post New Thread

Similar Threads

  1. Problems editing already mapped drive in HAP v9.1
    By Paul-K in forum Home Access Plus+
    Replies: 9
    Last Post: 22nd May 2013, 03:46 PM
  2. Domain Controller not reading mapped drive!
    By gloriousglenn in forum Windows Server 2000/2003
    Replies: 28
    Last Post: 18th August 2009, 02:47 PM
  3. Restricting executables on a mapped drive
    By Jambo_C in forum Windows Server 2000/2003
    Replies: 8
    Last Post: 2nd June 2009, 04:36 PM
  4. Access control lists on DNS Server
    By Neville in forum Windows
    Replies: 0
    Last Post: 10th November 2008, 01:19 PM
  5. Accessing Printer on other network.
    By SimpleSi in forum Wireless Networks
    Replies: 5
    Last Post: 13th June 2006, 06:32 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •