+ Post New Thread
Results 1 to 5 of 5
Home Access Plus+ Thread, Problem with special characters in passwords in Projects:; Hello, We are currently rolling out HAP+ to test in our environment. While testing, it appears if a user has ...
  1. #1

    Join Date
    Jul 2013
    Posts
    3
    Thank Post
    2
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Problem with special characters in passwords

    Hello,

    We are currently rolling out HAP+ to test in our environment. While testing, it appears if a user has a greater then or less then character (<,>) in their password, the application spits out an error:

    Server Error in '/hap' Application.
    ________________________________________
    A potentially dangerous Request.Form value was detected from the client (ctl00$body$password="<users password was here>").

    Not sure about other characters as I haven't fully tested. Just wondering if there is a work around for this? Sorry if it's already been asked, I searched the forum but couldn't find anything.

    Thanks,
    John

  2. #2

    Join Date
    Nov 2011
    Location
    Cambridgeshire
    Posts
    522
    Thank Post
    141
    Thanked 75 Times in 67 Posts
    Rep Power
    19
    Could it be to do with encoding? I had problems with other services when I tried to use as a character in a password. It's not an ANSI character. Unfortunately, the system I was using didn't throw out error messages - it just denied me access...

  3. Thanks to jmak from:

    johnjs (8th July 2013)

  4. #3

    Join Date
    Jul 2013
    Posts
    3
    Thank Post
    2
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Thanks for the reply. I'm really not sure, I'm not really great with coding. I have ran into this with other applications, not sure if it has to do with the XML using < and > in it's formatting.

  5. #4
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,484
    Thank Post
    37
    Thanked 490 Times in 422 Posts
    Rep Power
    110
    This is a security feature of ASP.net. To turn it off is very tricky.

    HTML Code:
    <configuration>
    ...
      <location path="login.aspx">
        <system.web>
          <pages validateRequest="false" />
          <httpRuntime requestValidationMode="2.0" />
        </system.web>
      </location>
    ...
    </configuration>

  6. Thanks to nickbro from:

    johnjs (8th July 2013)

  7. #5

    Join Date
    Jul 2013
    Posts
    3
    Thank Post
    2
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    That did it, thanks for the help!!

SHARE:
+ Post New Thread

Similar Threads

  1. Replies: 0
    Last Post: 1st November 2010, 10:24 AM
  2. Permission problems with SEN access in Sims
    By Mongoose in forum MIS Systems
    Replies: 10
    Last Post: 27th March 2010, 09:58 AM
  3. problem with web page in FF...
    By beeswax in forum Web Development
    Replies: 2
    Last Post: 10th March 2008, 12:31 PM
  4. Replies: 1
    Last Post: 4th October 2007, 08:28 AM
  5. Problem with Proxy settings in GPO
    By tosca925 in forum Windows
    Replies: 9
    Last Post: 18th January 2006, 12:54 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •