+ Post New Thread
Results 1 to 5 of 5
Home Access Plus+ Thread, Upgrading from v8 to v9 in Projects:; Is there any instructions to achieve this successfully? is it just an overright of the exisiting files and copying the ...
  1. #1

    Join Date
    Nov 2005
    Location
    North
    Posts
    1,842
    Thank Post
    25
    Thanked 91 Times in 71 Posts
    Rep Power
    51

    Upgrading from v8 to v9

    Is there any instructions to achieve this successfully? is it just an overright of the exisiting files and copying the relevant config files back across?

  2. #2
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,593
    Thank Post
    39
    Thanked 514 Times in 444 Posts
    Rep Power
    115
    Delete all but the app_data folder, and install the v9 base web release, then the latest upgrade. Run HAP+ and it should upgrade

  3. #3

    Join Date
    Nov 2005
    Location
    North
    Posts
    1,842
    Thank Post
    25
    Thanked 91 Times in 71 Posts
    Rep Power
    51
    It hates me.

    Server Error in '/HAP' Application.


    Object reference not set to an instance of an object.

    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: System.NullReferenceException: Object reference not set to an instance of an object.

    Source Error:

    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

    Stack Trace:

    [NullReferenceException: Object reference not set to an instance of an object.] HAP.Web.Configuration.hapConfig.doUpgrade(Version version) +9258 HAP.Web.Configuration.hapConfig..ctor() +666 HAP.Web.Configuration.hapConfig.get_Current() +135 HAP.Web.Global.Application_Start(Object sender, EventArgs e) +52[HttpException (0x80004005): Object reference not set to an instance of an object.] System.Web.HttpApplicationFactory.EnsureAppStartCa lledForIntegratedMode(HttpContext context, HttpApplication app) +4064869 System.Web.HttpApplication.RegisterEventSubscripti onsWithIIS(IntPtr appContext, HttpContext context, MethodInfo[] handlers) +191 System.Web.HttpApplication.InitSpecial(HttpApplica tionState state, MethodInfo[] handlers, IntPtr appContext, HttpContext context) +352 System.Web.HttpApplicationFactory.GetSpecialApplic ationInstance(IntPtr appContext, HttpContext context) +407 System.Web.Hosting.PipelineRuntime.InitializeAppli cation(IntPtr appContext) +375[HttpException (0x80004005): Object reference not set to an instance of an object.] System.Web.HttpRuntime.FirstRequestInit(HttpContex t context) +11775984 System.Web.HttpRuntime.EnsureFirstRequestInit(Http Context context) +141 System.Web.HttpRuntime.ProcessRequestNotificationP rivate(IIS7WorkerRequest wr, HttpContext context) +4914821

  4. #4
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,593
    Thank Post
    39
    Thanked 514 Times in 444 Posts
    Rep Power
    115
    Ah, the dreaded upgrade failed error. backup your hapConfig.xml, delete it. Use setup to create a new one, then copy parts of the old config over the new one (using notepad).

    Sorry about this. I never did find out why the upgrade failed like that.

  5. #5

    Join Date
    Nov 2005
    Location
    North
    Posts
    1,842
    Thank Post
    25
    Thanked 91 Times in 71 Posts
    Rep Power
    51
    Don't apologize, your doing us all a favour with this project.

    Will have another go tommorow, I tried copying stuff from one XML to the other and it didn't like any of the line... then it didn't show any icons so I think I will just manually use the GUI to recreate the links... won't take me long.

SHARE:
+ Post New Thread

Similar Threads

  1. HAP v9 Upgrade from V8 - Problem
    By timbo343 in forum Home Access Plus+
    Replies: 14
    Last Post: 17th May 2013, 01:53 PM
  2. Upgrade from 2003 to 2008R2 with Exchange 2003
    By Jamo in forum Windows Server 2008 R2
    Replies: 2
    Last Post: 11th July 2011, 02:06 PM
  3. Replies: 0
    Last Post: 10th November 2010, 08:51 AM
  4. upgrading from 2008 to 2008 r2 dc's
    By ful56_uk in forum Windows Server 2008 R2
    Replies: 8
    Last Post: 2nd February 2010, 02:13 PM
  5. Samsung R510 laptop - upgrade from VHP to VB
    By dgsmith in forum Windows
    Replies: 2
    Last Post: 28th May 2009, 11:52 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •