+ Post New Thread
Results 1 to 8 of 8
Home Access Plus+ Thread, Server Error in '/HAP' Application in Projects:; Hi Nick, I have a problem which seems intermittent and is fixed by a restart of IIS, but if it ...
  1. #1

    Join Date
    Dec 2009
    Location
    Cranleigh, Surrey
    Posts
    27
    Thank Post
    6
    Thanked 2 Times in 2 Posts
    Rep Power
    10

    Server Error in '/HAP' Application

    Hi Nick, I have a problem which seems intermittent and is fixed by a restart of IIS, but if it falls over during the weekend the users are without access until the next day, The attached error occurs after the login page, when users successfully authenticate and instead of getting their Homepage they get the error.

    Server Error in '/HAP' Application-hap-server-error.png

    Unfortunately I can't currently reproduce so not got any-more than the attached screenshot, but know that when it occurs it is not browser specific, nor computer/OS specific it affects all users.

  2. #2
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,520
    Thank Post
    37
    Thanked 501 Times in 432 Posts
    Rep Power
    113
    Restart IIS

  3. #3

    Join Date
    Dec 2009
    Location
    Cranleigh, Surrey
    Posts
    27
    Thank Post
    6
    Thanked 2 Times in 2 Posts
    Rep Power
    10
    Hi Nick, restarting IIS fixes it, but it then fails again, as has just been reported to me again I fired up FireBug and got this line:

    "NetworkError: 500 Internal Server Error - https://hap.glebelands.surrey.sch.uk/HAP/login.aspx?ReturnUrl=%2fhap"

    Do I need to look at hosting this on a different server if it is an IIS issue?

    Thanks
    Guy

  4. #4
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,520
    Thank Post
    37
    Thanked 501 Times in 432 Posts
    Rep Power
    113
    Hmm I don't know, can you restart the server it's on? It's something to do with some of the HAP+ stuff not being loaded into cache

  5. #5

    Join Date
    Dec 2009
    Location
    Cranleigh, Surrey
    Posts
    27
    Thank Post
    6
    Thanked 2 Times in 2 Posts
    Rep Power
    10
    A restart of the server fixes it for a short while, as does just restarting the HTTPS and WWW services on the server, but unfortunately short lived.
    Thanks
    Guy

  6. #6
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,520
    Thank Post
    37
    Thanked 501 Times in 432 Posts
    Rep Power
    113
    Ok, can you try this attached dll

  7. Thanks to nickbro from:

    gomalley (27th February 2013)

  8. #7

    Join Date
    Dec 2009
    Location
    Cranleigh, Surrey
    Posts
    27
    Thank Post
    6
    Thanked 2 Times in 2 Posts
    Rep Power
    10
    Thanks Nick I've applied that and will let you know how it goes.
    Guy

  9. #8

    Join Date
    Dec 2009
    Location
    Cranleigh, Surrey
    Posts
    27
    Thank Post
    6
    Thanked 2 Times in 2 Posts
    Rep Power
    10
    Been working now since I implemented the fix without needing any restarts.
    Many Many Thanks for this.
    Guy

  10. Thanks to gomalley from:

    nickbro (27th February 2013)

SHARE:
+ Post New Thread

Similar Threads

  1. Server Error in /Hap Application Reference Dropzone
    By nyates in forum Home Access Plus+
    Replies: 2
    Last Post: 5th December 2012, 01:03 PM
  2. Server Error in /Hap Application
    By nyates in forum Home Access Plus+
    Replies: 2
    Last Post: 28th November 2012, 08:59 AM
  3. Server Error in '/hap' Application -intermittent error
    By dosh in forum Home Access Plus+
    Replies: 8
    Last Post: 6th June 2012, 10:25 PM
  4. Server Error in '/HAP' Application.
    By victory2009 in forum Home Access Plus+
    Replies: 17
    Last Post: 6th June 2012, 01:40 PM
  5. Replies: 19
    Last Post: 20th January 2012, 02:09 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •