+ Post New Thread
Results 1 to 7 of 7
Home Access Plus+ Thread, Home Access Plus Upgrade to 8.7 in Projects:; Hi Nick, Can you let me know two things: 1. What is the correct and safest method to upgrade Home ...
  1. #1

    Join Date
    Nov 2012
    Posts
    10
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Home Access Plus Upgrade to 8.7

    Hi Nick,
    Can you let me know two things:

    1. What is the correct and safest method to upgrade Home Acces Plus from version 8.5 to 8.7. I do not see any documenation on website.

    2. How do I stop the warning message about upgrades when student or staff logon but still appear when admin members logon?

    Thanks
    Nathan

  2. #2

    Danp's Avatar
    Join Date
    Jul 2011
    Posts
    1,446
    Thank Post
    78
    Thanked 168 Times in 148 Posts
    Rep Power
    147
    Quote Originally Posted by nyates View Post
    Hi Nick,
    Can you let me know two things:

    1. What is the correct and safest method to upgrade Home Access Plus from version 8.5 to 8.7. I do not see any documenation on website.

    2. How do I stop the warning message about upgrades when student or staff logon but still appear when admin members logon?

    Thanks
    Nathan
    1. - turn off website in IIS, take a backup of the files, copy and paste from upgrade folder to your HAP folder. Restart website.

    2. - Line 30'ish of hapconfig.xml within app_data

    <AnnouncementBox showto="All" enableeditto="Domain Admins" />

  3. #3
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,581
    Thank Post
    39
    Thanked 513 Times in 443 Posts
    Rep Power
    115
    The upgrade message will only be displayed to Domain Admins.

    The upgrade download will upgrade any version of v7 to v7.8

  4. #4

    Join Date
    Nov 2012
    Posts
    10
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Thanks Dan for your answer. I have carried out what you have said for the upgrade of version 8.5 - 8.7 and now get a server error.Have attached screenshot.
    Do you have any idea what this could be?
    Also Thanks to Nick for your answer and also do you now what the cause of this screenshot could be?
    Nathan
    Attached Files Attached Files

  5. #5
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,581
    Thank Post
    39
    Thanked 513 Times in 443 Posts
    Rep Power
    115
    You will need to go into the registry and remove anything to do with Home Access Plus from the event log, you may also need to grant read permissions to the HAP+ AppPool user for the security log. This is in the registry, search this forum for the specific steps

  6. #6

    Join Date
    Nov 2012
    Posts
    10
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Quote Originally Posted by nickbro View Post
    You will need to go into the registry and remove anything to do with Home Access Plus from the event log, you may also need to grant read permissions to the HAP+ AppPool user for the security log. This is in the registry, search this forum for the specific steps
    Thanks Nick - I followed other threads for this error where you have replied with this answer :

    Select Start - Run, then enter: regedt32
    Navigate/expand to the following key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic es\Eventlog\Security
    Right click on this entry and select Permissions
    Add the IIS AppPool\HAP User
    Give it Read permission

    This fixed the problem - now all working and running version 8.7

    Thanks
    Nathan

  7. #7
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,581
    Thank Post
    39
    Thanked 513 Times in 443 Posts
    Rep Power
    115
    Good to hear, sorry if my posted didn't sound right, I couldn't remember the fix off the top of my head

SHARE:
+ Post New Thread

Similar Threads

  1. Home Access Plus+
    By nickbro in forum Home Access Plus+
    Replies: 784
    Last Post: 24th February 2014, 03:39 PM
  2. Home Access Plus slow to load
    By smitho1990 in forum Home Access Plus+
    Replies: 1
    Last Post: 20th July 2012, 09:30 AM
  3. Replies: 1
    Last Post: 22nd February 2012, 12:10 PM
  4. Convert Home access plus site to secure site in IIS 7?
    By reggiep in forum Home Access Plus+
    Replies: 1
    Last Post: 28th April 2011, 01:23 PM
  5. Home Access Plus - How Secure?
    By andy_d in forum Internet Related/Filtering/Firewall
    Replies: 9
    Last Post: 31st March 2011, 12:30 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •