+ Post New Thread
Results 1 to 4 of 4
Home Access Plus+ Thread, Issues with Help Desk in Projects:; Nick and others, I just started playing around with the help desk portion of HAP, and ran into some issues ...
  1. #1

    Join Date
    Oct 2011
    Posts
    11
    Thank Post
    1
    Thanked 1 Time in 1 Post
    Rep Power
    0

    Issues with Help Desk

    Nick and others,

    I just started playing around with the help desk portion of HAP, and ran into some issues with it. I am able to create a new ticket as a teacher, but when I go to close the ticket as an admin, I get the following message:

    "String was not recognized as a valid DateTime."

    I installed firebug to see what was going on, and I get two error messages: 405 Method Not Allowed, and 400 An WCF Error has Occured


    Code:
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml">
    <head>
    <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1"/>
    <title>405 - HTTP verb used to access this page is not allowed.</title>
    <style type="text/css">
    <!--
    body{margin:0;font-size:.7em;font-family:Verdana, Arial, Helvetica, sans-serif;background:#EEEEEE;}
    fieldset{padding:0 15px 10px 15px;} 
    h1{font-size:2.4em;margin:0;color:#FFF;}
    h2{font-size:1.7em;margin:0;color:#CC0000;} 
    h3{font-size:1.2em;margin:10px 0 0 0;color:#000000;} 
    #header{width:96%;margin:0 0 0 0;padding:6px 2% 6px 2%;font-family:"trebuchet MS", Verdana, sans-serif;color:#FFF;
    background-color:#555555;}
    #content{margin:0 0 0 2%;position:relative;}
    .content-container{background:#FFF;width:96%;margin-top:8px;padding:10px;position:relative;}
    -->
    </style>
    </head>
    <body>
    <div id="header"><h1>Server Error</h1></div>
    <div id="content">
     <div class="content-container"><fieldset>
      <h2>405 - HTTP verb used to access this page is not allowed.</h2>
      <h3>The page you are looking for cannot be displayed because an invalid method (HTTP verb) was used to attempt access.</h3>
     </fieldset></div>
    </div>
    </body>
    </html>
    and

    Code:
    {"Message":"String was not recognized as a valid DateTime.","Detail":null,"FaultType":"FormatException"}
    I looked on the forum and saw this post

    String was not recognized as a valid DateTime

    but couldn't find the ".formatDate('d MM yy', curdate)" to take out in the ~HelpDesk/default.aspx. I wasn't sure if this was referring to an older version of HAP, and this line may not be in this version (8.6) or if I just missed it.

    The ticket never closes out, and if I choose to logout with that ticket open, it then throws up this error:
    Code:
    Server Error in '/HAPTEST' Application.
    'userlist' has a SelectedValue which is invalid because it does not exist in the list of items.
    Parameter name: value
    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.
    
    Exception Details: System.ArgumentOutOfRangeException: 'userlist' has a SelectedValue which is invalid because it does not exist in the list of items.
    Parameter name: value
    
    Source Error:
    
    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.
    
    Stack Trace:
    
    
    [ArgumentOutOfRangeException: 'userlist' has a SelectedValue which is invalid because it does not exist in the list of items.
    Parameter name: value]
       System.Web.UI.WebControls.ListControl.set_SelectedValue(String value) +3192331
       System.Web.Util.CalliHelper.EventArgFunctionCaller(IntPtr fp, Object o, Object t, EventArgs e) +25
       System.Web.UI.Control.LoadRecursive() +71
       System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +3064
    
    
    Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.0.30319.272
    Sorry for the big strings of code. I am running IIS 7.5 on Server 2008 R2 with HAP version 8.6.1213.1220. I am using https with a self-signed ssl certificate (for now, just for testing). I am not sure if it is something stupid I did, or because I am in the U.S. and the locale for HAP is GB, or something else completely different.

    Thanks!

  2. #2

    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,675
    Thank Post
    43
    Thanked 557 Times in 465 Posts
    Rep Power
    122
    You may need to force asp.net into en-GB mode: How to: Set the Culture and UI Culture for ASP.NET Web Page Globalization

  3. #3

    Join Date
    Oct 2011
    Posts
    11
    Thank Post
    1
    Thanked 1 Time in 1 Post
    Rep Power
    0
    Nick,

    Sorry for the long delay in getting back to you. We were on Holiday Break for 2 weeks, and today is our first day back. I went ahead and forced asp.net into en-GB by adding in the culture and ui-culture settings into the web.config file. That fixed the "String was not recognized as a valid DateTime."

    I was still getting the 405 Method Not Allowed error, but after some googling, I was able to find a fix. It seems that webdav publishing can cause some conflicts with the http verbs (PUT in this case). We had webdav publishing installed on the same server from when we were looking at another product that required webdav. I removed it and it worked. The tickets closed out fine. If anyone else runs into this, removing webdav fixed it for us.

    Thanks!

  4. #4

    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,675
    Thank Post
    43
    Thanked 557 Times in 465 Posts
    Rep Power
    122
    You should be able to get away with setting the webdav module for IIS to disabled for the HAP application, if you need webdav on the same server



SHARE:
+ Post New Thread

Similar Threads

  1. Help! Joomla Issues with Internet Explorer!
    By oalcock in forum Internet Related/Filtering/Firewall
    Replies: 0
    Last Post: 26th February 2012, 10:12 PM
  2. Replies: 19
    Last Post: 14th September 2011, 11:18 AM
  3. Having real issues with Trickle feed (CC4) on laptops? Will Wake on LAN help?
    By meadowgirl in forum Network and Classroom Management
    Replies: 1
    Last Post: 2nd February 2011, 11:24 AM
  4. Help Desk
    By kingswood in forum How do you do....it?
    Replies: 53
    Last Post: 16th March 2007, 10:43 AM
  5. Help desk and inventory
    By Dos_Box in forum Downloads
    Replies: 5
    Last Post: 22nd June 2006, 09:47 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •