+ Post New Thread
Results 1 to 3 of 3
Home Access Plus+ Thread, I must be stupid... in Projects:; Hello, I have probably set something somewhere which is stopping people (in the Staff & other OU's) from accessing the ...
  1. #1
    cmorgan's Avatar
    Join Date
    May 2012
    Location
    Torquay
    Posts
    42
    Thank Post
    4
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Angry I must be stupid...

    Hello,

    I have probably set something somewhere which is stopping people (in the Staff & other OU's) from accessing the booking system.

    In particular, one user.

    The contents of my Web.config in the BookingSystem directory is...
    Code:
    <?xml version="1.0"?>
    <configuration>
      <system.web>
        <authorization>
          <allow users="*" />
          <deny users="?" />
        </authorization>
      </system.web>
      <location path="Default.aspx">
        <system.web>
          <authorization>
            <allow roles="Domain Admins, Staff, Cheryl" />
            <deny users="*" />
          </authorization>
        </system.web>
      </location>
      <location path="New.aspx">
        <system.web>
          <authorization>
            <allow roles="Domain Admins, Staff, Cheryl" />
            <deny users="*" />
          </authorization>
        </system.web>
      </location>
    </configuration>
    The user that is having problems would come under the "Cheryl" group whereas I come under the "Domain Admins" group, so logically staff + cheryl should be able to access the page.

    As for what the OU's are set to...
    <OUs>
    <OU name="Technicians" path="LDAP://OU=IT Technicians,DC=dc,DC=local" visibility="Both" />
    <OU name="Staff" path="LDAP://OU=Staff,DC=dc,DC=local" visibility="BookingSystem" />
    <OU name="Cheryl" path="LDAP://OU=Our Cheryl,DC=dc,DC=local" visibility="BookingSystem" />
    </OUs>
    There has got to be something ive done wrong

    Running HAP+ Version 8.1.1.something
    Last edited by cmorgan; 26th November 2012 at 03:53 PM.

  2. #2
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,566
    Thank Post
    38
    Thanked 510 Times in 440 Posts
    Rep Power
    115
    Try using IIS manager to set the permissions.

    Also try

    <allow roles="Domain Admins" />
    <allow roles="Staff" />
    <allow users="Cheryl" />
    <deny users="*" />

    These need to be AD Groups, not AD Org Units

  3. #3
    cmorgan's Avatar
    Join Date
    May 2012
    Location
    Torquay
    Posts
    42
    Thank Post
    4
    Thanked 0 Times in 0 Posts
    Rep Power
    0


    Will update tomorrow with AD groups.

    Sorry for such a stupid problem

SHARE:
+ Post New Thread

Similar Threads

  1. Cookies must be enabled? Bah they are.....
    By Scotmk in forum Web Development
    Replies: 6
    Last Post: 19th October 2007, 02:49 PM
  2. Data Projector being stupid
    By e_g_r in forum Hardware
    Replies: 3
    Last Post: 19th October 2005, 03:27 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •