+ Post New Thread
Results 1 to 10 of 10
Home Access Plus+ Thread, Booking sheet, emails to admins? in Projects:; Unsure why this isn't working or if it's even intended to work the way I'm assuming, emails get sent to ...
  1. #1
    mrbios's Avatar
    Join Date
    Jun 2007
    Location
    Stroud, Gloucestershire
    Posts
    2,541
    Thank Post
    362
    Thanked 263 Times in 215 Posts
    Rep Power
    100

    Booking sheet, emails to admins?

    Unsure why this isn't working or if it's even intended to work the way I'm assuming, emails get sent to the user who submits a room booking correctly but admins don't receive any notification, any ideas of how to sort this? or if it's even an intended way of working?

    I know in the bookingtemplates there's a line for admin, and i'm in the booking sheet admin group so i guess i should be receiving them from that design?

  2. #2
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,561
    Thank Post
    38
    Thanked 507 Times in 437 Posts
    Rep Power
    114
    Have you enabled the email admins for each resource you want? And do the admins exist as the resource admin (note it wont email the booking system admins, only the resource admins)

  3. Thanks to nickbro from:

    mrbios (6th November 2012)

  4. #3
    mrbios's Avatar
    Join Date
    Jun 2007
    Location
    Stroud, Gloucestershire
    Posts
    2,541
    Thank Post
    362
    Thanked 263 Times in 215 Posts
    Rep Power
    100
    Quote Originally Posted by nickbro View Post
    Have you enabled the email admins for each resource you want? And do the admins exist as the resource admin (note it wont email the booking system admins, only the resource admins)
    Email Admins is ticked

    Additional admins is set to "inherit" do i need to change this to a specific group(s) then?

  5. #4
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,561
    Thank Post
    38
    Thanked 507 Times in 437 Posts
    Rep Power
    114
    I think so, I can't really remember

  6. Thanks to nickbro from:

    mrbios (6th November 2012)

  7. #5
    mrbios's Avatar
    Join Date
    Jun 2007
    Location
    Stroud, Gloucestershire
    Posts
    2,541
    Thank Post
    362
    Thanked 263 Times in 215 Posts
    Rep Power
    100
    Quote Originally Posted by nickbro View Post
    I think so, I can't really remember
    Tried both a username and a group name in the box rather than inherit but still didn't receive any emails

  8. #6
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,561
    Thank Post
    38
    Thanked 507 Times in 437 Posts
    Rep Power
    114
    Can you check your HAPConfig.xml file

    HTML Code:
     <resource name="Laptops" type="Laptops" admins="Nick" enabled="True" emailadmins="True" enablecharging="True" showto="All" hidefrom="" years="Inherit" quantities="15,29" readonlyto="" readwriteto="" multilessonto="None" />
          <resource name="S6" type="Room" admins="LizB, ChristineB" enabled="True" emailadmins="True" enablecharging="False" showto="All" hidefrom="" years="Inherit" quantities="" readonlyto="" readwriteto="LizB, AnitaB, AndrewM, LloydE, GeraintW, AnnaT" multilessonto="None" />
    I have 2 rooms where the admins are emailed.

  9. Thanks to nickbro from:

    mrbios (6th November 2012)

  10. #7
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,561
    Thank Post
    38
    Thanked 507 Times in 437 Posts
    Rep Power
    114
    Give this DLL a try, it contains some debug steps to track down why emails aren't being sent, you will need the web tracker enabled, an/or the Event Viewer for HAP+ working

  11. Thanks to nickbro from:

    mrbios (6th November 2012)

  12. #8
    mrbios's Avatar
    Join Date
    Jun 2007
    Location
    Stroud, Gloucestershire
    Posts
    2,541
    Thank Post
    362
    Thanked 263 Times in 215 Posts
    Rep Power
    100
    Thanks Nick, will test this tomorrow and let you know

  13. #9
    mrbios's Avatar
    Join Date
    Jun 2007
    Location
    Stroud, Gloucestershire
    Posts
    2,541
    Thank Post
    362
    Thanked 263 Times in 215 Posts
    Rep Power
    100
    Got it working now, didn't actually change anything from what i was doing last night though so i assume just adding the individual admins in and removing inherit did the trick, thanks Nick

  14. #10
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,561
    Thank Post
    38
    Thanked 507 Times in 437 Posts
    Rep Power
    114
    Yep that should fix it. Sometimes the cache doesn't clear very quickly. We use resource admins as you may not want some admins to get resource emails but have control of booking system

SHARE:
+ Post New Thread

Similar Threads

  1. HAP: User Access to Booking Sheet and Helpdesk problem
    By bclarke in forum Home Access Plus+
    Replies: 15
    Last Post: 9th February 2012, 02:57 PM
  2. Replies: 5
    Last Post: 28th February 2008, 04:57 PM
  3. Replies: 2
    Last Post: 10th October 2007, 07:57 AM
  4. Outlook 2007 sending emails to @local
    By Mintsoft in forum Windows
    Replies: 0
    Last Post: 7th July 2006, 11:52 AM
  5. Admin staff to 'admin' AD phonebook
    By ITWombat in forum MIS Systems
    Replies: 2
    Last Post: 31st May 2006, 10:08 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •