+ Post New Thread
Results 1 to 9 of 9
Home Access Plus+ Thread, Creating an intranet start page - getting Internal error pop ups in Projects:; Hi I have created a second instance of HAP on my server, it appears to work, and logs me in ...
  1. #1

    Join Date
    Apr 2012
    Posts
    417
    Thank Post
    39
    Thanked 35 Times in 28 Posts
    Rep Power
    15

    Creating an intranet start page - getting Internal error pop ups

    Hi

    I have created a second instance of HAP on my server, it appears to work, and logs me in automatically - which is what I wanted (Followed this thread:Quick question - HAP internal )

    However, I get 6 internal error pop ups - and this appears to be because of an error 500 on the file - all I did was copy and paste the working system into another folder...

    Anyways - here is the debug info:

    Code:
    <html>
        <head>
            <title>Security settings for this service require 'Anonymous' Authentication but it is not enabled for the IIS application that hosts this service.</title>
            <style>
             body {font-family:"Verdana";font-weight:normal;font-size: .7em;color:black;} 
             p {font-family:"Verdana";font-weight:normal;color:black;margin-top: -5px}
             b {font-family:"Verdana";font-weight:bold;color:black;margin-top: -5px}
             H1 { font-family:"Verdana";font-weight:normal;font-size:18pt;color:red }
             H2 { font-family:"Verdana";font-weight:normal;font-size:14pt;color:maroon }
             pre {font-family:"Lucida Console";font-size: .9em}
             .marker {font-weight: bold; color: black;text-decoration: none;}
             .version {color: gray;}
             .error {margin-bottom: 10px;}
             .expandable { text-decoration:underline; font-weight:bold; color:navy; cursor:hand; }
            </style>
        </head>
    
        <body bgcolor="white">
    
                <span><H1>Server Error in '/hapinternal' Application.<hr width=100% size=1 color=silver></H1>
    
                <h2> <i>Security settings for this service require 'Anonymous' Authentication but it is not enabled for the IIS application that hosts this service.</i> </h2></span>
    
                <font face="Arial, Helvetica, Geneva, SunSans-Regular, sans-serif ">
    
                <b> Description: </b>An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.
    
                <br><br>
    
                <b> Exception Details: </b>System.NotSupportedException: Security settings for this service require 'Anonymous' Authentication but it is not enabled for the IIS application that hosts this service.<br><br>
    
                <b>Source Error:</b> <br><br>
    
                <table width=100% bgcolor="#ffffcc">
                   <tr>
                      <td>
                          <code>
    
    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.</code>
    
                      </td>
                   </tr>
                </table>
    
                <br>
    
                <b>Stack Trace:</b> <br><br>
    
                <table width=100% bgcolor="#ffffcc">
                   <tr>
                      <td>
                          <code><pre>
    
    [NotSupportedException: Security settings for this service require &#39;Anonymous&#39; Authentication but it is not enabled for the IIS application that hosts this service.]
       System.ServiceModel.Activation.HostedAspNetEnvironment.ValidateHttpSettings(String virtualPath, Boolean isMetadataListener, Boolean usingDefaultSpnList, AuthenticationSchemes&amp; supportedSchemes, ExtendedProtectionPolicy&amp; extendedProtectionPolicy, String&amp; realm) +198300
       System.ServiceModel.Channels.HttpChannelListener.ApplyHostedContext(String virtualPath, Boolean isMetadataListener) +104
       System.ServiceModel.Channels.HttpsChannelListener.ApplyHostedContext(String virtualPath, Boolean isMetadataListener) +39
       System.ServiceModel.Channels.HttpsTransportBindingElement.BuildChannelListener(BindingContext context) +123
       System.ServiceModel.Channels.Binding.BuildChannelListener(Uri listenUriBaseAddress, String listenUriRelativeAddress, ListenUriMode listenUriMode, BindingParameterCollection parameters) +166
       System.ServiceModel.Description.DispatcherBuilder.MaybeCreateListener(Boolean actuallyCreate, Type[] supportedChannels, Binding binding, BindingParameterCollection parameters, Uri listenUriBaseAddress, String listenUriRelativeAddress, ListenUriMode listenUriMode, ServiceThrottle throttle, IChannelListener&amp; result, Boolean supportContextSession) +393
       System.ServiceModel.Description.DispatcherBuilder.BuildChannelListener(StuffPerListenUriInfo stuff, ServiceHostBase serviceHost, Uri listenUri, ListenUriMode listenUriMode, Boolean supportContextSession, IChannelListener&amp; result) +583
       System.ServiceModel.Description.DispatcherBuilder.InitializeServiceHost(ServiceDescription description, ServiceHostBase serviceHost) +2020
       System.ServiceModel.ServiceHostBase.InitializeRuntime() +82
       System.ServiceModel.ServiceHostBase.OnOpen(TimeSpan timeout) +64
       System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout) +789
       System.ServiceModel.HostingManager.ActivateService(String normalizedVirtualPath) +255
       System.ServiceModel.HostingManager.EnsureServiceAvailable(String normalizedVirtualPath) +1172
    
    [ServiceActivationException: The service &#39;/hapinternal/api/livetiles&#39; cannot be activated due to an exception during compilation.  The exception message is: Security settings for this service require &#39;Anonymous&#39; Authentication but it is not enabled for the IIS application that hosts this service..]
       System.Runtime.AsyncResult.End(IAsyncResult result) +901424
       System.ServiceModel.Activation.HostedHttpRequestAsyncResult.End(IAsyncResult result) +178702
       System.Web.CallHandlerExecutionStep.OnAsyncHandlerCompletion(IAsyncResult ar) +136
    </pre></code>
    
                      </td>
                   </tr>
                </table>
    
                <br>
    
                <hr width=100% size=1 color=silver>
    
                <b>Version Information:</b>&nbsp;Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.0.30319.272
    
                </font>
    
        </body>
    </html>
    <!-- 
    [NotSupportedException]: Security settings for this service require &#39;Anonymous&#39; Authentication but it is not enabled for the IIS application that hosts this service.
       at System.ServiceModel.Activation.HostedAspNetEnvironment.ValidateHttpSettings(String virtualPath, Boolean isMetadataListener, Boolean usingDefaultSpnList, AuthenticationSchemes& supportedSchemes, ExtendedProtectionPolicy& extendedProtectionPolicy, String& realm)
       at System.ServiceModel.Channels.HttpChannelListener.ApplyHostedContext(String virtualPath, Boolean isMetadataListener)
       at System.ServiceModel.Channels.HttpsChannelListener.ApplyHostedContext(String virtualPath, Boolean isMetadataListener)
       at System.ServiceModel.Channels.HttpsTransportBindingElement.BuildChannelListener[TChannel](BindingContext context)
       at System.ServiceModel.Channels.Binding.BuildChannelListener[TChannel](Uri listenUriBaseAddress, String listenUriRelativeAddress, ListenUriMode listenUriMode, BindingParameterCollection parameters)
       at System.ServiceModel.Description.DispatcherBuilder.MaybeCreateListener(Boolean actuallyCreate, Type[] supportedChannels, Binding binding, BindingParameterCollection parameters, Uri listenUriBaseAddress, String listenUriRelativeAddress, ListenUriMode listenUriMode, ServiceThrottle throttle, IChannelListener& result, Boolean supportContextSession)
       at System.ServiceModel.Description.DispatcherBuilder.BuildChannelListener(StuffPerListenUriInfo stuff, ServiceHostBase serviceHost, Uri listenUri, ListenUriMode listenUriMode, Boolean supportContextSession, IChannelListener& result)
       at System.ServiceModel.Description.DispatcherBuilder.InitializeServiceHost(ServiceDescription description, ServiceHostBase serviceHost)
       at System.ServiceModel.ServiceHostBase.InitializeRuntime()
       at System.ServiceModel.ServiceHostBase.OnOpen(TimeSpan timeout)
       at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout)
       at System.ServiceModel.ServiceHostingEnvironment.HostingManager.ActivateService(String normalizedVirtualPath)
       at System.ServiceModel.ServiceHostingEnvironment.HostingManager.EnsureServiceAvailable(String normalizedVirtualPath)
    [ServiceActivationException]: The service &#39;/hapinternal/api/livetiles&#39; cannot be activated due to an exception during compilation.  The exception message is: Security settings for this service require &#39;Anonymous&#39; Authentication but it is not enabled for the IIS application that hosts this service..
       at System.Runtime.AsyncResult.End[TAsyncResult](IAsyncResult result)
       at System.ServiceModel.Activation.HostedHttpRequestAsyncResult.End(IAsyncResult result)
       at System.Web.HttpApplication.CallHandlerExecutionStep.OnAsyncHandlerCompletion(IAsyncResult ar)
    --><!-- 
    This error page might contain sensitive information because ASP.NET is configured to show verbose error messages using &lt;customErrors mode="Off"/&gt;. Consider using &lt;customErrors mode="On"/&gt; or &lt;customErrors mode="RemoteOnly"/&gt; in production environments.-->
    And this is a picture of where the 6 errors show up:

    Creating an intranet start page - getting Internal error pop ups-haperror3.png

    When I press OK on the errors, the page appears fine - but none of the live tileness works....

    Any ideas?

  2. #2
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,561
    Thank Post
    38
    Thanked 507 Times in 437 Posts
    Rep Power
    114
    The error message give you a clue at what is wrong. Also make sure you are using https


    Security settings for this service require 'Anonymous' Authentication but it is not enabled for the IIS application that hosts this service.

  3. #3

    Join Date
    Apr 2012
    Posts
    417
    Thank Post
    39
    Thanked 35 Times in 28 Posts
    Rep Power
    15
    But for Windows auth you said to ensure all others were disabled?

    Its working fine on http for the bits Im doing it seems - as otherwise it will route through the SSL on the external domain and not windows auth which defeats the whole point again

  4. #4
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,561
    Thank Post
    38
    Thanked 507 Times in 437 Posts
    Rep Power
    114
    HAP+ uses https though, the services that are failing need https to encrypt traffic

  5. #5

    Join Date
    Apr 2012
    Posts
    417
    Thank Post
    39
    Thanked 35 Times in 28 Posts
    Rep Power
    15
    Seems what I wanted to do is not really possible then any chance of releasing the style in a pure XHTML/CSS style? I know I wouldn't ave the live tiles but at least styling would be consistent. Can't believe no one else has asked for tis?!

  6. #6
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,561
    Thank Post
    38
    Thanked 507 Times in 437 Posts
    Rep Power
    114
    Have a look at the basestyle.css file. You should be able to use the developer tools in IE/Firefox to actually copy the HTML that's generated for the live tile interface and combine it with the CSS. Animations are done through jquery, which is in the hap.js file in scripts

  7. #7

    Join Date
    Apr 2012
    Posts
    417
    Thank Post
    39
    Thanked 35 Times in 28 Posts
    Rep Power
    15
    Thanks Nick. Possible future feature? - as I do think having this info on your intranet start page (unread emails/calendars) and easy access to booking system would be fab. I know it's home access plus... But I always think a consistent system is best...!

  8. #8

    Join Date
    Apr 2012
    Posts
    417
    Thank Post
    39
    Thanked 35 Times in 28 Posts
    Rep Power
    15
    Can I assign another cert to the hap internal instance? Or - if it not being on https is causing this - what if I moved it to another server?

  9. #9
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,561
    Thank Post
    38
    Thanked 507 Times in 437 Posts
    Rep Power
    114
    Try and see, HAP+ needs https to work

SHARE:
+ Post New Thread

Similar Threads

  1. Why an I getting this error?
    By Jobos in forum East Midlands Broadband Consortium (EMBC)
    Replies: 4
    Last Post: 10th December 2010, 11:37 AM
  2. Replies: 0
    Last Post: 20th November 2009, 12:35 PM
  3. How to make an intranet front page on OSX
    By GenieNitro in forum How do you do....it?
    Replies: 1
    Last Post: 27th June 2009, 05:01 PM
  4. Pricing an Intranet server
    By u8dmtm in forum Hardware
    Replies: 20
    Last Post: 9th February 2006, 10:19 AM
  5. Changing the start page
    By Dos_Box in forum General EduGeek News/Announcements
    Replies: 2
    Last Post: 4th October 2005, 05:25 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •