+ Post New Thread
Results 1 to 9 of 9
Home Access Plus+ Thread, remote apps not working in Projects:; I have added a folder "rdweb" and added my remote app rdp files, I have tested my remote apps and ...
  1. #1
    edie209's Avatar
    Join Date
    Mar 2006
    Location
    Kernow
    Posts
    671
    Thank Post
    41
    Thanked 16 Times in 15 Posts
    Rep Power
    20

    remote apps not working

    I have added a folder "rdweb" and added my remote app rdp files, I have tested my remote apps and they work outside of HAP. However when I click on the remote apps link I get

    Code:
    403 - Forbidden: Access is denied.You do not have permission to view this directory or page using the credentials that you supplied.

    Here are the parts of my config file that I have changed


    Code:
    <Links>
          <Group name="Resources" showto="All" subtitle="">
            <Link name="Me" showto="Inherit" description="About Me and Change My Password" url="#me" icon="~/images/icons/metro/folders-os/UserNo-Frame.png" target="" type="me" />
            <Link name="My Files" showto="Inherit" description="Access your School My Files" url="~/myfiles/" icon="~/images/icons/metro/folders-os/DocumentsFolder.png" target="" type="myfiles" />
            <Link name="Remote Apps" showto="Inherit" description="Run School Applications at Home via School" url="~/rdweb/" icon="~/images/icons/metro/applications/remotedesktop.png" target="" type="remapps"/>
            <Link name="Emails" showto="Inherit" description="Access Outlook Web App" url="https://mail.school.uk/owa/" icon="~/images/icons/metro/Office-15/outlook.png" target="" type="exchange.unread" />
            <Link name="Calendar" showto="Inherit" description="My Calendar" url="https://mail.school.uk/owa/" icon="~/images/icons/metro/applications/calendar.png" target="" type="exchange.appointments" />
          </Group>




    Code:
    <Group name="remapps" showto="All" subtitle="">
            <Link name="Sims.Net" showto="Inherit" description="Sims.net" url="~/rdweb/simsload.rdp" icon="~/images/icons/metro/Other/shortcuts.png" target="" />
            <Link name="Microsoft Word" showto="Inherit" description="Microsoft Word 2010" url="~/rdweb/word.rdp" icon="~/images/icons/metro/Office-15/word.png" target="" />
            <Link name="Microsoft Excel" showto="Inherit" description="Microsoft Excel 2010" url="~/rdweb/excel.rdp" icon="~/images/icons/metro/Office-15/excel.png" target="" />
            <Link name="Microsoft Access" showto="Inherit" description="Microsoft Access 2010" url="~/rdweb/msaccess.rdp" icon="~/images/icons/metro/Office-15/access.png" target="" />
    	<Link name="Microsoft Publisher" showto="Inherit" description="Microsoft Publisher 2010" url="~/rdweb/mspub.rdp" icon="~/images/icons/metro/Office-15/publisher.png" target="" />
    	<Link name="Microsoft Powerpoint" showto="Inherit" description="Microsoft Powerpoint 2010" url="~/rdweb/powerpoint.rdp" icon="~/images/icons/metro/Office-15/powerpoint.png" target="" />
    	<Link name="Surelab EngraveLab" showto="Inherit" description="Surelab EngraveLab 8" url="~/rdweb/cadlink.rdp" icon="~/images/icons/metro/other/shortcuts.png" target="" />
          </Group>

  2. #2
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,474
    Thank Post
    37
    Thanked 483 Times in 415 Posts
    Rep Power
    109
    You may need to add the MIME type to IIS so it knows to handle rdp files

  3. #3
    edie209's Avatar
    Join Date
    Mar 2006
    Location
    Kernow
    Posts
    671
    Thank Post
    41
    Thanked 16 Times in 15 Posts
    Rep Power
    20
    Hi Nick I have done that I found a post quite a way back that you mentioned to do that.

    extension .rdp
    MIME type application/rdp
    entry type Local

  4. #4
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,474
    Thank Post
    37
    Thanked 483 Times in 415 Posts
    Rep Power
    109
    Ok, did you put the rdp files into a folder called rdweb inside the HAP folder or is it in the rdweb folder at the root of the server. If the latter you need to use /rdweb/ instead of ~/rdweb/

    ~/ stands for application root, e.g. /hap/

  5. #5
    edie209's Avatar
    Join Date
    Mar 2006
    Location
    Kernow
    Posts
    671
    Thank Post
    41
    Thanked 16 Times in 15 Posts
    Rep Power
    20
    the rdweb folder is at the root of the HAP structure.
    I have managed to move a little forward (I think) I now get a "save as" box when I click on the word link.

  6. #6
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,474
    Thank Post
    37
    Thanked 483 Times in 415 Posts
    Rep Power
    109
    That's a positive step, that's what it should do, if you do open it should then start to launch the rdp connection.

  7. #7
    edie209's Avatar
    Join Date
    Mar 2006
    Location
    Kernow
    Posts
    671
    Thank Post
    41
    Thanked 16 Times in 15 Posts
    Rep Power
    20
    This is what happens when I click on the RDP link. Is this the way it works? you have to save the rdp shortcut? you can't click on a link on the site and open the ap that way.



    remote apps not working-untitled.jpg

  8. #8
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,474
    Thank Post
    37
    Thanked 483 Times in 415 Posts
    Rep Power
    109
    You need to encode your RDP gateway into the RDP files, so that it connects via the RDP Gateway

  9. #9
    edie209's Avatar
    Join Date
    Mar 2006
    Location
    Kernow
    Posts
    671
    Thank Post
    41
    Thanked 16 Times in 15 Posts
    Rep Power
    20
    ok thanks I will look into that tomorrow

SHARE:
+ Post New Thread

Similar Threads

  1. Network not working
    By witch in forum Wireless Networks
    Replies: 21
    Last Post: 1st March 2006, 11:58 AM
  2. why your internet is not working
    By russdev in forum Jokes/Interweb Things
    Replies: 0
    Last Post: 22nd February 2006, 07:18 PM
  3. Redirecting "My Documents" Not Working!
    By secman in forum Windows
    Replies: 7
    Last Post: 14th February 2006, 11:56 AM
  4. Forces and Motion not working.
    By altecsole in forum Educational Software
    Replies: 5
    Last Post: 13th December 2005, 08:48 PM
  5. Permissions not working
    By mark in forum Windows
    Replies: 5
    Last Post: 19th October 2005, 12:21 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •