+ Post New Thread
Results 1 to 3 of 3
Home Access Plus+ Thread, V8 Installation in Projects:; Hi Nick, I've just installed V8 as per your instructions of just leaving the APPDATA folder and deleting and replacing ...
  1. #1
    linkazoid's Avatar
    Join Date
    May 2007
    Location
    London
    Posts
    649
    Thank Post
    119
    Thanked 90 Times in 74 Posts
    Rep Power
    78

    V8 Installation

    Hi Nick,

    I've just installed V8 as per your instructions of just leaving the APPDATA folder and deleting and replacing all the other files.

    I can see the login screen but when I enter a username and password I get the following message:

    Code:
    Server Error in '/HAPBETA' Application.
    
    Parameter is not valid.
    
    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code. 
    
    Exception Details: System.ArgumentException: Parameter is not valid.
    
    Source Error: 
    
    
    Line 32:                                             $(document).ready(function () {
    Line 33:                                                 hap.livetiles.Init([
    Line 34:                                                 <%#gettiles((HAP.Web.Configuration.LinkGroup)Container.DataItem)%>
    Line 35:                                                 ]);
    Line 36:                                             });
    
    Source File: c:\inetpub\wwwroot\HAPBETA\Default.aspx    Line: 34 
    
    Stack Trace: 
    
    
    [ArgumentException: Parameter is not valid.]
       System.Drawing.Bitmap..ctor(String filename) +751215
       HAP.Web.LiveTiles.IconCache.GetColour(String icon) +1268
    
    [Exception: ~/images/icons/bookingsystem.png]
       HAP.Web.LiveTiles.IconCache.GetColour(String icon) +2607
       HAP.Web.Default.gettiles(Object o) +1066
       ASP.default_aspx.__DataBind__control9(Object sender, EventArgs e) in c:\inetpub\wwwroot\HAPBETA\Default.aspx:34
       System.Web.UI.Control.DataBind(Boolean raiseOnDataBinding) +304
       System.Web.UI.Control.DataBindChildren() +11426535
       System.Web.UI.Control.DataBind(Boolean raiseOnDataBinding) +321
       System.Web.UI.WebControls.Repeater.CreateItem(Int32 itemIndex, ListItemType itemType, Boolean dataBind, Object dataItem) +185
       System.Web.UI.WebControls.Repeater.CreateControlHierarchy(Boolean useDataSource) +627
       System.Web.UI.WebControls.Repeater.OnDataBinding(EventArgs e) +167
       HAP.Web.Default.Page_Load(Object sender, EventArgs e) +723
       System.Web.Util.CalliHelper.EventArgFunctionCaller(IntPtr fp, Object o, Object t, EventArgs e) +25
       System.Web.UI.Control.LoadRecursive() +71
       System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +3064
    
    Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.0.30319.272
    This is from the JSON Debug

    Code:
                <b> Source File: </b> c:\inetpub\wwwroot\HAPBETA\Default.aspx<b> &nbsp;&nbsp; Line: </b> 34
                <br><br>
    
                <b>Stack Trace:</b> <br><br>
    
                <table width=100% bgcolor="#ffffcc">
                   <tr>
                      <td>
                          <code><pre>
    
    [ArgumentException: Parameter is not valid.]
       System.Drawing.Bitmap..ctor(String filename) +751215
       HAP.Web.LiveTiles.IconCache.GetColour(String icon) +1268
    
    [Exception: ~/images/icons/bookingsystem.png]
       HAP.Web.LiveTiles.IconCache.GetColour(String icon) +2607
       HAP.Web.Default.gettiles(Object o) +1066
       ASP.default_aspx.__DataBind__control9(Object sender, EventArgs e) in c:\inetpub\wwwroot\HAPBETA\Default.aspx:34
       System.Web.UI.Control.DataBind(Boolean raiseOnDataBinding) +304
       System.Web.UI.Control.DataBindChildren() +11426535
       System.Web.UI.Control.DataBind(Boolean raiseOnDataBinding) +321
       System.Web.UI.WebControls.Repeater.CreateItem(Int32 itemIndex, ListItemType itemType, Boolean dataBind, Object dataItem) +185
       System.Web.UI.WebControls.Repeater.CreateControlHierarchy(Boolean useDataSource) +627
       System.Web.UI.WebControls.Repeater.OnDataBinding(EventArgs e) +167
       HAP.Web.Default.Page_Load(Object sender, EventArgs e) +723
       System.Web.Util.CalliHelper.EventArgFunctionCaller(IntPtr fp, Object o, Object t, EventArgs e) +25
       System.Web.UI.Control.LoadRecursive() +71
       System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +3064
    </pre></code>
    
                      </td>
                   </tr>
                </table>
    
                <br>
    
                <hr width=100% size=1 color=silver>
    
                <b>Version Information:</b>&nbsp;Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.0.30319.272
    
                </font>
    
        </body>
    </html>
    <!-- 
    [ArgumentException]: Parameter is not valid.
       at System.Drawing.Bitmap..ctor(String filename)
       at HAP.Web.LiveTiles.IconCache.GetColour(String icon)
    [Exception]: ~/images/icons/bookingsystem.png
       at HAP.Web.LiveTiles.IconCache.GetColour(String icon)
       at HAP.Web.Default.gettiles(Object o)
       at ASP.default_aspx.__DataBind__control9(Object sender, EventArgs e) in c:\inetpub\wwwroot\HAPBETA\Default.aspx:line 34
       at System.Web.UI.Control.DataBind(Boolean raiseOnDataBinding)
       at System.Web.UI.Control.DataBindChildren()
       at System.Web.UI.Control.DataBind(Boolean raiseOnDataBinding)
       at System.Web.UI.WebControls.Repeater.CreateItem(Int32 itemIndex, ListItemType itemType, Boolean dataBind, Object dataItem)
       at System.Web.UI.WebControls.Repeater.CreateControlHierarchy(Boolean useDataSource)
       at System.Web.UI.WebControls.Repeater.OnDataBinding(EventArgs e)
       at HAP.Web.Default.Page_Load(Object sender, EventArgs e)
       at System.Web.Util.CalliHelper.EventArgFunctionCaller(IntPtr fp, Object o, Object t, EventArgs e)
       at System.Web.UI.Control.LoadRecursive()
       at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
    [HttpUnhandledException]: Exception of type &#39;System.Web.HttpUnhandledException&#39; was thrown.
       at System.Web.UI.Page.HandleError(Exception e)
       at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
       at System.Web.UI.Page.ProcessRequest(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
       at System.Web.UI.Page.ProcessRequest()
       at System.Web.UI.Page.ProcessRequest(HttpContext context)
       at ASP.default_aspx.ProcessRequest(HttpContext context) in c:\Windows\Microsoft.NET\Framework64\v4.0.30319\Temporary ASP.NET Files\hapbeta\a7b1b7b7\36c58cd3\App_Web_0ek4p1sp.1.cs:line 0
       at System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
       at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)
    --><!-- 
    This error page might contain sensitive information because ASP.NET is configured to show verbose error messages using &lt;customErrors mode="Off"/&gt;. Consider using &lt;customErrors mode="On"/&gt; or &lt;customErrors mode="RemoteOnly"/&gt; in production environments.-->
    Any idea why it's not working?

    Thanks

    Michael

  2. #2
    linkazoid's Avatar
    Join Date
    May 2007
    Location
    London
    Posts
    649
    Thank Post
    119
    Thanked 90 Times in 74 Posts
    Rep Power
    78
    Fixed it... Seems I may have missed a custom icon from the old icon folder.

  3. #3
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,561
    Thank Post
    38
    Thanked 507 Times in 437 Posts
    Rep Power
    114
    Good to hear, was about to say it's complaining about an icon

SHARE:
+ Post New Thread

Similar Threads

  1. HAP V8 Install A WCF Error occured
    By TechieWils in forum Home Access Plus+
    Replies: 1
    Last Post: 30th August 2012, 01:27 PM
  2. Remote Installation Services (RIS)
    By Dos_Box in forum How do you do....it?
    Replies: 140
    Last Post: 29th June 2010, 06:27 PM
  3. Projector Installation/ source for parts
    By mark in forum Hardware
    Replies: 23
    Last Post: 20th September 2005, 10:41 PM
  4. Replies: 17
    Last Post: 16th September 2005, 08:07 AM
  5. ..Install software?
    By kingswood in forum How do you do....it?
    Replies: 21
    Last Post: 4th August 2005, 04:00 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •