+ Post New Thread
Results 1 to 9 of 9
Home Access Plus+ Thread, Unable to rename file in version 8 in Projects:; Running version 8 (HAP+ Web v8.0828.1800). When trying to "rename a file" (right-click), HAP hung on the message "checking" and ...
  1. #1

    Join Date
    Jul 2012
    Location
    Melbourne
    Posts
    57
    Thank Post
    11
    Thanked 1 Time in 1 Post
    Rep Power
    0

    Unable to rename file in version 8

    Running version 8 (HAP+ Web v8.0828.1800). When trying to "rename a file" (right-click), HAP hung on the message "checking" and the message "The given key was not present in the dictionary" was displayed in the top left corner of the screen

    MyFiles hung at this point, even when I closed the "checking" box. I had to terminate the window it was running in.

    Browser is Firefox 13.0.1 and OS in Win XP SP3 (if that helps)

    Thanks

  2. #2

    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,678
    Thank Post
    43
    Thanked 557 Times in 465 Posts
    Rep Power
    122
    Can you make sure that the drive letters in your hapConfig.xml are in uppercase

  3. #3

    Join Date
    Jul 2012
    Location
    Melbourne
    Posts
    57
    Thank Post
    11
    Thanked 1 Time in 1 Post
    Rep Power
    0
    Thanks for your reply. I have checked and all drive mappings are in upper case. Here's an example:

    <mapping drive="I" name="Himage Installs" enablereadto="Domain Admins" enablewriteto="Domain Admins" enablemove="True" usagemode="DriveSpace">\\himage\installs</mapping>

    And here's a screenshot of what I get

    Unable to rename file in version 8-attempt_to_rename_file.png

    Thanks

  4. #4

    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,678
    Thank Post
    43
    Thanked 557 Times in 465 Posts
    Rep Power
    122
    Ok, hmm, odd.

    Can you use firebug to find out what the post request to check is doing?

  5. #5

    Join Date
    Jul 2012
    Location
    Melbourne
    Posts
    57
    Thank Post
    11
    Thanked 1 Time in 1 Post
    Rep Power
    0

    I hope this is what you were asking for

    G'day

    Installed Firebug and captured the HTML code in the attached text file. I'm not familiar with the package so please let me know if I've got the wrong information for you.

    BTW Also tried on Safari v5.1.7 with same result

    Thanks
    Attached Files Attached Files

  6. #6

    Join Date
    Jul 2012
    Location
    Melbourne
    Posts
    57
    Thank Post
    11
    Thanked 1 Time in 1 Post
    Rep Power
    0
    Or perhaps this is what you were looking for. Apologies if I've got it wrong. I got this from HAP+ JSON Debugging

    Thanks

    https://hap.stkevins.vic.edu.au/hap/...:39:16.915Z%22

    XML Tab

    XML Parsing Error: not well-formed Location: moz-nullprincipal:{a4cf6032-8349-4d5c-bd52-c52a1d112a03} Line Number 1, Column 1:

    {"Message":"The given key was not present in the dictionary.","Detail":null,"Fau...
    ^

    {"Message":"The given key was not present in the dictionary.","Detail":null,"FaultType":"KeyNotFoun dException"}

    js (line 1)

    {"Message":"The given key was not present in the dictionary.","Detail":null,"FaultType":"KeyNotFoun dException"}

    JSON Tab

    Message


    "The given key was not present in the dictionary."


    Detail


    null


    FaultType


    "KeyNotFoundException"


    https://hap.stkevins.vic.edu.au/hap/...:39:16.935Z%22


    XML Tab

    XML Parsing Error: not well-formed Location: moz-nullprincipal:{f3bc5274-18d0-439f-895a-b72e94ac0684} Line Number 1, Column 1:

    {"Message":"The given key was not present in the dictionary.","Detail":null,"Fau...
    ^

    {"Message":"The given key was not present in the dictionary.","Detail":null,"FaultType":"KeyNotFoun dException"}

    js (line 1)

    {"Message":"The given key was not present in the dictionary.","Detail":null,"FaultType":"KeyNotFoun dException"}

    js (line 1

    JSON Tab

    XML Parsing Error: not well-formed Location: moz-nullprincipal:{f3bc5274-18d0-439f-895a-b72e94ac0684} Line Number 1, Column 1:

    {"Message":"The given key was not present in the dictionary.","Detail":null,"Fau...
    ^

    {"Message":"The given key was not present in the dictionary.","Detail":null,"FaultType":"KeyNotFoun dException"}

    js (line 1)

    {"Message":"The given key was not present in the dictionary.","Detail":null,"FaultType":"KeyNotFoun dException"}

    js (line 1)

  7. #7

    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,678
    Thank Post
    43
    Thanked 557 Times in 465 Posts
    Rep Power
    122
    I'm more after what's on the post tab

  8. #8

    Join Date
    Jul 2012
    Location
    Melbourne
    Posts
    57
    Thank Post
    11
    Thanked 1 Time in 1 Post
    Rep Power
    0
    I'm sorry - I'm not familiar with Firebug or how to get the information that you are after. I couldn't find a tab called "Post". Here are two screen shots of what tab options were displayed. It would be appreciated if you could direct me to the right spot

    Thanks

    Unable to rename file in version 8-list_of_tabs.pngUnable to rename file in version 8-list_of_tabs-2-.png

  9. #9

    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,678
    Thank Post
    43
    Thanked 557 Times in 465 Posts
    Rep Power
    122
    Should be fixed in v8.0.0901.1830. To upgrade replace ~/myfiles/default.aspx with the one in the release.

    Home Access Plus+ - Download: v8.0

  10. Thanks to nickbro from:

    peterdwyer (2nd September 2012)



SHARE:
+ Post New Thread

Similar Threads

  1. [MS Office - 2007] in excel 2007, unable to find printer in drop down list
    By Blakeman321 in forum Office Software
    Replies: 2
    Last Post: 7th June 2012, 12:13 PM
  2. [MS Office - 2003] Outlook unable to send files
    By nephilim in forum Office Software
    Replies: 6
    Last Post: 12th December 2008, 12:55 PM
  3. Users unable to add favorites in IE7
    By jamin100 in forum Windows
    Replies: 9
    Last Post: 21st April 2008, 09:29 AM
  4. unable to set wallpaper in vista following virus
    By marky2027 in forum Windows Vista
    Replies: 16
    Last Post: 13th November 2007, 09:57 AM
  5. Replies: 3
    Last Post: 25th September 2006, 01:27 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •