+ Post New Thread
Results 1 to 11 of 11
Hardware Thread, epson c900 in Technical; Epson c900n developed an odd printing problem yesterday - prints fine in mono but anything in colour seems to out ...
  1. #1
    chrbb's Avatar
    Join Date
    Oct 2005
    Location
    Midlands
    Posts
    1,506
    Thank Post
    141
    Thanked 66 Times in 61 Posts
    Rep Power
    46

    epson c900

    Epson c900n developed an odd printing problem yesterday - prints fine in mono but anything in colour seems to out of alignment - sort of double vision. I can't find anything on epson's website re maintenance. I changed all the toners. Am I missing something really obvious?

  2. #2
    contink's Avatar
    Join Date
    Jul 2006
    Location
    South Yorkshire
    Posts
    3,791
    Thank Post
    303
    Thanked 327 Times in 233 Posts
    Rep Power
    118

    Re: epson c900

    Can you run an alignment tool with that printer?

    if not I'd hazzard a guess at something like the fuser, etc.. being a problem or something that results in one or more of the colours being out of whack.

  3. #3
    acrobson's Avatar
    Join Date
    May 2007
    Location
    Tyne & Wear
    Posts
    519
    Thank Post
    5
    Thanked 6 Times in 6 Posts
    Rep Power
    17

    Re: epson c900

    Quote Originally Posted by contink
    Can you run an alignment tool with that printer?

    if not I'd hazzard a guess at something like the fuser, etc.. being a problem or something that results in one or more of the colours being out of whack.
    I agree, check the fuser units and photo conductor units.

  4. #4
    chrbb's Avatar
    Join Date
    Oct 2005
    Location
    Midlands
    Posts
    1,506
    Thank Post
    141
    Thanked 66 Times in 61 Posts
    Rep Power
    46

    Re: epson c900

    I took the photoconductor unit out but we didn't have a spare so I just pushed it back in and made sure it was secure. I'd check the fuser unit if I knew where it was!

  5. #5
    acrobson's Avatar
    Join Date
    May 2007
    Location
    Tyne & Wear
    Posts
    519
    Thank Post
    5
    Thanked 6 Times in 6 Posts
    Rep Power
    17

    Re: epson c900

    Quote Originally Posted by chrbb
    I took the photoconductor unit out but we didn't have a spare so I just pushed it back in and made sure it was secure. I'd check the fuser unit if I knew where it was!
    The fuser units are usuall at the rear of the printers.

    Check out these links, hope it helps:

    http://esupport.epson-europe.com/V31...xeKSoCPW7ezHXR

    http://www.epson.co.uk/supplies/supp...erSupplies.pdf

  6. #6

    Geoff's Avatar
    Join Date
    Jun 2005
    Location
    Fylde, Lancs, UK.
    Posts
    11,802
    Thank Post
    110
    Thanked 583 Times in 504 Posts
    Blog Entries
    1
    Rep Power
    224

    Re: epson c900

    Some printers don't separate have fusers. I think the c900 is one of them.

  7. #7
    acrobson's Avatar
    Join Date
    May 2007
    Location
    Tyne & Wear
    Posts
    519
    Thank Post
    5
    Thanked 6 Times in 6 Posts
    Rep Power
    17

    Re: epson c900

    Quote Originally Posted by Geoff
    Some printers dont have fusers. I think the c900 is one of them.
    Fair enough, It was just advice.

  8. #8
    chrbb's Avatar
    Join Date
    Oct 2005
    Location
    Midlands
    Posts
    1,506
    Thank Post
    141
    Thanked 66 Times in 61 Posts
    Rep Power
    46

    Re: epson c900

    Thanks I've studied the epson link and looked at the maintenance bit, it might be worth me taking out the photoconductor unit etc and making sure there's no forgein bodies on it I suppose.

    Might be time for the school to get a replacement printer and keep this one for mono printing only.

  9. #9

    john's Avatar
    Join Date
    Sep 2005
    Location
    London
    Posts
    10,498
    Thank Post
    1,488
    Thanked 1,049 Times in 918 Posts
    Rep Power
    301

    Re: epson c900

    Have you tried phoning Epson Support? I normally avoid phoning HP RE printers as I get the usual is it HP ink, paper etc so I just say yeah it sure is all the time but they can be useful.

  10. #10
    chrbb's Avatar
    Join Date
    Oct 2005
    Location
    Midlands
    Posts
    1,506
    Thank Post
    141
    Thanked 66 Times in 61 Posts
    Rep Power
    46

    Re: epson c900

    I used the epson chat to an expert!
    The response when i had sent back a scanned image of a printout was that the transfer belt timing was causing a problem and would need replacing at a cost of approx £200.
    so Mon I will take out all moving bits, blow on them and put them back in - then advise the head that we may need a new printer and to keep this one for mono printing as that doesn't seem to be affected!

  11. #11

    john's Avatar
    Join Date
    Sep 2005
    Location
    London
    Posts
    10,498
    Thank Post
    1,488
    Thanked 1,049 Times in 918 Posts
    Rep Power
    301

    Re: epson c900

    That sounds perfectly logical, its a slippage of something if the colours are not lining up as they go on in 4 layers (C,M,Y,K) so yup hence why black is ok, or any 1 colour is fine, its just not layering them up right.

SHARE:
+ Post New Thread

Similar Threads

  1. Epson EMP - 74 Fails to pick up PC
    By speckytecky in forum Hardware
    Replies: 1
    Last Post: 17th September 2007, 12:54 PM
  2. Epson Projectors BEWARE!!!
    By katie.lawe in forum Bad Experiences
    Replies: 20
    Last Post: 21st October 2006, 08:41 PM
  3. Problem Sharing Epson Stylus D68
    By PsychoTech83 in forum Hardware
    Replies: 3
    Last Post: 7th June 2006, 11:52 AM
  4. Epson Stylus C62 drivers for XP
    By Preston in forum Windows
    Replies: 15
    Last Post: 21st March 2006, 04:15 PM
  5. Tips for unblocking Epson inkjets?
    By crc-ict in forum Hardware
    Replies: 17
    Last Post: 7th September 2005, 08:29 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •