+ Post New Thread
Results 1 to 4 of 4
Hardware Thread, Old RM Board Firmware in Technical; Hi All, I don't know if anyone can help but I am quite desperate for this. I could really do ...
  1. #1
    tomgrindle's Avatar
    Join Date
    Oct 2010
    Location
    Gloucestershire
    Posts
    204
    Thank Post
    53
    Thanked 17 Times in 14 Posts
    Rep Power
    22

    Old RM Board Firmware

    Hi All,

    I don't know if anyone can help but I am quite desperate for this. I could really do with some firmware for one of the first original RM Interactive Whiteboards. I presume that these were made by Promethean and just re branded. Can't really find anything on the net so wondered if anyone had anything in a archive anywhere etc?

    Many Thanks

    Tom

  2. #2

    Join Date
    Jul 2005
    Location
    Worthing, West Sussex
    Posts
    868
    Thank Post
    19
    Thanked 74 Times in 69 Posts
    Rep Power
    34
    IIRC, weren't the old RM Classboards re-branded Hitachi's?

    Could be wrong though.

  3. #3
    tomgrindle's Avatar
    Join Date
    Oct 2010
    Location
    Gloucestershire
    Posts
    204
    Thank Post
    53
    Thanked 17 Times in 14 Posts
    Rep Power
    22
    Ohhh I thought the RM ActivBoard's were just Promethean's with and RM sticker on them.

  4. #4

    Join Date
    Jul 2005
    Location
    Worthing, West Sussex
    Posts
    868
    Thank Post
    19
    Thanked 74 Times in 69 Posts
    Rep Power
    34
    Ah, I was thinking of RM Classboards - you may well be right about ActivBoards.

SHARE:
+ Post New Thread

Similar Threads

  1. Promethean Board Firmware
    By thor_it in forum Hardware
    Replies: 3
    Last Post: 9th March 2009, 04:49 PM
  2. Old RM
    By cst101 in forum Network and Classroom Management
    Replies: 0
    Last Post: 8th February 2009, 10:13 PM
  3. Old RM Desktops
    By MJoyeux in forum Hardware
    Replies: 3
    Last Post: 19th June 2008, 03:25 PM
  4. OLD RM Workstations
    By lovelldr in forum Hardware
    Replies: 10
    Last Post: 27th February 2008, 01:57 PM
  5. Problems getting old RM PC's to PXE boot
    By Kyle in forum Windows
    Replies: 7
    Last Post: 21st November 2007, 12:14 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •