+ Post New Thread
Results 1 to 5 of 5
Hardware Thread, Think it's broken :S in Technical; Am taking a look at a Toshiba laptop for a friend of a friend, and I think it's dead as ...
  1. #1

    Join Date
    Mar 2010
    Location
    Isle of Wight
    Posts
    28
    Thank Post
    1
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Think it's broken :S

    Am taking a look at a Toshiba laptop for a friend of a friend, and I think it's dead as a dead thing.

    By the sounds of things, it hasn't worked for a while (not sure why they waited till now to get it looked at). Basically, the battery doesn't charge, and I've discovered the laptop won't turn on running on mains (with no battery plugged in).

    The owner said she's tried another charger, but that made no difference.

    I think the main give away that it's the pin inside the charging port in the laptop is that when the mains lead is plugged in, the plug itself is bent at an angle as opposed to straight from the laptop.
    I've tried wiggling the cable to see if the power/charge light comes on (until this point it hasn't), but no joy. The cable seems to be able to move about 5mm in any direction.

    I'm not sure on the age of the laptop, but there's a big Vista sticker on it, so at a wild guess it's over a year old.
    Think it's time for a new motherboard, or new laptop :S
    Last edited by FunkMaster_J; 19th September 2010 at 08:18 PM.

  2. #2


    Join Date
    Mar 2009
    Location
    Leeds
    Posts
    6,579
    Thank Post
    228
    Thanked 853 Times in 732 Posts
    Rep Power
    294
    try ebay if your solderings up to it sockets can often be replaced

  3. #3

    glennda's Avatar
    Join Date
    Jun 2009
    Location
    Sussex
    Posts
    7,799
    Thank Post
    272
    Thanked 1,134 Times in 1,030 Posts
    Rep Power
    349
    Had a teacher bring me in a tosh before the summer hols - had problem with power supply not charging properly - it was the fact that the inside socket had been snapped and pushed in a bit to far - taking the laptop apart and glueing the plastic back where it was meant to be with the socket attached was all that was needed plus a reminder to be more gentle in future!

  4. #4

    Join Date
    Mar 2010
    Location
    Isle of Wight
    Posts
    28
    Thank Post
    1
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    The plastic that your talking about glennda looks ok, it's more the pin within the plastic socket that is bent.

    sted - I've not soldered anything since high school, but could be worth a go

    Thanks

  5. #5

    Andrew_C's Avatar
    Join Date
    Sep 2005
    Location
    Winchester
    Posts
    2,960
    Thank Post
    64
    Thanked 374 Times in 284 Posts
    Rep Power
    158
    I'd think that could be fixed with the will, and an offer of sufficient (quality) alcohol...

SHARE:
+ Post New Thread

Similar Threads

  1. Broken Projector
    By marsdenprimary in forum Promethean Direct Support
    Replies: 2
    Last Post: 19th July 2010, 11:17 AM
  2. [Fog] Broken after 0.29 upgrade
    By JJonas in forum O/S Deployment
    Replies: 12
    Last Post: 1st July 2010, 07:36 PM
  3. Google broken?
    By theeldergeek in forum General Chat
    Replies: 6
    Last Post: 11th September 2009, 10:24 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •