+ Post New Thread
Results 1 to 3 of 3
Hardware Thread, sanyo plc se20a help!!!! in Technical; i have a sanyo plc-se20a projector. went to switch it on this evening and it would power up, then about ...
  1. #1

    Join Date
    May 2010
    Location
    Plymouth
    Posts
    1
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    sanyo plc se20a help!!!!

    i have a sanyo plc-se20a projector. went to switch it on this evening and it would power up, then about 5 seconds later would power off (fans go loud for about 1 min then switches off) i have looked at various forums and the suggest problem is the heat (thermal) switch needs switching. the problem is i have no idea how to get to it, i have taken the case off to try and find the switch but no luck. but now the projector is not even powering up! the light isnt even comin on. any help would be much appreciated

  2. #2
    TechSupp's Avatar
    Join Date
    Mar 2007
    Location
    South Yorkshire
    Posts
    1,876
    Thank Post
    295
    Thanked 120 Times in 101 Posts
    Rep Power
    40
    Just had a Sanyo sent away for a similar problem (under warranty) and they eventually replied that it was a bulb fault (new bulb reqd) and not coveredby warranty so we are left with a 200+ bill to foot. Not ever be buying Sanyo again, its spent more time awaiting repair/exchange than installed! Less than a year old. Sticking to Epson where ceiling mounted anf Hitachi for short thow from now on. Iknow that does not help solve your problem but just letting you know others have had similar problems.

  3. #3

    Join Date
    Nov 2013
    Location
    Hastings
    Posts
    1
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Hello
    I know this was 3 years ago but do you remember if you ever got this sorted out? the reason I ask is that I have a customer that has bought one of these projectors in to us and it is doing the exact same thing and I'm fairly sure it's not the lamp (although that has gone off to be tested as only 2 months old), I have put the old bulb back in to try as well, as I don't believe that to have gone either as it was replaced due to the lamp light coming on and not the fact that it had blown, and the same thing just happens which makes me believe that this is a fault on the projector and I keep reading about a thermal switch ... But i cannot for the life of me see one, will I have to delve deeper in to the projector (i.e take off the top board!) to find it?!
    Thank you for anyone who replies!!

    Kind Regards

SHARE:
+ Post New Thread

Similar Threads

  1. Cleaning the Sanyo PLC-XE40 projector
    By Gromit in forum Hardware
    Replies: 77
    Last Post: 3rd May 2013, 09:05 PM
  2. Sanyo PLC-XE40 will not startup
    By Skinny in forum Hardware
    Replies: 5
    Last Post: 8th October 2010, 02:33 PM
  3. Do you have a Sanyo PLC-XW200?
    By Little-Miss in forum Hardware
    Replies: 0
    Last Post: 27th January 2010, 03:32 PM
  4. Quote for replacement lamp for sanyo PLC-XE40
    By bladedanny in forum Our Advertisers
    Replies: 5
    Last Post: 5th November 2009, 09:01 AM
  5. Replies: 5
    Last Post: 10th April 2008, 09:11 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •