+ Post New Thread
Results 1 to 15 of 15
Hardware Thread, Acer Laptops - Cursor Jumping around whilst typing typing. in Technical; Were having a problem with all of our Acer Laptops (5720/5630ez) where when staff are typing on them the cursor ...
  1. #1
    mbird's Avatar
    Join Date
    Feb 2010
    Location
    High Wycombe
    Posts
    190
    Thank Post
    51
    Thanked 21 Times in 16 Posts
    Rep Power
    40

    Acer Laptops - Cursor Jumping around whilst typing typing.

    Were having a problem with all of our Acer Laptops (5720/5630ez) where when staff are typing on them the cursor will jump backwards - meaning when there typing it goes up a paragraph, or across a few cells in a excel spreadsheet.
    Anyone heard of this before/Know how to fix it?
    As acer aren't particularly helpful and i don't really want to send 50 laptops back ....

    mb

  2. #2
    Jamo's Avatar
    Join Date
    Jan 2009
    Posts
    1,354
    Thank Post
    66
    Thanked 175 Times in 147 Posts
    Rep Power
    60
    Usually due to people touching the touchpad lightly during typing. Try seeing if the laptops have a 'disable the touchpad' button, sometimes it is just a square symbol.

  3. #3
    mbird's Avatar
    Join Date
    Feb 2010
    Location
    High Wycombe
    Posts
    190
    Thank Post
    51
    Thanked 21 Times in 16 Posts
    Rep Power
    40
    they don't unfortunately, a teacher did say they used there pointers to type (thus avoiding the touch pad) and it still happened

  4. #4
    Jamo's Avatar
    Join Date
    Jan 2009
    Posts
    1,354
    Thank Post
    66
    Thanked 175 Times in 147 Posts
    Rep Power
    60
    Have you 'massaged' around the touchpad to see if its loose connections on behalf of the touchpad cable?

  5. #5
    mbird's Avatar
    Join Date
    Feb 2010
    Location
    High Wycombe
    Posts
    190
    Thank Post
    51
    Thanked 21 Times in 16 Posts
    Rep Power
    40
    I haven't no - sounds interesting. How do i massage the touch pad?

  6. #6
    Quackers's Avatar
    Join Date
    Jan 2006
    Posts
    1,350
    Thank Post
    41
    Thanked 146 Times in 121 Posts
    Rep Power
    54
    We have had this on other laptops, like the HP 530. Make sure they have the synaptics mouse driver installed (or equivlennt), then in the utility there is a sensitivty setting, to stop it happening.

  7. #7
    Jamo's Avatar
    Join Date
    Jan 2009
    Posts
    1,354
    Thank Post
    66
    Thanked 175 Times in 147 Posts
    Rep Power
    60
    Quote Originally Posted by mbird View Post
    I haven't no - sounds interesting. How do i massage the touch pad?
    haha just press around the touchpad to see if its pressure on the face plate that is causing it. Post above is v correct about sensitivity, this can cause issues where leaning on the faceplate can cause a mouse press. Reducing sensitivty may sort some of the issues out.

  8. #8


    Join Date
    Feb 2007
    Location
    Northamptonshire
    Posts
    4,692
    Thank Post
    352
    Thanked 797 Times in 716 Posts
    Rep Power
    347
    Yes, this happens on my acer work laptop and it is an absolute pain in the backside.

    I disabled the touchpad and use a mouse now, it's just easier and less dramatic than crying when you completely type the wrong stuff into a terminal.

  9. #9


    Join Date
    Feb 2007
    Location
    51.403651, -0.515458
    Posts
    9,058
    Thank Post
    231
    Thanked 2,716 Times in 2,004 Posts
    Rep Power
    794
    TouchFreeze perhaps?

  10. 2 Thanks to Arthur:

    mbird (15th March 2010), SimpleSi (12th March 2010)

  11. #10

    SimpleSi's Avatar
    Join Date
    Jun 2005
    Location
    Lancashire
    Posts
    5,822
    Thank Post
    1,476
    Thanked 593 Times in 445 Posts
    Rep Power
    168
    I thought it was just me doing something wrong when I was using mine

    Good job I've ordered mice to go with the 15 I've just ordered!

    regards

    Simon

  12. #11
    Ben-UK's Avatar
    Join Date
    Jan 2010
    Location
    Nottingham
    Posts
    40
    Thank Post
    6
    Thanked 2 Times in 2 Posts
    Rep Power
    10
    This happens on my Acer laptop (model 6930G), although its only started happening since i installed win7pro64bit which i find strange. Never happen on vista which i had installed for 8 months.

    It is real pain in the ass though !

    Would love a fix

  13. #12


    Join Date
    Feb 2007
    Location
    51.403651, -0.515458
    Posts
    9,058
    Thank Post
    231
    Thanked 2,716 Times in 2,004 Posts
    Rep Power
    794
    Just came across the following AutoHotKey script that does the same thing as TouchFreeze (but more reliably according to the comments).

    DisableTrackpad.ahk
    Code:
    ; Source: http://productivegeek.com/forums/topic/touchfreeze-alternative-in-ahk#post-1548
    ; v1.0 2010-02-23 Original Release
    ; v1.1 2010-02-25 Added user configuration section
    ;                 Added option to block mouse clicks
    ;                 Added option to omit blocking for shift, ctrl, alt, win keys
    
    #NoEnv  ; Recommended for performance and compatibility with future AutoHotkey releases.
    SendMode Input  ; Recommended for new scripts due to its superior speed and reliability.
    SetWorkingDir %A_ScriptDir%  ; Ensures a consistent starting directory.
    
    ; User configuration
    DisableTime := 500 ;in milliseconds
    BlockMouseMove := True
    BlockLeftClick := True
    BlockMiddleClick := True
    BlockRightClick := True
    AllowShift := True
    AllowCtrl := True
    AllowAlt := True
    AllowWin :=True
    
    ;keyboard hook code credit: http://www.autohotkey.com/forum/post-127490.html#127490
    #Persistent
    OnExit, Unhook
    
    ;initialize
    hHookKeybd := SetWindowsHookEx(WH_KEYBOARD_LL   := 13, RegisterCallback("Keyboard", "Fast"))
    Hotkey, LButton, DoNothing, Off
    Hotkey, MButton, DoNothing, Off
    Hotkey, RButton, DoNothing, Off
    Return
    
    DisableTrackpad:
    ShiftActive := AllowShift && GetKeyState("Shift")
    CtrlActive := AllowCtrl && GetKeyState("Ctrl")
    AltActive := AllowAlt && GetKeyState("Alt")
    LWinActive := AllowWin && GetKeyState("LWin")
    RWinActive := AllowWin && GetKeyState("RWin")
    if (!ShiftActive && !CtrlActive && !AltActive && !LWinActive && !RWinActive)
    {
       if (BlockMouseMove)
          BlockInput, MouseMove
       if (BlockLeftClick)
          Hotkey, LButton, DoNothing, On
       if (BlockMiddleClick)
          Hotkey, MButton, DoNothing, On
       if (BlockLeftClick)
          Hotkey, RButton, DoNothing, On
    }
    Return
    
    ReenableTrackpad:
    if (BlockMouseMove)
       BlockInput, MouseMoveOff
    if (BlockLeftClick)
       Hotkey, LButton, Off
    if (BlockMiddleClick)
       Hotkey, MButton, Off
    if (BlockLeftClick)
       Hotkey, RButton, Off
    Return
    
    DoNothing:
    Return
    
    Unhook:
    UnhookWindowsHookEx(hHookKeybd)
    ExitApp
    
    Keyboard(nCode, wParam, lParam)
    {
       Critical
       If !nCode
       {
          Gosub, DisableTrackpad
          SetTimer, ReenableTrackpad, %DisableTime%
       }
       Return CallNextHookEx(nCode, wParam, lParam)
    }
    
    SetWindowsHookEx(idHook, pfn)
    {
       Return DllCall("SetWindowsHookEx", "int", idHook, "Uint", pfn, "Uint", DllCall("GetModuleHandle", "Uint", 0), "Uint", 0)
    }
    
    UnhookWindowsHookEx(hHook)
    {
       Return DllCall("UnhookWindowsHookEx", "Uint", hHook)
    }
    
    CallNextHookEx(nCode, wParam, lParam, hHook = 0)
    {
       Return DllCall("CallNextHookEx", "Uint", hHook, "int", nCode, "Uint", wParam, "Uint", lParam)
    }

  14. #13
    Ben-UK's Avatar
    Join Date
    Jan 2010
    Location
    Nottingham
    Posts
    40
    Thank Post
    6
    Thanked 2 Times in 2 Posts
    Rep Power
    10
    Thanks for that.

    Just set it up, will see how it performs

  15. #14

    Join Date
    Jan 2009
    Posts
    104
    Thank Post
    6
    Thanked 27 Times in 24 Posts
    Rep Power
    21
    to disable the touchpad on the 5720, you only have to press Fn + F7. I accidently hit this once and spent three hours trying to fix my touchpad!

  16. #15

    Join Date
    Apr 2014
    Location
    Philadelphia
    Posts
    1
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Quote Originally Posted by crt404 View Post
    to disable the touchpad on the 5720, you only have to press Fn + F7. I accidently hit this once and spent three hours trying to fix my touchpad!
    Wow, that was too easy! There it was, staring me in the Fn face all this time! Thanks.

SHARE:
+ Post New Thread

Similar Threads

  1. Network Typing Tutor
    By dave.81 in forum Educational Software
    Replies: 1
    Last Post: 1st March 2010, 12:32 PM
  2. Cursor jumping in text boxes
    By zag in forum Windows 7
    Replies: 0
    Last Post: 9th September 2009, 10:00 AM
  3. The skills of typing
    By callumtuckey in forum General Chat
    Replies: 18
    Last Post: 9th October 2007, 09:01 AM
  4. Typing Tutor Software
    By rlculver in forum General Chat
    Replies: 9
    Last Post: 28th August 2007, 02:10 PM
  5. Touch Typing
    By enjay in forum How do you do....it?
    Replies: 20
    Last Post: 15th June 2007, 12:01 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •