+ Post New Thread
Results 1 to 2 of 2
Hardware Thread, Sanyo plc-xe40 in Technical; Hi, the lamp was flashing red so I replaced it but now the projector will not switch on??.....it goes green ...
  1. #1

    Join Date
    Apr 2014
    Posts
    1
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Sanyo plc-xe40

    Hi,

    the lamp was flashing red so I replaced it but now the projector will not switch on??.....it goes green for 20 seconds and then switches to red....I have cleaned it, reset, reset the thermal but still nothing....have any ideas

  2. #2

    Sylv3r's Avatar
    Join Date
    Jul 2005
    Location
    Co. Durham
    Posts
    3,268
    Thank Post
    380
    Thanked 388 Times in 343 Posts
    Rep Power
    150
    We've had similar issues. Something to do with the Projector's ballast I believe. Cost us around £100 for repair.



SHARE:
+ Post New Thread

Similar Threads

  1. Cleaning the Sanyo PLC-XE40 projector
    By Gromit in forum Hardware
    Replies: 77
    Last Post: 3rd May 2013, 10:05 PM
  2. Sanyo PLC-XE40 will not startup
    By Skinny in forum Hardware
    Replies: 5
    Last Post: 8th October 2010, 03:33 PM
  3. Quote for replacement lamp for sanyo PLC-XE40
    By bertster in forum Hardware
    Replies: 0
    Last Post: 7th September 2010, 01:01 PM
  4. Sanyo PLC-XE40 Projector Not Starting Up
    By avr34 in forum Hardware
    Replies: 0
    Last Post: 28th August 2010, 11:35 AM
  5. Quote for replacement lamp for sanyo PLC-XE40
    By bladedanny in forum Our Advertisers
    Replies: 5
    Last Post: 5th November 2009, 10:01 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •